Problems connecting your new Homey Pro to your WiFi? Try this!

  1. Make sure your WiFi is using the 2.4 GHz network.

  2. Make sure your WiFi uses the b / g standard, only n or ac does not work.

  3. Turn off your Homey.

  4. Restart your Router and any Access Points that distribute IP addresses.

  5. Start your Homey again.

  6. If the above do not work, turn off 5 GHz WiFi and support for n and ac in your Router / Access Point during Homey installation.

  7. Ensure that your SSID (the name of your WiFi) does not use characters other than numbers and letters - do not use åäö or other special characters.

  8. If you have an extra mobile phone, switch off your router and share WiFi from your mobile phone with the same SSID and password that your router uses. Connect Homey to that network and then start up your router again and turn off the WiFi sharing from your mobile, Homey should then kindly use your regular WiFi.

  9. If your are still unable to connect, try changing the USB power supply, make sure the new one can handle a minimum of 2.4 Amp.

Once you get it to work you should be able to turn 5 GHz, n and ac back on again in your Router / AP’s.

And while you’r at it it’s a good idea to assign your Homey a fixed/static IP address in your Router.

4 Likes

Homey doesn’t support it, there is no setting for that. And i don’t want to do that in my router, don’t want static addresses in my DHCP pool…
So if it’s recommended, why isn’t this a setting in Homey itself?

Am…

O. K…

… Interesting…

Can’t even think of how to explain what’s wrong with that statement

Because I think you can only make static addresses from your DHCP server I quess?
And homey is not a DHCP server

If I make a DHCP reservation for a device in my router, this ip adres is automatically excluded from the range.
Why is this not preferred for you? Also, does your dhcp pool start at the first available address? Maybe you can make a reservation outside of the pool? (to clarify; if the first ip adres of the dhcp pool is 192.168.1.50 and the last one is 192.168.1.254 you can make a reservation for 192.168.1.10 )

1 Like

I know it get’s excluded. But that’s the point: reservation occurs on the already supplied DHCP address, thus in the DHCP pool. And I explicitly don’t want that.

My point is: if it is recommended by the manufacturer (which i completely understand), then make it possible in the device and don’t force customers to have to poke around in their router configuration.

You and I know how to do it, but most of the “normal” customers don’t even know how to get into their router…

First, it was not Athom that recommended using static IP address for Homey, it was all me!

Second, this is a community forum and almost never the voice of Athom. My advice comes from helping hundreds of ppl with issues where a static IP address somewhat helped minimize the issues.

But you are free to continue to use a dynamic IP address :blush:

2 Likes

I understand your point, it is weird you cannot provide a static ip adres in the device.
But it is also a bit weird that you cannot join another wifi network from the interface. But it is foolproof, if homey doesnt connect to the wifi, reset the device and join again.

About the DHCP: if a device does a DHCP request, it will provide the previous adres. If a DHCP server gives a DHCP offer it will provide the stored ip adres. Sooo… if you don’t reset the homey and your router at the same time, your device will keep the same ip address.
Second thing about DHCP servers: If you make a static dhcp reservation with an ip address outside of the dhcp pool the dhcp request gets denied and a dhcp offer with the static reservation will be sent to the device. devices are not aware of dhcp scopes and exclusions so will happily accept the ip adres given by the server.

I have problems connecting to my WiFi. I have tried to resolve it using advice 1-6. My SSID is “Melinda_24GHz”… Changing SSID is not a small issue. All my stuff needs to be reconnected… Is it really necessary to exclude special characters? And why is this even an issue for Homey? BR Henrik

Hi Henrik.
The troubleshooting suggestions is quite general when it comes to WiFi problems, Homey have no issues with WiFi most of the time but to minimize the number of problem sources I often ask ppl to remove special characters. Sometimes that has turned out to be the problem, mostly not.

Have you tried connecting Homey to a mobile phone WiFi?

Hi Johan,

It turned out to be the special character that was the problem. Many thanks!

However, I strongly suggest you guys include these advice in your Q&A more visably. It took a while before I found this. I spent many hours trying and trying…

All the best / Henrik

1 Like

Thanks for tipps.
Finally got my working .

Could also add tips to use correct USB power source.
I couldn’t get my to recover until I change ac/dc plug/ charger. And it finally got pass orange led mode and where able to recover.

Any workaround for static ip address option in Homey please?

Static address can be done in your router

Hi,

Since few days I switch to Ziggo. No I can not reconnect my Homey anymore. I did all the steps above but none of this works. In step 8 I can see that Homey is connected to my phone for a few seconds and then it’s gone and Homey says: Sorry, ik kan niet verbinden met dit netwerk.

  • I turned off 5 GHz and turned on 2.4GHz.
  • I used b/g/n standard
  • Turned off my Acces point
  • SSID is only characters
  • I use IPad addapter

Can you please help what steps are further left?
(mag ook in het Nederlands)

Groetjes Sander

Can you see homey by connected Devices?

Not in my router. It didn’t appear.
When I used my phone for Hotspot I saw it connected for a few seconds, then it was gone

This is a issue multiple users have had.
I’m writing this in case it helps others…

I just tried to setup my new Homey, and also had a lot of issues with it.
I have tried turning of 5 GHz on my Wifi, and changeing 2.4 GHz to only use G/B with no luck (This is mentioned in Homey’s support page).
I tried turning of my wifi, creating a new mobile hopspot with same SSID and password, also no luck.
Tried reboot and reset the Homey a few times.
Tried to setup the unit from a Chrome browser on my laptop.

All of the above has been testet without luck a few times.
After the last reboot it connected without any problems at all.
Strange this issue is still on the unit after a few years…

On top of doublechecking that your wifi supports 8.11 b/g (2.4 GHz), could you please check whether you are using a mesh wifi system?

Sometimes some wifi devices have some issues when connecting to mesh systems, especially the old ones that are only able to work at 8.11 b/g

I have a mesh system at home and I don’t have issues with Homey but still you might want to check (I have had some issues with other devices).

A test should be easy, just switch off all your mesh devices except the main one, just having homey closed to it, restarting first the wifi device and homey afterwards.

I’ve bought a new Homey Bridge a few days ago and still have these connection Problems. I checked anything mentioned in this forum. Is there any help a few month later?