Troubleshooting Homey Early 2019

I own a Homey early 2018.
I have felt it to be more and more slow and unresponsive over time.
Both Ikea and Philips HUE apps takes over 15 seconds to respond to a change of state.
And all devices seems to lock if I try to switch two or more times in a row with only seconds between.
I have around 60 devices now.

Have 18 apps right now, but only 2 of them using more then 20mb of memory, Influxdb and Mqtt Hub.
System memory is about 120mb almost all the time.

None of the apps use any significant amount of CPU, almost 0% all the time.
System uses max 6% CPU overall.

It got a little better after rebooting the Homey every night but far from OK. Now the Ikea Gateway app works almost every time with a delay of 15+ seconds. Before I restarted Homey every night, the Ikea Gateway didn’t respond at all from time to time.

If anyone endured to read through my too long post, thanks! I have a few questions.

  1. Are there anyone else out there with the same problem as me? did you solve it? How?
  2. Does is work for anyone else with Homey early 2019 with 60 devices? I’m I suppose to upgrade tp Homey Pro?
  3. How can I get the graph as you show in this post memory graph?

I have tried to search the forum for days now without solution, please help.


That is gonna be trial and error I think.
What if you disable as much apps as possible, except Ikea & Hue.
See if the responsetimes get better.
If so, enable other apps one by one, to see where it goes slow.

What are your zigbee channel numbers of Hue bridge, Ikea hub and Homey zigbee?

Go to…More>Settings>General and wait for a while.

In Insights you can view the history also per app.

Hi Peter_Kawag!

Thanks for the help.
I did have overlap on Wifi and Zigbee for Homey and for Ikea, all was on 11 and 1, now changed it to:

  • Zigbee on Homey: 11

  • Zigbee on Hue: 25

  • Zigbee Ikea: 11

  • Wifi Sonos: 11

  • Wifi 2.4GHz: 6

I really tried to change Zigbee on Homey, but it didn’t take, maybe there is something wrong with that?
I will test to see if it help somewhat.

About the memory graph.
I’m I right if I say that the graph that they show on this link is not available anymore. I knew about the Insights but I wanted to find the one where you see them as a bar.

Another problem that I have with Homey is that I almost always get that it is offline when I try to access it, either via the app, or computer or Developer Tools.

YW, Jimmy,

That can be a timeconsuming process (sometimes like hours).
If you have a homey ball, changing zigbee channel should be possible.

I’ve never seen it with a horizontal bar. Probably a legacy desktop app showed it.

I hear this every now and then. I think your wifi setup is to “modern” for Homey.
Dualmode f.i. can get Homey unresponsive.
This might come in handy: Problems connecting your new Homey Pro to your WiFi? Try this!

Have you tried a new Power supply? I had the same experiences, but I have changed the original Power supply with an iPad supply (2.1A) and that helped me.

I will try that!
I actually had a 2.0A, bit I switched to a 3.0A and we will see.

Didn’t work, to bad :frowning_face:
Still get connection errors from time to time.

Try rebooting the router instead, see if that helps.
My tp-link it’s cache/routing tables fill too quick and made homey sluggish and on every reboot it acts normal.
Now I installed a raspberry pi with pihole and it’s DHCP server it all runs better.