My new out of the box Homey-Pro will not connect to my WiFi

Looks like it might be possible with a workaround: https://www.reddit.com/r/orbi/comments/pd2vxg/how_to_disable_5ghz_wifi_on_firmware_update_v27322/hapfrl2/

Even at 50% braodcast power for 5GHz Homey disconetted. :rage:
Let’s try if 25% will result in a stable connection with Homey and no loss of bandwith for my other devices. :crossed_fingers:

That’s no solution, even if it works it’sa bad solution in my opinion

1 Like

Sure, but what’s the alternative? Athom’s not willing (or able) to fix these issues so people have to work around them.

1 Like

A (better) solution would be to create a dedicated network/ ssid for iot on 2.4 ghz only. I fully agree this is to silly to be real, and silly is putting it mildly. But don’t have any confidence athom is able to solve this and by crippling your normal network, just feels wrong.

1 Like

MESH d
networks can certainly cause some trouble

All they had to do was make one with ethernet

A decent WiFi implementation would be fine too for me. Roaming, 5ghz, stable…. Shouldn’t be so hard nowadays.

1 Like

At the moment both Homey and all other equipement seems to work properly with the 25% broadcast power for 5 GHz. That was 100% power

1 Like

I wonder how possible it would be to improve the network firmware?

Unless you’re Athom: not.

If the situation is exactly, as described above - then suspecting, that even firmware is not sufficient. I bet on hardware.

Yes, in theory it’s possible improve some SDR firmware algorithms to fight against the inductions… but this all is a theoretic philosophizing.

In practice… first of all, i’d attempt to find some other location for Homey. Even half meter[1] may change the game drastically. Not so good for final solution, but the 3 cm move may also give a sign (5Ghz wavelength ~6cm - half=>3cm). Yeah, not so final-good, as 3cm back-move can be happened very randomly :wink:

[1] RF weakening by square of the distance…

1 Like

I recently bought the same Asus XT8 set and had some problems at first. Since updating the routers firmware to the latest beta, I had no problems anymore. I left WiFi 6 and Smart Connect on, so I have 1 combined SSID for all WiFi bands. Works flawlessly now!
I even activated the second 5GHz band for connecting clients since I wired both nodes.

Changelog of the XT8 beta firmware says it solved issues with IoT compatibility.
See:

1 Like

Not saying Athom/Homey isn’t at fault in some way for this, but it isn’t Homey that is disconnecting from 2.4GHz when the 5GHz radio is switched from 50% to 100% power. Homey does not have a 5GHz radio so there is no way Homey could tell at what power 5GHz is transmitting.

What happens is that the Mesh router kicks Homey of 2.4 thinking it supports 5GHz and will do better when it reconnects to that, only it doesn’t because it can’t. Some routers have options to disable that behavior for certain devices so maybe your router does too?

In that case any 2.4Ghz device would be kicked off the network, and that would be a major bug. Band steering only works when clients explicitly tell the router it supports both 2.4Ghz and 5Ghz, so if the mesh router thinks Homey supports 5Ghz it was told it does by Homey itself (although I doubt that this is the actual issue, it’s more likely that Homey gets confused by the mesh arrangement).

Hi Guys,

Is this still ongoing.
I have a brand new Homey Pro (2019) from Athom and am having a similar issue. Where it will fall off my wifi for hours or untill I restart it or the router.

Seperate 2.4 and 5ghz said names.
Wireless power set to 50% on both.

I have had a Homey (2016) and (2019) and they have operated fine. Is this a hardware issue with new wifi chip in Pro (2019) or could I just have a dud?

Cheers
Gary

Set 2.4 wireless power to 100% maybe?

This hardware isn’t smart enough to utilise the below features for a 2.4Ghz network?

  1. WiFi Agile Multiband
  2. Target Wake Time
  3. Various WMM Settings?

Already done. Plus it has been moved from right beside to 10 metres away.

Temporary turn 5GHz off while trying to add Homey.
More hints: