Problem connecting to brand new Homey Pro

Hello all,

I have just bought my first homey and was very excited to receive it yesterday. I plugged it in and set it up using the instructions from and it seemed to work fine - it found my wifi, connected ok (blue light whilst connecting then green light) downloaded some software and its voice then rebooted and a rainbow led ring showed. I then went to the app on iPhone and it can’t find my homey and says it’s offline. I tried through the app on iPad and the same thing.

I then read some of the threads on here and tried the following over the course of the day:

  • rebooting homey (turning it upside down) and resetting it using safari browser on iPhone 10;

  • rebooting homey and resetting it using safari browser on iPad Pro (this didn’t work as it wouldn’t connect to my wifi with this method - the browser instructions seemed to think I was using an actual Mac which I wasn’t);

  • rebooting homey and resetting it using chrome browser through a windows laptop;

  • rebooting homey, deleting it from the app and doing a complete factory reset;

  • rebooting homey and using an iphone hotspot as the wifi connection with the same details as my wifi router then turning the hotspot off and rebooting homey and the router (as set out in some of the community forum suggestions);

  • turning off the 5ghz SSID from my router (although the 2.4ghz and 5ghz have different SSIDs);

  • moving my homey to right next to the router; and

  • trying different plug sockets (although the most powerful one I have spare is a 2A one, and the one supplied with the homey is 2.1A I believe).

Nothing makes a difference. I also did a few ptps as well. I thought I’d leave it overnight to see if anything miraculously happened but it’s still the same this morning.

Just to be clear - my homey connects to the wifi absolutely fine when it is in setup mode (apart from when using the iPad to do so) but after it finishes setup and restarts itself each time it then won’t connect. It shows as a connected device however in my router information panel. When saying “Ok homey” it says “oops I couldn’t reach the server, please try again later”. And it appears as offline in the app on iPhone, iPad, and through the web and developer apps.

I’ve sent a note to the support email address but thought I’d send a post here in case anyone has any tips at all?

One other thing I wasn’t sure of - on the setup procedures and when homey talks to you when it’s first set up it does talk about downloading the desktop app which I don’t seem to be able to find and think has been replaced by the mobile app?

Thanks in advance for any tips!

Sad to hear this ‘experience’. I see you’ve read a lot of info. The only thing I can think of is a. Your wifi is bad or b. Your Homey is defect.

Thanks Peter. My wifi is otherwise fine - everything else connects to it and works ok (both on the 2.4ghz and the 5ghz SSIDs - although I know homey only works on the 2.4ghz one).

Perhaps it is indeed option b - I have a dud homey. Hopefully support will reply to me shortly to confirm this and can arrange a new one to be shipped to me (or I return it to the supplier I got it from). Very disappointed so far, but hopefully it’s an easy fix - either I’ve done something stupid someone here can tell me or I just need a new one.

This looks like an original Homey with microphone ENABLED running on the original Firmware v1.5.x.
That firmware and speech isn’t supported anymore Service Announcement - Homey v1.5 is now end-of-life
According to my latest info it should still be posible to upgrade it from the “new” mobile App but it looks like there is no correct connection with your account to start that Firmware upgrade. Might be some bug if first time setup is still on FW 1.5.

You can stop trying other things as a qualitative stable adapter of 2.0 A should be fine, as also is your WiFi.
Just leave it powered on, and wait for contact of Athom Support.

If it is a v1.5.x, could he connect to it locally with a web browser?

if he knows the bearer token … so nope.

1 Like


Note to self: Reading is an art. In my mind he bought himself a brand new recent Homey :hugs: .

According to Athom it is unlikely but he should deffinetly contact support.
Mic was disabled probably later…

I think you have done everything I can think of, including describing what you did.
just to be sure:

  • You don’t have something blocking internet access on your network (Pi hole or WiFi Isolation)
  • is it a Homey or a Homey Pro? What was the Product ID on the box? HOMEY-??-??

just forget the Desktop App,
after connecting WiFi and setup with an account you should be able to see it in the mobile app on the same account, and on / while logged on with the account to connect.

Contact Support and tell (write) them above info,

1 Like

5 posts were split to a new topic: Problem Homey Bridge Not Connected