Homey Pro doesn’t connect to 5 GHz WiFi 5 (Ubiquiti)

Hi. I’ve just purchased a Homey Pro.

Can someone help me understand why it won’t connect to my Ubiquity WiFi 5 network? It sees the SSID, but refuses to connect. It does connect to the 2.5 WiFi.

Are there any gotchas that I need to know about?



First, welcome to the forum!

It may be the new wifi driver in latest firmware. Its sensitive for certain channels it seems.

Could you please disable “auto-channel” for the 5 GHz network and select channel 36, 40, 44, 48, 149, 153, 157, 161 or 165.

Thanks for the quick reply. I’ll give that a go. (Looks like it needs another upgrade to 10.1.4 first!)

Ok. Call me stupid, but I can’t see anywhere where to change the network settings.

You checked the setup of your router?

Hey SingKT, I’m talking about the WiFi configuration of the Homey, not my local WiFi network.

@DrChaos I think that @To_Lou means the settings of the router.


Oh. Well that’s not possible. I’ve got four access points in a mesh, and they are spread across the spectrum to avoid the neighbours frequencies.

The homey is the only device that doesn’t connect to it. It must be a bug. It’s really unusual to have WiFi issues in this day and age. Are they responsive to bug requests? Their web site says they have a three week queue for support requests which can’t be right, can it?

Isn’t it possible to turn three of them off, add Homey and then turn the other three on again. I thought it was possible to connect to a selected device of the mesh network.
I thought I have read somewhere over here that Homey has a problem to choose a device in a mesh network.
Also turn of 2.4GHz while connecting to the 5GHz if they have the same SSID.

Hmm, that is not what it says:

They say, expect a response in 3 weeks, not “it takes us three weeks to respond”
One of the reasons probably is to prevent users asking for updates all the time (which causes the response times to grow longer and longer).
Of course they prioritize the incoming issues.

Yep, it’s really odd. Please report this bug. Be aware Homey’s wifi implementation has been very picky very since the first model from 2016 :no_mouth:. In other words, don’t expect anything, or just buy the ethernet dongle (yeah finally there’s ethernet available for Homey).
Try to use 2.4GHz only. I don’t think the speed advantage of 5GHz wifi is needed at all.
And after connecting, force Homey to use only one of the AP’s, by band steering, MAC filtering or transmit power settings
Also reserve an IP address for Homey @ DHCP server.

I’ve got 4 mesh devices, and they are all nailed to 80MHz band widths, on base channels 36, 52, 100 and 116.

It is, the Raspberry Pi module that Homey uses has issues with certain WiFi networks. So far, no resolution (other than, possibly, changing the WiFi channel), because it depends on some sort of third party closed firmware (see this bugreport, “hmeerlo” is an Athom employee).

1 Like

While I suspect you are talking about the 2023 Homey Pro, if you have bought early 2019 version (white ball) then it doesn’t support 5Ghz.
Is your UniFi controller showing Homey in the devices tab?
For interests sake this is my 2019 Homey on Unifi
Channel1 (2.4 GHz, 20 MHz)
Signal -26 dBm
AP/Client Signal Balance good
Standard WiFi 4

It’s the ‘23 version. I’ve reorganised my 2.4GHz WiFi and am using that now with Homey. I might get an Ethernet adapter, but I need to move all the zwaves first before I put it somewhere with an Ethernet socket.

Thanks for that. It must be frustrating for them! I run an ISP so have had thousands of customers myself who depend on sometimes flakey WiFi too.

I can recommend this one. It’s rock solid

Please can you share which unifi devices you use for mesh?

I’ve got four UniFi AP AC LITE modules.

1 Like

Thanks. That looks like half the price of the homey official one.

My Homey Pro 2023 is on the 5ghz band on my ubiquity
LR6 connected to USW light and UDMPro