My new out of the box Homey-Pro will not connect to my WiFi

I have Ziggo internet cable - Ziggo Router in bridge mode - Netgear Orbi50 with 4 (wired) Wifi AP (up to 500 Mbps Wifi); Works flawless.

With iPhones, iPads, wifi printers, business (Windows) laptops, Music systems, Robo Vacuum cleaner (switching couple of times a month to another wifi network and back using the same connection method as Homey).

One SSID for both 2.4 (auto channel) and 5.5GHz (channel 36) / Strong Password

Homey is in the middle of my house with 200-300 MBps WiFi speed.

I started as indicated via the Homey app. Blue light circling around and No connection.

I also tried with the web variant via (Safari and Chrome) using the option trick.

First to the intended WiFi network as mentioned above with resetting every piece of equipment several times

Second to a iPhone hotspot setup with the credentials above

Third to a iPhone hotspot with the simplest possible credentials (12345678 / 12345678)

Forth scenario: I used an older Netgear Wifi AP (connected to internet). I first reseted it to factory setting and the enabled Wifi with and without any security.

And again and again the Homey says that connecting to WiFi did not work

I have tried to reset the H-Pro to factory settings (maybe I have a 2nd chance ?) Then you should hear a countdown; That doesn’t happen and nothing happens at all.

What did I miss?

What are the minimal requirements from Homey for a WiFi network settings? I can’t find this.

Thank you in advance for your help.

Homey only supports 2.4ghz, no 5ghz. Experiences are best when there is a dedicated 2.4ghz network so Homey itself doesn’t have to figure things out.

What @Martijn_Hoogenbosch says…

Try disabling 5GHz wifi temporarily. After succesfull connection by Homey, you can enable it again (that worked for me).
Also try using Firefox as browser.

Same problem with ny brand new Homey Pro (one week old). At the initial setup, I didnt see the Wi-Fi SSID, but had to Split 5 GHz and 2.4 GHz with their pen SSID, theb disable all the fancy new functions for the Asus XT8, do the router is like a old 2010 router. Needed also get a new power adapter with more juice. That fixed the somr of problem Wi-Fi connection.

I get connected, but Homey Losses connection all the time. Have to disconnect power from homey, reboot Wi-Fi and connect homey to power again.

Ive noticed that if I have any apps that Athom created, the Homey Wi-Fi losses connection. But if i remove all Athom apps, homey pro is stable and connected to my Wi-Fi…

Thats so wierd that the apps from producers of the product makes the Homey Wi-Fi Crash and not reconnect…

Im also wondering if they have changed some hardware in the product, because og the pandemics chip-shortage to have a product to the customers. New chips from an other producer will have impact om stability of the product and its code.

Doesn’t sound like the same problem then.

Did a edit, its the same problem at start. And extended the problem after the Ive got it connected (after about 1 day with switching Things on/of on the router)…

It shouldnt be so hard to get a unit like this to connect to a Wi-Fi nettwork that has 2.4 and 5 GHz antenas.

After a lot of additional trying:

  • I can’t switch off only 5 GHz
  • I reduced the broadcast power for 5GHz to 25%
  • Then Homey was willing to connect. :thinking:
  • After putting the 5Hz back to 100% Homey disconneced :angry: :rage:
  • For now I reduced 5GHz power to 50%
    Hopefully my Wifi throughput for all other sdevices doesn’t drop.

This has cost me almost 6-8 hours before I could switch on just my very first lamp.
Unbelievable for a Eur 400,- product !!

What’s unbelievable too is not being able to switch off 5ghz.


What I have read somewhere this is because of Mesh !?

1 Like

Looks like it might be possible with a workaround:

Even at 50% braodcast power for 5GHz Homey disconetted. :rage:
Let’s try if 25% will result in a stable connection with Homey and no loss of bandwith for my other devices. :crossed_fingers:

That’s no solution, even if it works it’sa bad solution in my opinion

1 Like

Sure, but what’s the alternative? Athom’s not willing (or able) to fix these issues so people have to work around them.

1 Like

A (better) solution would be to create a dedicated network/ ssid for iot on 2.4 ghz only. I fully agree this is to silly to be real, and silly is putting it mildly. But don’t have any confidence athom is able to solve this and by crippling your normal network, just feels wrong.

1 Like

networks can certainly cause some trouble

All they had to do was make one with ethernet

A decent WiFi implementation would be fine too for me. Roaming, 5ghz, stable…. Shouldn’t be so hard nowadays.

1 Like

At the moment both Homey and all other equipement seems to work properly with the 25% broadcast power for 5 GHz. That was 100% power

1 Like

I wonder how possible it would be to improve the network firmware?

Unless you’re Athom: not.