[Info] USB Power Supplies and cables (for Homey Pro Early 2023)

USB Power Supplies and cables

This test is performed due to the email send by Athom after the first shipment of the new Homey’s

  • The first shipment has received a power adapter which unfortunately makes Homey Pro’s CPU underclock. Read the e-mail here »

But also for users that have to replace their adapter or cable in the future. And I have read a lot of nonsense on Slack and on social media around it, so let’s see if we can clarify.

TL:DR: Test it and if you can measure it. Bigger or newer isn’t better!

In the hope to come with some list of working :white_check_mark: or not-working :x: Adapters I started testing:
Not on the picture, also tested with a IKEA Tradfri Zigbee Repeater and a Raspberry PI 4 USB-C Adapter.

First of all what (I think) I know:

  • Homey, or the Raspberry PI module (CM4) needs approximately 5.0 volt.
  • Homey self (incl. the CM4) uses most of the time less than 1000mA even with LED RIG ON (never seen it higher, maybe it uses it for flashing Firmware or under heavy compute load. I have not yet load tested it yet.)
  • A Adapter with higher Amperage isn’t necessary better. If it provides 5.00 Volt it probably doesn’t work no matter if it is 1A , 2A or 20A.
  • Real USB-C Power adapters (for Laptops, telephones etc.) communicate with the device to negotiate a higher voltage (9, 15 or even 20 Volt) to speed up Charging. Homey doesn’t use that.
  • Some (cheaper) cables drop more power (volt) and that increases with longer cables, thinner coperwires and bad connectors adapters (USB-A to USB-C of vice versa).

So please stop the nonsense about bigger, higher better.

The result is not easy, testing Homey probably plugged and started more than 50 times, testing some adapter more than once, on different ports, etc…

Using some conversion adapters (USB-A Male - USB-C female, USB-C Male - USB-A female, and two extra short cables) and the USB Tester introduces also a small voltage drop.
That extra loss is expected (See USB hardware - Wikipedia wat the expected powerdrop could be in a cable and connectors ) but also makes good testing complex. On the other hand: If it works WITH the tester some time it probably has less chance to fail without the tester.

First I was measuring at the power adapter as that was the easiest to place the tester. But moving the tester to Homey, clearly showed it displayed a sleight lower voltage there behind the 1.x meter USB-C to USB-C cable.
So I also monitored the videoCoreUndervoltageOccured to be False to check for at least some hours. That is where we are doing it for, a stable Homey Pro Early 2023!

Some test I have repeated 2 or 3 times to verify, most adapters that fail, fail already very soon after plugging in and booting. Often also tested a Restart from software.
Some tests with adapters with the USB-Tester and short cables worked but failed with the longer cables or with the Homey Pro Ethernet Adapter and a long cable.


There was no easy option that absolutely worked with the Ethernet adapter, test it with what you have.

  • :white_check_mark: The Raspberry PI 4 USB-C Adapter is working for me, even WITH the USB tester in between. (Not tested with Ethernet adapter as the PI 4 USB-C Adapter has a fixed cable with USB-C male connector.)
  • :x: Most USB-C adapters stick with ~ 5.0 Volt, you can probably skip them.
  • Most USB-A adapters have a slight higher voltage, around 5.1 to 5.2 Volt.
  • Most USB (-A) Adapters have a lower voltage without load (eg 4.88V) and raise if you plug in Homey to fe 5.10 or 5.20 Volt. These look better (Also older adapters)
  • Some Adapters with USB-C & USB-A or Adapters with USB-A 2100mA and USB-A QC perform better with the dump USB-A as it often had a slight higher voltage.

Note: The place I tested I didn’t have an ethernet cable, Test With Ethernet adapter where performed without using the Ethernet for now.

It looks like a more than 5 years old adapter with specification: DC 5 Volt +/- 5% 1000+/-50mA
is even more stable than most newer adapters.

Without Load it starts with 5.17 Volt on the tester (behind the Ethernet and long USB-C to USB-C cable) and raised on plugging Homey Pro in the Tester to ~5.29 Volt +/- 0.03 Volt. :white_check_mark:

If I missed something, let me know but most is just what I experienced.

If you have a alternative good working adapter (preferably that is easily available) Post it here below!

:white_check_mark: Brand-And-Name-Of-The-Adapter

And a good Picture!


:white_check_mark: The NEW HY-PD3 / HY0028 specified with 5.2 V=== / 2.1 A

See the New (Above / connected) and the original 5V=== below.

Please do not use the original anymore for Homey Pro (Early 2023)

If you need to replace it order it here:

PS — in case you want to manually select your power adapter region: Type-C (EU) | Type-A (US) | Type G (UK) | Type I (AU) (Edited to Direct Store Links)

:white_check_mark: Samsung USB super fast changer 45 w (Ep-TA845)

Works with Ethernet adapter.

:x: Eaton USV 3S 700
Doesn’t work (only tested with Ethernet adapter). Homey works fine, but undervoltage info appeares in developer page (at least while booting). Unfortunately it is not possible to power Homey directly from the USV USB port. A power supply is still needed.


One comment on this - when testing stability of power supply, it must be tested under high load to be 100% sure it can deliver sufficient requirements.
Eg. in my case, with CPU on 70-80% (and even more ;-( ) and temp. 70-75C the Homey/RPI module complain about videoCoreUndervoltageOccured quite often even when having power supply delivering enough of voltage and current. As soon as I lower the load, the error disappear and not appearing randomly. This is even valid for original RPI USB-C power supply unfortunately.


Then we can only hope that Athom will produce the new power supply units in such a way that the drama comes to an end.
Homey and its power supplies have been a never-ending story so far.

Well, I’ve used the original Athom power supply for 2 years for the pro 19, without any issue. They are not all bad :nerd_face:
It’s not generic.
We never hear about the ones without issues, right? :wink::wink:

Indeed, also running original power supply for 3 years, never had any problems and my old HP2019 is running on 150% load…

A post was merged into an existing topic: [APP][Pro] sysInternals - Shows Homey’s System Internals

FYI, I have been relying on original USB cable shipped with Homey, hoping that this cable is well tested…still got videoCoreUndervoltageOccured randomly…replaced is now with shorted cable (branded USB-C USB-C 0.5m) and the error is gone even under high load. I must admit, I was not expecting that, as the current power supply I’m using, delivers about 5.2V - so I though even with longer cable the additional drop, if any, will be insignificant. (btw using Ethernet adapter, so voltage drops probably sums…)

In my case the same adapter (only black) didný work with the Original Homey USB-C to USB-C Cable and Ethernet Adapter. With a short (25cm) USB-C to USB-C Cable direct between Homey and Adapter it works without issues.
So results will vary…

This booster works
(Thanks @Davide_Zamo for the Tip: Power supply can cause slow Homey Pro 2023 - #116 by Davide_Zamo)

See the voltage drop, 5,55 Volt out and ~5,27 Volt at the end of the cable.


Is it the new replacement adapter?

Currently i I have only some dev apps installed and the CPU usage is low enough.

Nope, it is the old USB Adapter from the first Homey 2016, the Red USB Power Quick is from “wuzhi” and boosts from 5,15 to 5,55 Volt.
The yellow is just a tester to measure the voltage drop in Cable and connectors.
I also tested the last black USB-A to USB-C cable and that one also drops again up to max 0,1 volt but that’s enough then in the Homey. (seeing NO undervoltage issue’s anymore)

Where did you order the device? I found this one:

Looks the same,

I had to assemble the top and bottom self (8 screws and 8 busses and screwdriver included :wink: )

1 Like

@Dijker Is this the testing device on your picture?
Testing the resintance of the cable.


The Chargerlab power-z KM003C is also very good :+1:

Athom advice NOT to connect short cable from ethernet adapter to Homey.