Homey pro 2023 - zwave too much traffic error?

I had a perfectly working homey pro 2023 with about 45 zwave devices.
Since today, the zwave is not really working anymore as I get an error: "Could not send command. Too much Z-wave traffic. (TRANSMIT_COMPLETE_FAIL). This goes for all zwave devices now, and might be related to the latest firmware update.
I have tried to reboot, reset (with back) but nothing helps. My old homey pro works perfectly, so its not the devices themselves.

anyone else experienced the same?

5 Likes

Which latest… your latest update, Athom’s latest update, stable, experimental?

Same issue (seems like it) is reported on #Homey channel at Slack (note the 103 replies)

Screenshot from 2023-07-05 23-45-57

The stable rc.122 release mentions: user gets notified on ‘very chatty’ devices. Did you see any of those messages? While those devices can clutter up all traffic and should be edited so it sends less updates f.i. (just some thoughts).

1 Like

I tried both firmware versions, the stable and experimental one: same result.

I dont get any notification of noisy nodes. It just all comes as a big surprise.

1 Like

I also had a Homey Pro that was functioning flawlessly, and I had made significant investments in various automations. However, as of yesterday, I’m facing the same problem with 33 of my Z-Wave devices (out of a total of 125 connected devices). Devices like Wall Plugs and Multisensors from brands like Fibaro and Aeotec have suddenly stopped working.

No notifications about chatty devices or something similar.
homey_error

1 Like

Exactly the same with me.
It was fine with rc110 but when it auto installed rc118, the too much a wave traffic - transmit complete fail started happening.
During the day there would be the odd occasion when it would work, but mainly not.
I then turned on the experimental updates to try and fix it, nothing worked until i installed rc133 yesterday. Needed several ptp to get it working again.
Ive now turned experimental updates off again and will leave it a while until a more stable update.
I do think that while we are in early access and to all intent and purposes ‘beta testers’ the exchange of information between actual athom and us the testers could do with being a bit more of a two way street. It is clear that other people are having the same problem as us. I spent ages yesterday trying to find out what was wrong and mine was the only one. Would be so much easier if athom posted info as well, saying what niggles we might experience, rather than let us flounder. It is quite frustrating.

I also installed the experimental and did the ptp, but after a few hours the problem came back.
Fortunately I still have the previous pro, plugged that in and all works.
Now the wait is for the 2023 fix :frowning:
For sure the auto update will be turned off now.

same issues here - did you reported the issue to athom, too?

Athom has confirmed there is a bug with Z-Wave, especially because of S2 devices that are drowning in a communication spiral. Please send logs and diagnostics to them so they can find a fix. They are working on it.

I have reverted back to my HP2019, since my 150 Z-Wave devices were not working anymore.

2 Likes

S2 devices could also lead to problems on the HP19, e.g. long response times or devices did not react at all. So the advice to include S2 devices unsecure again?

@SvenRhein, @Martijn_C, with which firmware did the problems occur? Does this only affect migrated HP23? Or also those that were set up from scratch? Does anyone know?

True, but the strange thing is that I have included S2 devices with 00000 pin from the beginning. Never have I activated the security. Still they (apparently) are a problem. Also, some devices (like Heatit) set S2 security out of the box. Nothing you can do to change it. Thirdly, I also have non S2 devices that were going crazy with RX. Fakro roof windows with a set report interval of 15 minutes for example. So, I’m not totally convinced it’s just S2.

Anyhow. I cannot confirm it’s because of the latest firmware. It might be a coincidence but I migrated yesterday, with HP2023 on RC122. I immediately got the issues. Reverting back to the HP2019 went smoothly and the Z-Wave network was as normal, just smooth.

I have these issues with fw 133 - reported to athom already - so wait and see :slight_smile:

I am a new Homey Pro users so have not migrated, everything from scratch. Problems started with RC122

I was talking with support all morning but I think it’s better to leave it for now. They are working on it and the more I say and show, the less clear the problem becomes. The high RX of non S2 devices for example, they are saying I should contact the app developer or manufacturer. Why? These devices don’t have high RX on the HP2019… and the high RX on the HP2023 is not because of 1000 different data points. It’s one data point received (or duplicated) 40x times in a second. That’s Homeys doing… Anyway, getting a bit frustrated. :sweat_smile:

I have the same since RC-122. Running HP23 with RC-118 and all works fine. After Update to RC-122 the known Problem.

Seems for me a Problem with RC-122 and not with an App for Devices because i have high RX on 1 of 5 Fibaro- and 3 from 11 Aeotec-Switches.

Made Factory-Reset, took a Backup from RC-118 and made the Update again > Same result.

Reported all to Athom.

1 Like

Good to hear. The more we see it, the faster they’ll fix it.

I just got a message back from support saying it’s my devices and their set intervals… :sweat_smile: I know… it’s just support and they’re doing their best.

I guess those are S2 Unauthenticated devices without any PIN code. There is an app called UnZ-Cure in the HCS available, but the HCS is actually down. However, with this app you are able to include all devices unsecure.

Sorry, but I hate such ignorance from Athom. Also, according to my information, Fibaro devices are also affected, as @CyberSponk also confirms. Guess who is the app developer.

Oc, I guess you changed all interval settings because the HP23 is more powerful than the HP19… :joy:

Thank you all for your feedback.

Good to know, thanks!

Lol, yeah. I know. It’s just a standard response. Same as the email I got. It’s frustrating but I do hope they take it seriously.

UnZ-Cure is installable via CLI. It’s SDK3, but not sure if anyone tested it for real on a Pro 2023 (developer didn’t!)

1 Like

And now its stopped working again, back to too much traffic etc etc

I am now a bit worried if Athom is taking this seriously. Its a big issue for me, as the 2023 is not usable at all now (95% of my devices is zwave).

Is there a way to go back to previous firmware?