Homey Pro 2023 Zwave issues

Since migrating to HP23 I am finding that many of my zwave devices (Aeotec SS6 and ZW116) are not working consistently.
I use time of day an and motion activated timers to switch things on and off. Many times they don’t switch. Using the App I go to these devices and sometimes it works there but often it doesn’t. I can go back in a while and it works OK. When it doesn’t work it gives a red banner “TRANSMIT_COMPLETE_FAIL”

1 Like

Do they work if you move them closer to Homey?

Some of them are quite close and still fail. And the all worked flawlessly with HP16.
It surprises me.

Are these migrated using backup and restore or paired directly to Homey Pro Early 2023?

Some of each, doesn’t seem to make any difference. I tried to add some using my iPad but found the App isn’t set at the correct resolution so I couldn’t even see the SS6 under the Aeotec devices. So I had to use my iPhone - just mentioning as it was this experience which confirmed to me that the two devices I have set up as a test flow were added by pairing with HP23.

Placement of the new Homey Pro is more critical, since its antennas are located at the bottom and therefore you don’t want to place Homey on something metal, for instance.

1 Like

OK, I’ll try repositioning it.

You were spot on. I didn’t have it on a steel desk but I had it next to a 20Tb NAS Drive, behind my MacBook Pro and underneath a 32” monitor. Probably not the best environment. When you get old the basics sometimes get forgotten.
I shifted it and even printed a nice stand to get it up off the desk. It now seems to be operating perfectly.
Thanks very much for your help.


I am still having an issue with my Aeotec Smart Switch 6’s not turning on (or off) occasionally. I get a TRANSMIT_COMPLETE_FAIL error. All other devices are working well without fail.

I have the “transmit complete no ack” in both my smart switches 7.

It goes ok for a couple of days and then i have the message and they are not responding. I can solve by removing them from the wall plug for a couple of seconds …. And then the issue is gone a couple of days and it workjng like a charm

Very annoying though.

Are rather close to the homey and even some fibaro dimmer 2’s in between ( but they are not used as relay because i see in dev tools both the SM7’s are used directly by homey )

Yes, I get that error as well sometimes. It is very ad-hoc. I have been writing to Homey support about the issue for some time now. You should raise it with them as well. Ther is something wrong.

I also had a lot of issues with my Zwave network, making my HP23 pretty unusable.

Athom identified an a problem which could occur with zwave devices after a backup was completed.

This was fixed in the latest release candidate (rc100), really early days but I have noticed that my zwave network seems to now be the same or better then my HP19.

My advice, update to the latest version, and then update the thread with how it is going for you (both good or bad).

Thanks Jamie

Yes i updated already this morning. Fingers crossed.

The thing is though … i only have it with the aeotec plugs mentioned. ( 2 ). All the rest is fibaro stuff and i never had or have any issue.

But will report back id the issue happens after today

Thanks for the help !

I also have issues with the Aeotec plugs. I have received them last week (Smart Plug 7 eu version) and they are the only one with 700 chipset, and they just stop working, become unknown or just start blinking like they receveid a disjoin command.

I have informed Athom and Aeotec, and Aeotec just says “the homey pro 2023 is still beta, issues may occur”.

Just like you said, all the other Z-wave stuff works fine (Fibaro, Popp, Robbsmart) just aeotec 700 chipset devices are doing weird stuff.

He mike

Well mine are the older ones … not the 700

Hi Jamie,

Unfortunately the update did not fix.

Same aeotec switch 7 … 5 meters from homey … with 2 fibaro dimmers in between.

Restarted homey … no result.

Only taking it out the wall socket for 3 seconds and plugged it in … and it worked again ( a couple of days probably ).

Happening to both my smart switch 7’s … no other zwave switches ( fibaro build ins )

Doubt it is the range also. 2 potential relays in between and 3 meters further …… in my garage ( wall in between ) i have a aeotec multisensor that is perfectly working directly with homey ( no relays used at all according dev tools )

Will remove from homey and add again to see if that changes anything.

I have the same issue as Peter. I also have lots of Aeotec switches, mainly the dimmer switches. They work about 50% of the time, and otherwise fail with a TRANSMIT_COMPLETE_FAIL error. They worked flawlessly with the old Homey Pro.

Have you raised it with Homey Support. The more of us that do that the better.

Hi Peter, I have just contacted them. Will update here if I find out more. It looks like we’re having the same issue.

Have a look around the end of this post to see some more info related to this one.