Homey pro 2023, response_timeout when adding Z-wave devices

Hello all.

I’m new to Homey.
Going from an stable, but rather “old fashioned”, homeseer HS4 pro system, I wanted to try something new.

Installed my new Homey pro 2023 yesterday, running FW 10.0.8.
Installed apps for Fibaro, Heatit and Aeotec.
No matter which app I try, I get an instant message “that something went wrong, response_timeout”.
This message appears within 1-2 second, it looks like the HP23 doesn’t even try to search for Z-wave units.
Tried to reboot several times, also removed power for a few minutes.

Any suggestion?
Try the new beta FW?

Cheers from Norway,

In case the error will not go away even after restart, yes you can try newest beta firmware , there is currently no harm, many users are running this version already.

Also check Dev. interface, maybe you will see there is something wrong.


1 Like

Thanks for your reply.

Unfortunately, I didn’t manage to solve this problem.

When I check the dev interface, there is no problem when looking at the Zigbee tab.
When I change to the Z-wave tab, I receive an error message, response_timeout.
I guess the Z-wave is broken in this unit.

Tried the latest beta, did not solve the problem.
Then I tried to reset to factory default, no change.
I give up and will return the unit.

Last attempt - factory reset via USB, have you tried ?


1 Like

Thanks for your help, Sharkys.

Yes, I have tried factory reset via USB, did not help.

Is there anyone else here that have experienced faulty HP23 units out of the box, DOA?
Using Homeseer for 4 years without big issues, I now thought it was time to swap to a more modern system, and then I see this?

I guess it’s a waste of time trying contact the Homey support, expected response time is 3 weeks.
Not the best first impression of my swap to Homey :blush:


Not really, for Warranty claims they respond quicker but if you bought it on shop, that might be faster swap/replacement/return indeed.

There were some, but quite rare (but you can search on the forum).

First of all, welcome to the Homey Community!

To make sure you are aware of the forum rules, please read the Welcome to the forum post here.

1 Like

I will try again this afternoon with a new unit.

Does anyone use the stable 10.0.8 version without problem or is it recommended to use the 10.1.0-rc.4 version from the beginning?

I would start with this one for sure.

1 Like

The stable 10.0.8 version works fine for me, also the apps for Fibaro and Aeotec.

When do you get the error message, if you try to install the apps or the devices?
If the message come during installation of the devices, then try it with a close distance between HP2023 and the device.

It was when installing devices.

Homey support responded quickly and tried to reflash the Z-wave chip remotely.
That didn’t work, and they concluded that the Homey pro unit was broken for sure.
A new replacement unit is soon in place.
Thanks all :slight_smile:


Having the same issues
Did the new unit fix the problem?
Im guessing yes

Hi just bought a brand new homey pro 2023 to use in my cabbin
Unlucky for me im only staying here for some days.
I set up my homey and it started to update.
It failed updating firmware at70%
I left it alone for 10minutes, unplugged it and reeboted
It seemed to be working fine.
Started by adding my hue thru the hue hub. Ok
Then moved on to trying to add my zwave.
Search for fibaro, choose wallplugg and as soon as it starts the zwave process it gets response timeout
Same if go directly to zwave without choosing brand

Thoght it might have something to do with the update, so i went to developer tool and turned on experimental.
Downloaded new update -ok
But still the same
Sent a support ticket got a nice reply that it could take upto 2 weeks!
YAY :pensive:
After beeing an unhappy zipato user :frowning: for 10years and going good support to no support at all.
Im hoping i did not do the wrong thing going for homey :see_no_evil:

Any one that can help?
Have been searching the web for hours fin no fix
Found a case with faulty pro.

Next question i also bought a bridge, can i set up a bridge the move th configuration from the bridge to pro later? (If i need to take the pro back home)

Yes, the new unit worked well.