[HowTo] Homey Pro (Early 2023) - Migrating from Homey (Pro) (Early 2016-2019)

I see a lot of questions on Slack and here due to mistakes or nor reading. Lets see if we can organize them by topic.

I have written a [HowTo] Homey Backup and Restore - Homey Migration before when Backup-Restore came available.

Almost everything from the old topic is still true,

Add to that:

  • You need a recent successful backup of your other Homey;
  • Not validated, but pretty sure: you can’t migrate back from a Backup if the new Model Homey to a older model Homey!
  • Check all Homey apps on your Homey that they are ready for the new Homey Pro (Early 2023) Both that they are updated tot SDK3, but also verified by the developer or other Community members that they actually WORK on the new model!

Are you Ready?

If Everything working? If not, investigate, Send Logs, write down your issue’s, go back to your older Homey! Reset the new Homey and look how to fix your issue…

Next step - Zigbee Re-Pairing (actually repair :wink: )

  • For each and every Zigbee device Klick Repair - From WebApp Rightclick - From Mobile - Device-Settings - Maintenance Try to Repair.
    With Repair your Insights and Device ID are kept, so no need to Fix Flows after that!
    (Only the Zigbee ID’s are Replaced and the device joins the NEW Homey Pro Zigbee network!)

Once you start this process you can’t revert to your old Homey without again adding and repairing all Zigbee devices!


(This article is a work in progress, pls let me know if you have additions!!)


Question, i have migrated from Homey Early 2016 (latest version) to the new Homey Pro 2023 (latest version). All my devices have migrated with the apps (from back-up). But the flows are not migrated. Only the folder structure but no flows inside.

Is this a known issue? Already tried 3 resets for the homey pro 2023 and a new and older back-up.

Not that I know, please report as in the instructions for Early Access:

Report an Issue

If you have encountered an issue, please report it so our team can fix it. Even if you think it has already been reported, knowing how often it occurs help a lot solving it.

Hello all,

So I should be getting the new Homey Pro 2023 today however, Im missing how I can simply migrate everything from the older (2019) to the new 2023? What are the steps to follow?

I checked the knowledge-base but cant find any article about it.

Can someone pls let me know, thanks.


You must have a backup of your current Homey. Initiate a restore for the new Homey.

As far as I know, Zigbee devices are not restored. They have to be relearned and the flows have to be repaired.

In any case, I would disconnect the old Homey from the power supply before restoring the new one. If it goes wrong, you can reset the erarly 23 to factory settings and use the old one again.

I dont have direct Zigbee, only Z-Wave. Zigbee goes through Hue bridge, so that wont be a problem :grinning:

So basically, steps;

  • Recent backup ready
  • Remove old homey (disconnect)
  • Install new Homey with a restore? will it ask for that (to restore)?

@Dijker would it be possible to create a dedicated migration topic? For issues, questions but mainly experiences.


First contradicting thing; received an email stating I need to install the new app.

To set up the new Homey Pro, you need to install the new Homey app for iOS & Android .

Just opened the new Homey '23. The QR that’s on the backside of the included booklet directs me to the IOS App Store to download the regular ‘old’ app.

Why do I need the new app??

1 Like

The new app is still in beta. Until it’s ready for the App Store, you can download it through the beta channels:

Thanks for your reply but I know how to get it… but why is it necessary/essential? And is the new app compatible with the old homey too?

Because the new Homey 2023 requires the 7.0 app which is in testing atm.
And yes the old Homey also works with this new app :grinning:

1 Like

Probably answered in the email for Early Access,
But also now Answered here: you NEED the (currently BETA/Testflight) app now during Early Access: [HowTo] Homey Pro (Early 2023) - Getting started (With Early Access)

After Early Access you can keep the booklet with QR code, You will not get a Re-print.
then the new App will be stable and for everyone…

Today my new homey pro 2023 arived.
After a migration everything went well but the flows are gone.
Is the a way to get my flows back?
Update. Only the advanced flows were restored…strange

Welcome to Early Access,

Report an Issue

If you have encountered an issue, please report it so our team can fix it. Even if you think it has already been reported, knowing how often it occurs help a lot solving it.

I tried to migrate my Early 2016 Pro backup to the new 2023 Pro.
The first time it said the back-up was ready, at startup I received an error “TypeError: Invalid Version: null”.

I waited for 5 more minutes en restarted the App (7.0 Beta).

Afterward it just started, but all devices show like a dashed square, and the reason for it is the correct apps are not yet installed.

I just waited a lot longer to give Homey the time to download the apps, but the app screen keeps looking like this.

How long does it take to update the apps? And how can I see if it is still downloading and installing? I didn’t just restart the Homey because I think it is not a good idea to reset the Homey during the installing of the apps.

Also I have the exact same problem as everybody, only a few advanced flows (5%) are restored, but all of my normal flows (95%) are not restored.

1 Like

Seems like restoring normal flows is a serious bug. Please let Athom know too.

By the way… I think you mean flows in stead of apps.

1 Like

Yes correct, the apps didn’t install, and the normal flows didn’t update…

When I plug in the Ethernet adapter with homey then homey say I can connect with it but when I downloading an back up it’s very slow

When I only use WiFi the back up is very quickly !!!

What’s wrong

FYI: One thing I noticed that migrated logic variables caused issues in flows using Logic cards. I had to re-save the variables once to fix the error.

Have you checked cabling (RJ45 CATxx) between Homey adapter and Switch?
Tried another Switch port? Tried another Cable? What reports the switch as speed?
Send an Diagnostics report from the Homey on that adapter to Athom and created a Report an Issue with Homey Pro (Early 2023) →