Homey not responding to Hue Dimmer Switch

Hi All,

I’m a little bit lost and out of options… I have two Hue Dimmer switches that are not working any longer. One of them I completely removed, reset, added again and updated flows, but with no success. The homey is not responding to any button that I press.

Last couple of days I’ve been adding a lot of Zigbee sensors and today I noticed my motion sensor (at least the ones from Hue, but possibly also the ones from Aqara) have not been responding. The lights did not go off or on. However the switches were working just fine.

So I decided to restart the homey. Since then the motion sensors worked again and everything seemed fine. I’ve been adding a lot of flows for the sensors that I’ve added and all is working well.

Now I try to use the switches again and nothing is responding. When I execute the flows from the app or from the flow editor everything works fine.

I’ve tried resetting the switch and add it again. Hoping that Homey would recognize it and replace the “old one”. However, it was recognized as double, but that didn’t do anything.

So I removed one switch completely and added it again. I updated the flows, but still no succes whatsoever. Also the other switches still don’t work.

I’ve checked Developer and see that the switch was added and it even routes through one of the zigbee lights, a Hue GU10. I don’t have any Ikea stuff that I read about that could be a problem.

I’ve restarted both the Hue Zigbee app and the hue app, but still no success.

I’ve tried a soft reset of the switch by pushing all 4 buttons. No luck.

I can think of only one last resort, but I’m honestly not happy to use that option. Resetting the Zigbee network gives a warning that all Zigbee devices will be removed. I would rather buy a different switch than to do that. Not only adding every device again, but also updating all the flows is undoable.

I have 37 Zigbee devices connected, from which 8 lights, 1 relay and 28 sensors (motion, doors, humidity, switches etc.). Besides that I still run the hue bridge which only contains lights (around 20+).

What can I do to get these Hue Dimmer Switches working again?

28 end devices (sensor) against 9 router devices (at least, I assume that the lights and relay are always-powered) is probably the reason why it’s not working well. Unless you have a very well layed-out mesh, with more router devices, most of those sensors will connect to Homey directly (you should be able to see this in the Developer tools) and you’ll quickly run into the 20-directly-connected-devices limit of Homey.

Also, to prevent interference, ideally the Hue bridge should be on a different Zigbee channel than Homey. I believe you can change this for Hue, but not for Homey. Homey is on channel 11. I don’t know what the impact will be on changing the channel for your Hue hub, it may be that you need to re-add all devices to it after a channel change.

Happens automagically, no need te re-add to the hub.

1 Like

For all Philips Hue Devices and some other brands. But not for the IKEA Tradfri stuff!

1 Like

Yes, all routers are constantly powered and I see that all end devices are not connected directly to Homey. Most lights that are in the Zigbee network of Homey are GU10 spots on the ceiling ‘hanging’ free (pretty much the best place for the signals I guess.

Currently I only have lights in the living room connected directly to Homey and 2 in a bedroom, all others (hallway, toilet, other bedrooms) are connected through the Hue bridge.

I was in the process of moving lights from bridge to Homey. I guess that would improve the network. I’ll continue with that either way :wink:

Still I don’t understand why these Hue dimmer switches don’t work, while Hue motion sensors do work. All other sensors also work (from Aqara). Since this issue, pretty much nothing has changed regarding that

I’ve ordered some new Aqara switches to replace the Hue dimmer switches, but they won’t be delivered for another couple of weeks.

Here is the list of routes:

Are the switches RWL021? They are showing up in the list of nodes, so they appear to be reachable by Homey. I don’t know why it wouldn’t register any presses in that case (but given that your initial issue started with the motion sensors not working anymore, it smells like an overall Zigbee issue…).

Please read this topic:

and this: Hue dimmer switch werkt niet meer (I Google Translated it when I read it, it was understandable)

To my understanding this is something that sometimes just happens and there’s no real solution. Sometimes some changes in a ZigBee mesh helps, but I haven’t found any reliable solution. In my case it resulted in giving up on Homey ZigBee radio, I moved to integration via Philips Hue bridge (which runs much smoother IMHO).

1 Like

Absolutely agree with you! :+1:

Yes, that’s correct.

Indeed, that’s why I hoped restarting the Homey would be a solution.

Thanks, I’ve read it. Most solutions are in the area of removing an Ikea repeater, but I don’t have that. Also after updates it was all working fine. Also tried the soft reset mentioned in the Dutch post.

I agree that it runs smoother as long as everything is setup in the Hue bridge, but I use these switches for a lot more than just switching on the lights. E.g. one dim button means putting the child room into “sleep mode”, which sets some logic, which is important for a lot of other flows.

Besides that, when I use Homey to read a sensor through the bridge, the major downside is the polling time up to 5s. IMHO that’s the biggest reason for me to keep sensors connected directly to homey and lights connected to the bridge (better in grouping etc.).

I will try to unplug the Hue bridge tonight, change the channel or if that doesn’t work I’m going to move all lights to Homey to improve the mesh network. If that doesn’t work, then I will eventually replace the Hue sensors and switches and fingers crossed that it won’t happen with another brand.

I’ll keep you posted.

To be honest, I don’t think the issue here are the Hue devices.

Have you tried using a different power supply for your Homey? Sometimes, strange issues can be caused by the official power supply being a POS.

Ok, I tried a number of things tonight:

  • Switched off the Aqara Relais (perhaps same issue as with the Ikea stuff, but it turned out working fine as a router for the Dimmer Switch at a friend of mine).
  • Changed the channel on the Hue Bridge successfully
  • Rebooted the Homey again, now using a 2,4Amp iPad adapter
  • Removed all three Hue Dimmer Switches
  • Restarted the Hue Zigbee App
  • Reset the Hue Dimmer Switch to factory default
  • Added it to Homey again

Result: Still nothing. Everything else is working fine.

Tonight I came to the conclusion that also the hue motion sensors are not working. This may have been the case earlier, because most rooms also get activated by a door sensor, so I might not have noticed.

Currently the situation is that all hue sensors (motion and dimmer switches) are not working.

I can see the motion sensors detecting because of the red light, but homey doesn’ see it. In fact most sensor are now alarm on for 11 hours, wich is basically impossible.

hue Lights that are connected to homey via the hue zigbee app are working fine from the app.

I’m now coming to the conclusion that there must be an issue with the hue zigbee app.

Maybe I should re-install that app and see if that gets things working again.

Looking forward for updates! If you find a solution, please share it :slight_smile:

Somehow the issue solved itself. I still don’t know the reason why it took so long for the Hue Switches to start working again. I’m pretty sure it has not to do with the switch itself or with the Hue Zigbee app, but with Homey’s Zigbee itself. I’ve had short issue with other zigbee sensors from aqara as well. I guess Zigbee needs more time to “settle” when restarted.

Last couple of days I’ve had the Homey unplugged 2 times because I had to move it due to renovations and after it was back in its permanent spot I’ve restarted the Homey and let it sit overnight. After that I noticed that the Hue Switch I connected before was working again. One of the other two that I had removed was just added and worked fine instantly.

Happy with the fact that everything is now working again, but not happy with the fact that I still don’t know why :wink:

As soon as I find out about anything regarding this, I’ll come back and share it with you guys. Thanks for all the help!

The saga continues. This morning all zigbee sensor (Hue and Aqara sensors and switches) and lights did not work. Lights that are on the Homey’s Zigbee network did not respond. Lights that are on the Hue bridge network did respond without problems. Channels between the two zigbee networks are no longer the same.

I’m going to try to restart the Homey again tonight and see what happens tomorrow.


I have got the same problem since 2-3 days. Had 1 dimmer switch working for over 2 months , then i bought 2 more.After adding them everything worked fine until next day. Atm none of the 3 dimmers work :slight_smile: . I see them connected to homey in zigbee map, i have tried readding them, reseting etc. Nothing helped … I’ve got some old bridge v1 somewhere i’ll try to test with it.

Are you sure you’re not already using a v1 bridge? Seems like those have stopped working entirely with Homey: Support for Hue bridge version 1 gone?

I removed bridge from my network long time ago, was using everything directly through homey via zigbee. Did some tests and when i have added 2 dimmers to bridge then connected to homey, flows started work again. Dimmers work and send commands to the bridge. The one which left connected via zigbee still don’t work. Seems the problem is with homey <> zigbee/app hue zigbee.
I’ll do some more tests, wanted to buy bridge v2 anyway for my razer setup, just direct connection was easier for me (got already a lot stuff in my network with IP ><)

How many Zigbee devices do you have in Homey’s Zigbee network?

Around 14 with this 2 new dimmers