Can't add innr products

So i just switched from Home Assistant to Homey pro 2023. I had a sonoff zigbee reciever on my HA that was connected to the various innr light bulbs and two sp 220 wall plugs.
Now i wanted to integrate them into Homey but Homey can’t seem to find those lights and wall plugs when i reset them.

What i did this far:

  • Place my Homey directly near the wall plug and light bulb (maybe the zigbee range was falling short since my Homey is a bit further away from the living room)
  • Disable the specific light or wall plug in HA
  • Disable the whole zigbee integration in HA
  • Delete the whole zigbee integration in HA
  • Disconnected the sonoff zigbee reciever from my HA

But everytime i reset a light bulb or wall plug and add them in Homey i keep waiting very, very long. But nothing happens.
Can anyone shine some light on this issue?

Do you have any other Zigbee devices that are already connected to Homey?

Also, are you resetting the devices correctly? Just removing them from HA doesn’t reset them, you have to put them in pairing mode manually.

And lastly: you should pair Zigbee devices with both Homey and the device at their final location, not next to each other and then move them.

Yea, i did a reset on the bulbs and wall plugs everytime i tried to connect to it in Homey (turn light bulb on / off 6 times, press wall plug button for 5 secs). These innr products are the first zigbee devices i want to add to Homey.

Why is it important to connect to the zigbee devices at the final location? Just curious.
Also, what is the zigbee range from Homey? Since i moved it because i thought the range might had to do with it (ill also add it to my op)

Are the lights blinking when you do that? That should indicate they are correctly put into pairing mode.

If so, it may help to take Homey off power for a minute or so. Last week I tried pairing a sensor with Homey and it just kept on failing for no apparent reason (let’s just say Homey’s Zigbee isn’t exactly great).

Because Zigbee devices create a mesh, and when you move devices around you run the risk of interfering with the mesh. Some devices don’t like that.

Range is probably a few meters (this is also why a good mesh is important, that’s how you can build a Zigbee network that extends beyond the range of the controller).

Thnx!
The lights flas twice and the wall plug started blinking red then green after holding the button for 5 seconds. I’ll try disconnecting my Homey for a few minutes and then retry it.

I’m aware of the mesh network with zigbee devices. My sonoff reciever has a range from 6 to 7 meters i think. It was enough to catch the wall plug in the living room (my pc and nas being in a room behind the garage). The way my lights, wall plugs and zigbee dimmers were connected while using it on my sonoff reciever was good. It worked without issues from living room to attic.
So that’s why i tried putting the Homey closer by to rule out the distance from Homey’s zigbee signal.
If i can connect to these innr products and put my Homey back where it was and it works that’s great. If it’s not picking up the signals anymore then i know my Homey is too far away. But that’s for later. First i gotta see that my innr products are connected to Homey.

@robertklep so i turned my homey off for 5 to 10 minutes. After reboot i started the process again of adding the innr lightbulb and wall plug.
Sadly, the results are the same.

Any more suggestions?

Try an explicit Zigbee reset, you can do that from Homey Developer Tools

Thnx! Did it twice. Even rebooted Homey. I do notice that the channel changes from 25 to 20 and so back and forth everytime i reset it. But it doesn’t make any difference at all.
Now i’ve set my Homey somewhere else again. Right underneeth a innr dimmable lightbulb. Did reset the zigbee signal multiple times and tried to connect everytime. But without any success.

This is getting a bit frustrating now…

Edit 1:
Tried adding them as regular zigbee devices. But the same issue occurs. Homey app says its searching for devices. But it doesn’t find anything when i put my light bulbs or wall pugs in pairing mode.

Edit 2:
I came to the idea that somehow these innr devices are still connected to the sonoff zigbee reciever on my HA (altough i deleted the entire integration and disconnected the reciever). So i plugged back in the reciever, rebooted HA and added the zigbee integration. It automatically showed back the devices to add them to HA. Allthough almost everything was “unavailable” i thought this to be weird.
So i removed the two innr sp220 devices.
Set one of those two in pairing mode and let Homey search. Again with no results.
Put sp220 back in pairing mode and let sonoff reciever find it: success.

Deleted the sp220 in HA again and retried with Homey. Again no success.

Additional to Robert’s hint to pair zigbee devices close to their mounting points,
the very first several zigbee devices should be paired a few cm’s from Homey.
And start with the 230V powered zigbee devices (zigbee routers).
Also check if your 2.4Ghz wifi channel is set to a fixed number, preferrably to 1, 6 or 11
When you reset Homey zigbee afterwards, it should select a quiet channel.
So Ch 20 and 25 probably are ok.

Here’s a photo on another try to link it. Should be close enough you would think. But Homey doesn’t share that thought. Linking it still doesn’t work.
I’ve got some tplink deco m5’s. Changing the wifi channel isn’t possible.

I guess we disagree on this :smiley: I understand the idea (making sure that the device is paired directly with Homey) but it shouldn’t be necessary because the first routers will already do that from their final location. And if they don’t, they’re too far away from Homey anyway.

It’s not weird: you had the devices connected to HA before, and (apparently) didn’t remove them from HA. So as far as HA is concerned, it still “knows” these devices. The reason they are unavailable is because you placed them in pairing mode, which means they disassociated with the HA network and aren’t in it anymore. Removing them from HA only tells HA to forget about them, it doesn’t send any commands to the devices themselves.

Since a Zigbee reset also doesn’t work, the only other advise I can offer is to try with a different brand Zigbee device to see if your Homey is actually capable of connecting with any Zigbee device. And if not, contact Athom (or the seller of your device) because there’s clearly something wrong with your Homey :frowning:

1 Like

So this morning i tried to add a Osram gu10 light. It worked! :open_mouth:
And the most weird thing… I could add my innr products after that too. A bit sad i don’t know what was the issue now that caused these innr products to not to connect to homey.

I’d chalk it down to Homey’s not particularly stellar Zigbee track record :woozy_face:

1 Like

So after a little while now i noticed my flows aren’t all working that well. Lights turn on / off when not intended. Or half of the lights turn on / off when it needs to.
Was looking around and found this thread.
I decided to go check out my zigbee page on the developer page and it looks like this:

And if i’m right this isn’t good. Because everything is added as a router instead of being a proper mesh network. So this might be the issue why i have these weird issues.
But then again, i had issues even adding anything. So putting my zigbee in the same room as the devices i could finally add them.

What i’m gonna do now is take screenshots from my flows. Delete all the zigbee devices and add try to add them one by one from their final place in the order i would think the mesh network should function.

Also: i thought i read somewhere that smart lightbulbs couldn’t function as routers since they’re voltage is too low? But here they are shown as routers. Was i mistaken or is this yet another weird issue?

There are three types of Zigbee device: controller/coordinator, router and end-device.

Homey is the controller, router devices connect to the controller and/or each other to create a mesh network, and end-devices which connect to a single router or the controller and are leaf nodes (they don’t help in propagating messages across the mesh). So your devices showing as router is not a problem.

You should always pair Zigbee devices at their final location, some devices (although usually end-devices) will not work properly if you move them after pairing.

It’s always best to pair routers first (but given that you mostly have routers, that won’t be a problem) and end-devices later.

And be aware that you cannot control how your mesh is build up, that’s all done automatically between the devices and can change at any time.

Never heard that before, sounds like BS.

As for the symptoms you describe:

  • “Lights turn on / off when not intended”: some remote controls broadcast signals to certain Zigbee groups that some other devices (sockets, lights) are subscribed to. This can even work when those remotes are not part of your network, so it could be that perhaps one of your neighbours has one of those remotes and your lights are reacting to it. Not all brands do this, so it would be useful to know if it’s only specific lights that act that way. With Homey it’s not possible to stop this behaviour, other Zigbee implementations explicitly unsubscribe devices from these groups when they get paired to stop them from reacting to those messages.
  • “Or half of the lights turn on / off when it needs to”: if this happens as part of a flow, where you turn on multiple lights at the same time (or a Homey group), this is an issue that Homey has had for years and apparently cannot be solved: when sending a command to multiple devices, some of those commands get dropped and are never sent. It’s usually fairly random. This is also not helped by the fact that Homey doesn’t support proper Zigbee groups.

Hi,

With this you can make a route map

.
What caught my eye:
Node 1 / ‘tuin 7’ seems to be too far away from Homey or one of your other router
Just re-pair it, without removing it prior to that.
If that doesn’t work out, you probably have to add another router device between this one and the closest one.
Maybe there’s (too much) Wifi 2.4GHz interference at that location.

About Node 11 / ‘badkamer sensor’:
It seems to have lost it’s connection to it’s favorite router;
Just re-pair it, without removing it prior to that.
Often the Aqara app needs a restart after that.

Thnx for the link! I’ll defenitly take a look at that!
About the Tuin lights. I had to add them separately to homey because i noticed i can’t add multiple lights together at once inside homey. So with a spare electrical cord, a gu10 spot thing and a power strip i added those lights to homey.
Now i need to replace my garden light spots with the smart lights, possibly re-pair some or all, and group them together in the group app to integrate them in flows.

Only problem there is that one of those lights won’t work as intendend. Therefore i made this thread.