Apps not working (paused)

Yesterday all my apps on homey bridge stopped working (paused).
24 hours later, still not working

Tried to reset homey and remove/install app, but it will not work

I can’t find any post of this problem lately
Anyone has an idea?

I have got it working at the moment, my solution for now

  1. reset homey bridge
  2. in the app, go to “more” - “apps” and then the app of choice
  3. select “watch in homey store”
  4. i have got th option to install… this is strange because it is installed. After install the app seemed to be working fine for now

I seem to have the same issue since this morning. All apps are not running. Tried restarting them but get “spawn ENOMEM” error.

That means that Athom’s servers are out of memory…

Thanks @robertklep after a few restarts now all apps are working again.

Just had the same thing.

Every device attached to Homey was offline.

Bosch dishwasher
Logitech Harmony
Eufy robovacs
Eufy security cameras
Victron BMS
etc etc every single device

After a reboot everything was still offline.

Attempted to restart some Apps get a red banner with

! spawn ENOMEM

Because of ongoing memory issues in Homey I have been reducing its workload, removed 433mhz, zigbee, zwave devices, 90% of flows, most apps

But still plagued with memory issues.

It now appears any devices are too much for Homey to function :slight_smile:

The only way to reduce the loading further on Homey now is to turn it off.

This was a very expensive mistake, the promise was high but execution disappointing.


None of my installed apps are using any memory.

So with Homey doing absolutely nothing it has 14% of memory available.

The old Homey memory stats aren’t correct, they don’t take into account the amount of memory used for caches/buffers that can be made available for apps when required.

My old Homey is doing nothing and only has 3% free:

By disabling ALL apps and removing ALL zigbee, zwave and 433mhz devices managed to get free memory up from 14% to 15%.

Which according the the spawn ENOMEM error message there is not enough memory to run any apps or devices :slight_smile:

Just performed a hard reboot with a 60 second power out.

See if that helps…

It looks like Homey just decided day before yesterday that it needed all the memory to itself and stopped doing anything.

It looks like the hard reboot has fixed it.

I’ll put Homey on a smart plug controlled by a reliable home automation system and perform a hard reboot every night.

Hopefully that will keep Homey more reliable.

I have reduced Homey loading by 90% and that still appears to cause it to fail.

I’ll remove everything I can from Homey so it can concentrate on just the myenergi, Victron, Harmony, EUFY, Netatmo and MQTT Client so that it providing at least some value.

Realistically I can move Victron, Netatmo, Harmony off onto Node Red, maybe a few more, but feel the Homey should be able to contribute being the most expensive, and least useful, component in my home automation system.

Hopefully it can cope with that but not hopeful. :frowning:

Homey has been just a disappointment, so much potential.

All zigbee devices now on zigbee2MQTT, zwave on Hubitat, command and control in Node Red.

Homey now just relays data/commands TO/ from MQTT

What Homey model?
If Pro 201x: did you replace the power supply + cord already?
How do the app memory graphs look?
Any app using or used over 60MB?

The only app we both use is MQTT Client and that’s issue free.
Homey 2019 here is running 40+ apps without issues.
Last up time was 32 days. Hard restarting Homey every night, to me, looks like a way to kill Homey fast.

Have you started in Recovery and performed a “full software download”?
Have you tried a factory reset and read back a backup?

Did you create a ticket at Athom support?

See responses in line below.

Really appreciate you helping with this.

Hi Michael,

Athom states an app should not use more than 30MB.
Did you send a message to Martijn about this?
He’s always very helpful:

The Athom Hue app did also behave quite odd for several users, memory going over 60MB every x hours, so they restarted the app every x hours as workaround.

When you look at Insights, that seems to be true, but on the other hand the Memory Statistics (…more>settongs>general) do not show memory for disabled apps.

I was trying to build an app once, removed all of it, but Insights still shows 6MB after 2 years :woozy_face:
Or the Http Request app, it has two entries!:thinking:

In my opinion the Memory Statistics shows the real current RAM use.
Insights is just not removing the leftovers / updating inactive apps.

My apps & memory overview (40 active apps):

Disabled apps (only temporary enabled when needed)
Ecovacs Deebot
Advanced Scheduler
< Timeline Manager² >
Homey Community Store
Piggy Bank
Action Scheduler
Zone Memory

Around 50 apps in total.

I never (hard-)reboot it by a schedule; it reboots after firmware updates, and I reboot it sometimes after fiddling too much with app and device tests.
It’s a linux machine, just like HA, it doesn’t need rebooting to “reset” things imho.

Yes, sorry I did not mention it is non-destructive and won’t alter your stuff.
I think it sort of re-installs ‘Homey OS’ from scratch.
Of course things always cán go wrong (f.i. a power outage during the procedure), so I’d recommend to have a recent backup available.

Follow instructions, the setup menu will ask if you want to restore a backup:

True, but it could by using two Hue bridges.
But that is cheating imho :sweat_smile::sweat_smile:

It still puzzles me, I’d like to start without a manual, but to me it’s very un-intuitive.
What I like about Homey is the relative ease of automating.

True, although I had no real issues with Homey’s zigbee (Ikea lights + Aqara don’t mix), I’ve moved zigbee to HA with Z2M, also just to play and check stuff out. Works great.

Like most companies, the marketing is not exactly according to the reality
Homey just can’t interface with f.i. tado, Somfy io, and others, without having to use their own bridges/hubs.

Yeah, I got the idea they can’t solve it, just like the Google sync button switching itself off every x days.

But I still recommend to report the ENOMEM issue to Athom, for the record, and who knows this is a solvable issue.

1 Like

Unfortunately Eufy uses a lot of memory already made a lot of fixes but the library behind the app uses a lot of mem.

Every Eufy devices makes an individual connection. Still checking to fix the Memory issue.

Especially in Homeys with a lot of heavy apps it tends to crash sometimes.

Restarting it every night is a option. However i dont like that, it should just function , but might be a temporary solution

1 Like

The Eufy Security app is one of main functions for still using Homey, and I know it is a total pain to make it work, Eufy seem to revel in making it hard :slight_smile:

I have managed to uninstall Mqtt hub App from Homey, the first attempt to uninstall resulted in crashing Homey and took a few hours to get get everything running again.

I have a relatively small number of devices left in Homey and can manage with MQTT Client reducing loading on Homey further.

I am left with these APPs now

And memory is doing better

I do have 10 cameras on Eufy about to go down to 9 as I retire one.

Having fun with the facial recognition and having people announced as they walk up the drive will be fun, also having the blinds shut whenever the window cleaner is spotted will be interesting too.

I can move Victron off Homey as it uses Mqtt, I can move Sonos off into NR easily, then I’ll look at Harmony, Netatmo, LG WebOS, Bosch Home Connect.

Eventually leaving Eufy vacs and cameras along with myenergi, Tado, and MQTT client then hopefully Homey will stabilise some.

1 Like

It is a bit of a steep ramp, but I am absolutely loving it, Node Red is operating as the command and control for multiple incompatible hubs.

There are so many custom nodes to make it work with things I never dreamt of.

I love the autonomy of the hubs, if NR goes down heating and hot water still function normally, automated lighting still runs, most things run, I miss the really ‘clever’ stuff of integration across all things, like goodnight mode in NR that turns heating down in every room we are not in, manages light collapse back to bedroom, checks doors, door locks, windows, puts exterior cameras onto alert mode.

Anyway thanks for your help on this one.