[App][Pro] Tuya Cloud


About system updates:
Latest v11.0.0 firmware: april 24th
(Introduction of ‘moods’)
Latest v11.0.1 RC: a few days later
Changelog: https://homey.app/en-us/wiki/homey-pro-2016-2019-changelog/

It seems to be a local issue for now.
I’d recommend to install the test app v1.1.24 from the app store, without removing the installed app:

When that doesn’t make a difference:
If you have an offline backup holding the previous firmware, I’d restore that version.
Note: With Homey cloud backups, you can’t restore a backup holding a previous firmware version unfortunately.

1 Like


I moved this week from my homey 2016 to the new homey pro.
But i cant seem to get the tuya cloud to get working.

I followed the guide from this topic. (the github guide Personally I find kinda confusing because not everything matches with the tuya site)

The account gets paired in the settings menu but when I want the add devices I get a error.

The old homey 2016 still seems to work (turning devices on and off) adding new devices also gives the same error.

Any suggestions how to fix this ?

Have you tried removing a device from Tuya and adding it again to Tuya and after that try to add it to Homey again?
I believe after adding a device to Tuya you need to restart the Homey Tuya Cloud app before the device is found.

Hey @Sander24


I followed the Guide again. Made a new project. But still I get the same result.

I also tried the same project within HA and it works perfectly !!
All devices are found and controllable.
So I think the cloud project is setup right.

HA works very differently nowadays, you don’t need to have any IoT platform projects anymore. Unless you’re using a really old version of HA?

Im actually not sure about the HA. I only use it for testing some of the zigbee devices and industrial modbus things. It had a Tuya plugin that also asked for the API key etc.

But I find it strange I dont seem to find whats wrong with the Tuya cloud and homey. I followed the guide many times. Made a whole new tuya account but it keeps giving me the same error.

If my garden wasn’t done with all the tuya clooud devices I would switch it over to zigbee.

I miss your temp sensors in the app. I have a Smart temperature and humidity meter that I would very much like to have in my Homey Pro.

“This app is not active maintained, only Pull requests will be put through.”

First post of the thread.

You can use the When-cards in my snip, and build your device with “DeviceCapabilities”.


Thanks for reply but where can I find it? I’m a bit new to this.


Scroll up.

1 Like


Thanks for the answer, but I need a little more help here :slight_smile: I can’t get the temp sensor into tuja cloud, but it is available in Smart Life. Only find motion smoke co etc but no temp

Sincerely, Fredrik

Have you included it in your Tuya Project, that you made when you followed the “Setup Homey” in post one of this Topic?

I assume so, but when I read autumn up, I see that it only supports according to the picture :-/ I can think that temp sensors are perhaps among the most common things that you want to have with you. But maybe it will…

Then I assume that you have set up the Homey app and the Tuya project correctly and your project looks something like this:

Do you have more devices in your Tuya Project? Or only this one device?

Well, I have my cloud project but no devices. But I have more switches in my Smart Life app and they show up in Tuya Cloud in my Homey Pro would also like the temp sensor to do the same.

Can you share a screenshot/Snip of what you are trying to explain with "show up in Tuya Cloud in my Homey Pro " ? Is the device you wish to add in Homey, in your Tuya Project with a DeviceID?

If my second question is true, look at my snip, make the flow and fill in the DeviceID in the logic card, check if you get some “timeline” events. If you do, then you can build a “VirtualDevice”:

The cards are in Norwegian, the second card is “loigc - xxxx is exactly xxxx”. The third card is “make a timeline event”

I understand. Try to make the flow I posted.