[App][Pro] Tuya Cloud

Great, this worked and I now receive RAW events. Thank you.

The rest is way too much for my skill set.
I wish I could test the state of the device valve.

1 Like

Oke guys i am lost.

I followed the tutorrial, searched at this community, switcht from SmartLife to Tuya Smart, and still cant get it to work.

Steps i took:

  • installed the app at my homey
  • follewed the instruction to use Tuya IoT Platform
  • used the credentials to setup the app at my homey

The app tells me ‘settings saved, restart the app to make it active’. So it seems to me it sould work. But still no dives to be seen.

Things i tried:

  • switcht between ‘legacy’ / ‘official’ / ‘legacy and official’
  • deleted account from smartlife to tuya smart
  • had no tuya devices befor in homey so did not need to delete any
  • tried West european and Central european zones
  • gave all devices permission ‘controllable’

Anybody any other ideas?

Iam Dutch so respons in Dutch is even beter;-)

Search for “jackass” in this topic, you can use the search button:

There’s a manual in Dutch, created and linked to by user Jackass.

I also posted a YT video, sometimes seeing the expected results can help.
Just search for “youtube” in this topic.

Here’s a Dutch topic if you like

Thanks Peter!

This is exactly the tutorial i followed and afterwords checkt this community.

Sorry i forgot to tell a important message :-o that the homey app is telling me in the timeline ‘You are still using a old depricated API and drivers, please switch to new drivers’

Maybe this can help me?

YW.
Did the YT video show you any hints?

The preferred API should be on “official”.
If I’m right, the timeline msg won’t appear anymore.
If you installed devices when the setting was not set to official (yet), you’ll have to remove them, set the preferred API to “official”, restart app and install devices as new ones.

This was the exact timeline msg which inspired Jackass to write his howto :stuck_out_tongue_winking_eye:
Each and every step in the process is as important.

Somehow you are brilliant! :smiley:

Finaly havent got the message anymore and fould the devices!

1 Like

Nice to hear it works now!

Hi there hope you are fine !

Everything had been working fine for 5/6 months and for the past 2 days nothing has been working, no product is responding. I don’t understand what’s going on, when I execute an action I get the following error:

Cannot read properties of undefined (reading ‘0’)

Can you help me find out more about what’s going on?
I’m using Tuya cloud v1.1.23.

Thanks !

Most probably your iot trial period has expired, and needs to be renewed.
Search post 1 for “iot trial” for instructions.

Tuya should send email reminders for this.
Example:

Hi, trying to get Conecto smart plug working with Homey, When adding the the device, getting screen “New devices found” but empty list and text “Please configure the app first”

I have 2 other plugs and a led string from another manufacturer successfully connected in Homey app. The new Conecto plug is working fine in Tuya Smart app. I can see the device in Tuya Developer platforms project, online and having same data center and authorization for Homey as other working devices.

Any advice what to try next?

Yes, you can search this topic for ‘configure the app first’, there are dozens of posts about it
Screenshot from 2024-05-04 17-54-19
Hint:

After that, remove all devices you already had installed, and install them again. From now on they will use the official API, and not the ‘old’ one.

Not sure what your suggestion would be. I have checked Homey Tuya Cloud apps settings and back then December 2022 when i set up my first device, having all done as instructed (also using official API only)

Since December 2022, have added two smart plugs successfully, first one November 2023, second January 2024 and both have been found by Homey Tuya Cloud app without problems.

I can certainly do the reconfiguration of the whole thing if that is likely helping but has there been some change now after January which would have made my app configurations no more valid?

Edit: had my IoT core trial expired, could this be the cause?

No, it would just ‘cripple’ all of your Tuya cloud devices on Homey, until your trial period has been extended.

Well, check & double check every little step in the configuration.

And… back then, was the preferred API set to “Official” while you added those devices to Homey?
If not, they, or some, still use the old API, which causes the “configure app first” notification.
Remove those devices, make sure the preferred API is set to “Official” and then add the devices again.

Weird thing

Since last days my scenes are disappear…

If I want to choose can select anymore

Is your ‘iot trial’ period still valid?
See post #1 for how to.

Hi. I have checked the code and I see that it should support leak sensor but I can’t find it.

Do you know how I can enable it?

Code is there:

 {
        "type": "leakSensor",
        "category": ['rqbj', 'jwbj', 'sj']
    },

image

Do you have the test version installed alr, Alexis?
It supports more devices.

If not:
@ app store page, hit “Changelog” and then hit the orange test icon:

Now hit “Install”.

Since last week every couple of days the Tuya cloud app does not seem to work anymore (it stops receiving device updates). When I restart my app it seems to work once again, for a couple of days.

Anyone else noticed this recent behavior?

  1. Which app version?
  2. Which Homey model?
  3. What’s the app status when it stops updating? F.e. crashed / unexpected error / disabled.
  4. Are all the app’s flowcards still available in related flows?
  5. Can you show the insights app memory graph of the last 24h
    How to find it:

(Make sure you’ve enabled Experiments > power user)

Tuya cloud app is v1.1.23

Homey pro 2023

The behavior in the app differs per occurrence; once it was running still but trying to “save” settings in the app it gave a super weird error (didn’t screenshot it) until I restarted the Tuya Cloud app, then it worked once again.

Second time (couple of days later) the app itself was still running and even clicking “save” in settings worked but it did not receive any device updates until I restarted the app.

So in all scenarios the app still remains available, including the flows.

Memory week/day;


This is new behavior to me. Can’t recall if it started after a recent Homey update (did it update?)

Hope this helps