[APP][Pro] Homewizard

Hi, will this also become available for the regular Homey? Or will it remain available only to users with a Homey Pro device?

For Athom there is no longer a difference in Pro or non Pro. For software they call it Pro for all versions besides homey Bridge

Guess you have a Pro

All Homey ball shaped units will work with this app. The onle exception will be the puck shaped “cloud” / beta that does not support local wifi connection, hence it is not allowed to connect locally to Homewizard p1 dongle or Homewizard old style appliance.

1 Like

Thanks! The homey website only mentioned Homey Pro, the other mention was Homey beta. But, using the Homey app I was able to install the app and connect to the P1 meter instantly. Great!

Depends; what is your definition of a “regular Homey”?

Which means you have a Homey Pro :slight_smile:

Hi. Installed a P1 meter today. It works well in the Homewizard phone app. However I cannot seem to add it in Homey. When adding a device nothing is found. I digged around the phone app and there is an option to enable “local API”. It seem likely this should have to be enabled. But when enableing this in the phone app, it seems to disable itself again. The next time I go into settings, the “local API” setting is disabled again. The dongle has FW 2.13-sebeta. I saw above that 2.09 is the version that is supposed to be used. But I guess later versions also work. Or?

Is “local API” active needed to make it work?

Homey app version is 2.1.3.

Yes it must be enabled else it won’t work.

1 Like

Thanks. I will contact HomeWizard then and ask why I cannot enable it.

After restarting Homey several times and trying to add a P1 unit SEVERAL times I finally got a hit. Now it is installed. I did not change anything… Could it be that the discovery time is to short and that the info sent from the P1 dongle is beeing sent to seldom compared to pairing time?

Not sure, but are your dongle and homey on the same subnet/wireless network? I for example have dongle on a IoT network (different subnet) than my Homey which is in a LAN subnet. Router in between needs to relay the UDP broadcasts (mdns) to the other end. If there is a timing issue or perhaps a udp repeater/proxy not working properly that could be the issue.

Not sure, eighter. Everything is on the same LAN (for now). Broadcast and multicast is setup as it should in my opinion. I just wanted to bring forward that it took MANY attempts to make the app discover the unit. As it is working now, it is fine by me.

Hi, Is there an ETA when the app is going to work for the Homey (Beta)? I bought the new Homey but after installing it I found out most of the apps I want to use are currently only available on the Homey pro… so quiet a disappointment. If I knew that before buying I would probably have bought the pro version.

This app will never work on Homey (beta) hub. The hub does not allow local WiFi access which is mandatory for getting access to the local api of the p1 dongle or plugs.

Sorry but that’s Athoms choice not mine.

1 Like

Check, good to know! Great work you are doing (also on other apps).

Hi Jeroen,

With the current increased gas prices, just an idea, but
Is it possible to add a measure.gas capability?
Which can show the used m³ during f.i. the last hour?
It’s available in the Youless app f.i.
I know this can be realized by installing the Power OTH app, but I’ve a 512MB Homey and must make a selection of what to install :grimacing:

Another idea / question:
Does Homewizard provide for a high/low rate indicator?
If yes, is it possible to add it to the app one day?

Hi Peter,

I can look in to a measure_gas capability. I see there is a timestamp in the data although a bit strange format (ie. not epoch / unix).

High/low rate indicator I dont understand. I can see there is a “normaal” and “dal” meter set (T1/T2) but there is no parameter that indicates which is currently “active”.

Hi Jeroen,
Thanks for the quick response.

That would be very nice.
I was thinking maybe this is possible, just a basic idea:
Create a ‘hidden’ capability/variable [meter.gas-1h], which stores the gasmeter value also, but only once an hour.
Every hour, do subtract [meter.gas-1] from meter.gas which results in = measure.gas m³/h

Yes, on the actual meter the Normal(T2) / Dal(T1) state is shown, it’s odd it isn’t available in the available data from Homewizard.

I came up with these flows to determine the state.
(I use 2 numVars to be able to compare with yesterday’s meter value)
If…
The power changed
And…
-[Total T1 power] is greater than numVar
[SavedPowerT1LastDay]
-Bool var [DAL_T1_state] is No
Then…
Set [DAL_T1_state] to Yes

If…
The power changed
And…
-Total T2 power is greater than numVar [SavedPowerT2LastDay]
-Bool var [DAL_T1_state] is Yes
Then…
Set [DAL_T1_state] to No

There is a new test version for those that are already trying Homey 7.4.0.RC22. With this firmware and current stable 2.1.3 app version I see many crashes. Hope 2.1.7 in test will cover those issues.

1 Like