[APP][Pro] Homewizard

Dont forget to add rules to allow the http 80/tcp traffic. From one VLAN to another.
So in my case the P1 dongle is in my IoT VLAN and is allowed to talk to my Homey IP.

1 Like

Is that your homey IP? So that means I need to allow HTTP traffic from my IoT VLAN to Homey IP?

Yes by default (no rules) this is blocked so you need to open it else Homey can’t talk to your Dongle.
Be aware mDNS is only for announcement of the device, you still need to allowed the traffic to flow hence the Homey ->> Dongle p1 80/tcp. Homey is initiator so return traffic is fine.

Okay, I’m a bit confused now. From the screenshot you shared, looks like the dongle is the initiator? Looks like the rule says it allows all traffic from IoT VLAN to Homey?

This sounds strange to me because indeed as you mentioned, I would expect Homey to initiate a connection to the dongle. In my case, all traffic is allowed from the Homey VLAN to the IoT VLAN. The only case this wouldn’t work is if the dongle is trying to talk to homey.

Apologies if this is taking the thread off topic. Happy to move it to DM if you want :slight_smile:

I am lazy and just opened all Dongle traffic as I am the developer and need to test and track it.
Just try it with an other IP to confirm if the rule is mandatory or not.
Another thing would be to reboot the dongle to enforce a mDNS on your dongle maybe it stopped broadcasting?

1 Like

Hmm, I’m not able to get it to work. I tried adding a rule on the IoT VLAN to allow access to any as well. Also tried unplugging and re-plugging the dongle. Out of ideas now :frowning:

Get a mdns browser and check if your mdns repeater works from LAN

You’re right. Looks like the mDNS broadcasts are not reaching LAN. I’ll try to troubleshoot this. Thanks for your help with this. Meanwhile, is there a possibly to provide the IP of the dongle as a fallback?


Okay, got it all working :slight_smile:
It was indeed the broken mDNS relay. I removed mdns repeater (didn’t work for me), and instead installed the “UDP Broadcast Relay” plugin. In that, I configured it to relay mDNS, as shown in the screenshot, and then the dongle shows right up in the app. Hope this is helpful to others :slight_smile:

1 Like

This is why I love community developers that help each other. :slight_smile:

v2.1.1 Beta release

  • Energy socket support - Credits & Thanks to denniedegroot

Fantastic. Homewizard on fb told me you were working on it :blush: Thanks! I don’t have the socket yet. What can you show and do in homey with this socket?

This is how it looks like
Icon (off) with 0Watt

Dim level of the green led ring on the unit.

Here half dim

Usage info (Huidig vermogen, Totaal Verbruik, T1 en Fase1). Don’t ask why it has Fase1 and T1 here as this comes straight out of the API. :slight_smile:


Dank je wel Jeroen, ziet er goed uit!

New test version available:


  • Energy Socket support - Credits & thanks to denniedegroot
  • Only update values when changed (P1) - Credits & thanks to denniedegroot
  • Icon and images updated (Energy Socket)
  • Improved mdns discovery


  • Temperature / Humidity offset support (Thanks to Stevenv2201)

Any chance you found a bit of time to add the LED ring option? :blush:

Not really :frowning: But happy to code merge as per last update with Steven who wanted offset support for temperature and humidity.

1 Like

Would really be appreciated to have this option :blush: What exactly do you mean by code merging with Steven’s? Merge it in beta and then make it to the new stable version? Thanks again!

Code is in github. So those with JavaScript/nodejs skils can clone the repository modify it and request a merge with the original repository. Steven wanted offset support for temperature and humidity and added this himself that way. I merged his code and pushed it to the Homey beta/test store.
Maybe I have some time next week but family has priority still with this COVID crap .

1 Like

Thanks Jeroen. I unfortunately have no java script knowledge. I totally understand your priorities. Enjoy the time with your family!