[APP][Pro] Homewizard

Wow, thanks. Homey reboot did the trick. I wouldn’t have thought of that for issues like these, I’ll keep that in mind as a basic troubleshooting step for Homey I guess.

1 Like

very happy user here with the p1 dongle. i would love to have a flow card when power comes above x value on fase 1 etc. with some peak levels hitting my breakers max now i am worried when my heat pump is installed they might blow when multiple high consumption devices start to peak at the same time :grimacing:.
disable my charging when its peaking on a fase could solve that.

I think this is already possible with logic. Flow card, check logic value is greater than etc.

i can not find a token, condition or otherwise that includes the fuse levels. total power does not work since the peaks are concentrated one fuse 1 and the others might still be very low (mostly used while cooking for example)

ah right, in the token values they exist. ill investigate more

Additional to this, my P1 dongle went into unavailable state at some point. I could not re-add it in the Homey app.

Turned out this was because it stopped sending it’s mDNS identification (other devices in my network were still discoverable through mDNS).

In order to solve this I restarted the P1 device by unplugging the USB-adapter (mine is powered by USB because of the older type of energy meter). After it reconnected to the WiFi network it could be discovered again.

@Jeroen_Tebbens Hi, many thanks for this wonderful app! It really helps me making my home more automatic and in particular consume my solar energy as it’s generated.

However, since some time I noticed that my P1 dongle is unresponsive. I since removed it from my devices, and re-added it. The strange thing however is that it supplies no information on my gas meter and total energy consumption anymore. I tried removing and re-adding several times, but doesn’t help.
It still registers as normal in the Energy app itself.

My kWh single phase meter on my solar panels works as intended with this same app.

Do you have any idea what causes this effect? And even better, do you have a fix? Thanks!

No clue. Please sent me both a diagnostic report from the HomeWizard app for Homey and your output from your p1

http://{IP address}/api

Beta/test version:

v2.0.17

Several bug fixes (P1 numbers and values, SDM230 problem, memory leak)
Increase node-fetch module timeout to 20s (to compensate for slow wifi connection issues with Homewizard appliance)
Improved solar panel reflection in Energy tab
Updated manifest & description to comply with Homey/Athom policy
New icons for Heatlink and Energylink (thanks for community sharing)
2 Likes

First of all, great job on this app! Information from de P1 energy device is working very well. One question: is it possible to make a LED ring for the P1 like Plugwise P1 has? Maybe you can ask the developer how he did it? It is a very nice feature where you can see on the LED ring if you’re using power or giving back (with solar panels). Thanks!

Link to plugwise app:

Hi Jeroen,

Since about three days we have received the following message in the Homey for our P1 dongle: “Device Unavailable - invalid_capability_id”

We have restarted the HomeWizard app and Promey but to no avail. In the Homewizard app we can simply read the dongle.

Did anything happen to change, an update? I sent a diagnostic report: 640eafb1-dba2-479b-84c6-3d90f6b442d9

Try to pair your dongle again (remove/add). I can’t replicate the issue as I don’t see it with my p1 dongle. I do recall some software issue in Homey firmware that is currently released 7.1.4.
So perhaps try 7.1.4 first and if not, pair the dongle again.

1 Like

I understand your request. Not sure if I have the time at moment to add that enhancement yet.
I’ll put it to the list.

1 Like

Refresh time? What is the use case? Currently refresh time is 10 seconds which is fine to be honest. Else it app will eat unnecessary resources and cpu cycles.

Sorry, I replied to the wrong topic :joy: I’ll remove it. My request was about the LED ring. Too busy like you :wink:

Somehow the dongle works again. Didn’t do anything to make it work again. I checked the Homey app yesterday evening and there it was. Happy me :slight_smile:

Perhaps new Homey firmware kicked in? Really clueless on cause. But happy that it resolved for you!

1 Like

Hello!

I just bought the P1 dongle. And the dongle and homey are on two separate VLANs. Homey doesn’t seem to be detecting the dongle via this app. All traffic is allowed from homey VLAN to dongle VLAN (but not the other way around). Any ideas why Homey cannot see the dongle?

Thanks

Yes you need MDNS repeater on your router that connects both VLAN’s.
Pfsense has Avahi, Opnsense calls it mDNS repeater. Not sure what flavor router you have but this is what you need.

2 Likes

Thanks! Appreciate the professional level support :slight_smile:

I’ve installed mDNS repeater on my OpnSense installation, and enabled it for both the VLANs, restarted the app on Homey, but still no dice :frowning: