[APP][Pro] HomeKit Controller - for a better Homey

Project started as a way to include the Aqara FP2-sensor via Homekit into Homey.

App is now more generic, many services and capabilities are supported. If you encounter problems, please PM me a short note and a copy of the log where you add the device.

Generic procedure to add a device.

  1. Add your Homekit capable device to the app that came with the device and configure it.

  2. If added with iOS device, remove the device from the iOS Home app, a device only can have one controller.

  3. Most of the time the device can be discovered and added now, using the PIN.
    Additional services are made available over time, as its capabilities.
    As a start the Apple defined services and capabilities. When available some other vendor specific might be added as well.

  4. When entering the PIN and you have selected OK, please wait patiently until the device has been added. DO NOT click OK twice impatiently :wink:

14 Likes

Hi Martin,

thanks for providing the homekit controller. I tried to connect the FP2 sensor today. After a few attempts I got the sensor integrated into my home but the sensor doesn‘t sync anymore. The alarm is permanent active. Do you have an idea how to solve this issue?

Edit: Now is the device disconnected again.

Just pushed test version 1.0.3

You might just start over with 1.0.3 and delete current device and readd.

Thanks. Unfortunately the integration process doesn‘t work anymore in the new version. After entering the homekit ID, the page doesn‘t stop loading.

I know, had a number of reports, have to check why this working flawless at my place. Thanks for testing

Is HomeKit bridge supported?
For example can I connect IKEA Dirigera?

Could you redo test with test version 1.0.4 ?

1 Like

Enhanced code will be released in test version 5.

You will need to add/pair the bridge first. When done succesfully, bridge attached accesories can be added as well.

1 Like

Hi
So i added the sensor and thos is what i get
I dont see zones, movement and no information…
How to fix it?

All good in this case is not good.

What version of the app are you running? Test or Live? Best is to install test
Is the FP2 added to aqara app in iOS or Android?

You can start deleting this device in Homey.
Then remove accessory from aqara app.

Reset the FP2 by holding the button on the FP2 until it flashes yellow.
Then add it again to the aqara app.

If added using iOS then remove it from Homekit in iOS home app.

Add it to Homey.

Enter PIN and enter OK ONLY once, keep waiting until screen with pin clears.

1 Like

Hi
Thankyou for the replay
I am using 1.0.2
Just found out how to update to 1.0.4
Doing it now and delete from homey and aqara and add it all again and will update

Thankyou.

Just did and i think all working fine!

looks good

1 Like

Thanks. The integration works now. I had some trouble with ghosting, but this doesn‘t seem to be based on your app. Some „AI Learnings/Resets“ later, it is more reliable now. :slight_smile:

Version in test 1.0.6.

Mainly support for bridges.

Add the bridge device first, after that bridged devices will show which you can add without PIN.
Might be that sometimes device capabilities are not shown that you expect. (i do not have all devices :slight_smile: )
If this is the case PM me the log and a short description of the issue.

PS. Hue bridges that support Homekit can be discovered by pushing the button on the bridge.

I have a homebridge server with a TPlink plugin. I have this set up as a child bridge. I was able to successfully add the bridge and then all of my switches using the HomeKit controller. Very cool!

1 Like

Yes.

Thanks @robertklep

After trying several times, I could add the FP2 to Homey. :slight_smile:

But I get a yellow “!” (exclamation mark) on the device. Luminance and the zones are available, but most of the do have yellow exclamation marks. Is this a know issue?

This one?

image

In my case this turns up when there’s presence detected in that particular room.

Hi KEvlarD, thx. Yes, I mean this one. It seams, that I don’t get resent updates. Some status is several hours old, even there have been updates recently. I try to trouble shoot tonight.

Install latest test version.

Remove device from Homey
Remove accessory from Aqara
Press Aqara button until yellow flashing
Add to Aqara
If IOS remove from home app
Add to Homey
When PIN is entered, ONLY PRESS OK ONCE AND WAIT.