IKEA Gateway devices not responding in Homey app


I’ve got the IKEA Gateway with a few lights and plugs. Everything worked great untill about 2 weeks ago. The gateway devices become unresponsive now and then.

I tried restarting the apps, cut down the lower. But this doesn’t work always. At this moment the devices are unresponsive for 2 days. And I just discovered that the devices are working when I use the official IKEA Android app. But the homey app gives an error: ‘Something did go wrong, try again later’.

This setup did work for months and nothing changed so I don’t know what the probleem is.

Also the homey app recently started saying that homey is offline when I start the app. When I hit the button try again it works. But this is new, don’t know if it’s got something to do with the problem.

Did you change anything on your network two weeks ago? For instance, Homey relies on being able to use the Google DNS servers ( and, and if you’re blocking access to those from your network, Homey’s networking can become unstable.

Besides that, make sure that your IKEA gateway gets a fixed IP-address in your network. I can’t specifically remember how the IKEA gateway app works, but perhaps it’s possible from its settings page to do a rediscovery.

Have you tried a PtP an the IKEA gateway? After that restart the Homey tradfri gateway app.

I didn’t change anything to the network.

As far as I can see in the Homey IKEA gateway app, the gateway has an fixed ip. Or is that something else?

Yes, the IP-address needs to be fixed in your internet router.

Unfortunally my knowledge isn’t that great. So I’ve got no idea what you mean and how to do it :sweat_smile:

ptp = “Pull The Plug”, what @Dijker suggests is that you unplug the powercord and replug it after 10 minutes os so…

And what @robertklep says is needed for the tradfri app to work as intended. You will have to give the tradfri bridge a fixed ip within’ your router (also known as adress reservation)

O haha, never heard that abbreviation before. I tried that a couple of times. No result.

I’m going to try the suggestion of @robertklep, but then I’ve have to login to my router first (problems with password) :see_no_evil:

Still weird that it worked flawless for a long time right?

I checked the settings of the gateway again, and just to try something I pushed the ‘Authenticate’ button. And then I got the pop up saying the security code was wrong. Weird, because it always worked and I’ve used the qr code a long time ago.

So I put in the security code that is om the bottom of the gateway. And now it al works again. :blush:

Still going to check if the IP is a fixed adress.

It might work for a long time, if you can’t get it on a fixed ip you’ll just have to put in the codes (ip, security code etc. ) ones in a while…

Okay, thanks for the advice. Will definitily try to get it fixed.