Homey pro update to 10.0.0-rc118

This morning (2023-06-27) my homey has been updated to 10.0.0-rc118. . After that, there are red crosses through all devices. As a result, flows no longer work.

Did you PTP?

my first reaction was to reboot the Homey Pro form the menu, that didn’t fix the problem. A quick reboot didn’t work either. A PTP (incl. 10min. waittime) didn’t do it.

so i hope there is another solution for my problem

Are all your devices of the same type (Zigbee, Z-Wave, WiFi)?

i have many devices (Hue. zigbee, KaKu, z-wave, wifi) and they are all off, the Homey virtual devices are still there.

i also see, 3 apps which have the status “gecrasht”

  • Aeotec
  • android TV
  • picnic

after uninstalling the 3 apps above. there were 3 other apps which were crashing.

  • formule 1 and
  • flow checker
  • VD

and after the reboot another 3 apps crashed

  • cupra connect
  • Gallery
  • homeyscript

every time after a reboot and deinstalling 1 or more apps, 3 apps are crashing.


Perhaps one of the developers of the apps can tell you more about why they crashed, if they have received a crash report about it. I haven’t (yet) seen a particular rise in crashreports for any of my apps related to rc118.

HP2023 keeps a copy of the previous firmware on the device, but AFAIK there’s no way to switch to it (I asked on Slack). I assume you don’t have a local backup made from a previous firmware version?

So maybe I am lucky.
Here still 10.0.0-rc.110

Looking further I found the reason but it gives a other problem.

In the web app under updates I found that 10.0.0-rc118 is ready for download and instal.
But I have the automatic update in the green position.

For the moment I shall wait and see.

I didn’t create a local backup, unfortunately.

i also tried to deinstall the crashed apps and than reboot. but that was no solution to my problem.

Thank you for your time Robert,

Sadly it’s not possible to revert back to a previous partition :frowning:

could it be a solution to reset the device to factory default and restore the backup?

Possibly. You can start by trying to do a factory reset over USB and keep the existing user data. It will then just reinstall the (latest) firmware, although I doubt that your issues are related to the firmware not having been installed properly.

Alternatively, wait and see if other users end up in the same situation, in which case it might be caused by a firmware (software) issue that Athom can fix.

Hello Theo, could you please let me know when you have installed 118 and what the result is at your side.

Honestly, your problem now makes me doubt to do it by hand now.
Now I let stands it on automatic.

Lets hope that there is a solution for your problem.

Looks like other users are having issues as well:

Although a PTP seems to have fixed it for most of them.

1 Like

Thank you for this update.

i have done a PTP 2 times now. no success

Honestly, your problem now makes me doubt to do it by hand now.
Now I let stands it on automatic.

My automated update failed (red ring, Homey offline), I rebooted and did a manual install and everything seems to be working for me.

the problem still exists, and if i look at my HP2023 memory (in the android app), i see that all apps show null B.

I have this update 5 days running with not that much devices and app but have not seen any problems.

I woke up this morning with HP2023 on a red light. After PTP it is back to normal. I wrote Athom about it and they confirmed the automatic update did not go well for all. They advised me to do a manual update to rc118 which did go well. Here is the advice from Homey support in Dutch:

Dat klopt. We hebben inderdaad vastgesteld dat sommige devices na het mislukken van de laatste update niet lekker opnieuw opgestart waren. Als de update niet lukt hoort hij weer netjes te rebooten op zijn oude partitie en probeert hij het later nog een keer. Deze reboot lijkt echter niet helemaal goed te zijn gegaan bij jou.
Met een PTP start hij wel weer normaal op en zou het weer goed moeten gaan. Je kan even kijken of hij straks wel netjes naar rc.118 wilt updaten. Je kan ook even bij je updates zeggen dat je nu wilt updaten.
Mocht hij weer een rode ring geven na de update laat het dan even weten en stuur ons nog een rapportje na. Bij de meesten gaat het goed / is het goed gegaan dus de kans is erg klein dat het weer mis gaat.

I found a new issue:

Cannot save an advanced flow that contains the card “When sun rises”.
Red pop up card saying “homey.getmanager is not a function”.


I notified Homey support and this is their response saying they are aware and a fix is upcoming:

Hier zijn we inderdaad van op de hoogte en de fix hiervoor komt mee in de volgende firmware release!


my HP2023 is running 118, and the issue started with this build (this morning 2023-06-27)) and all apps do not start (even after the PTP). it was an automatic (scheduled) update (not manual).