HP23 first time a red ring this morning

This morning my Homey Pro 2023 was not working and it had a solid red ring…

I rebooted the device (disconnected power) and it started again…

With my former homey (19) I never had this before, not sure what caused it, but i only have the HP23 now for 1 week (and started from scratch) and now already a red ring…

Is there a way to find out why it had a red ring or what caused it?

Did it update to rc118 last night?

I myself did not do anything, it went offline somewhere between 5 and 6 oclock this morning, not sure it updated or trying to update itself, there is no message etc what is reporting that something went wrong, but it is currently at 10.0.0-rc.110

Probably update to latest RC118
You may want to check System memory in the insights (if you have enabled Experiments - Power user), but anyway, there might be many reasons.

interesting, I had the same solid red ring this morning. I had to reboot the HP twice until is was back. Still on version 110. I disabled automatic updates for now.

Btw, Athom gets notification when the RED ring occurs, so if there are more of such issues, there are already looking on it.

I have some kind of similar problem. more info:

Homey pro update to 10.0.0-rc118 - Apps - Homey Community Forum

Experienced the same this morning (red ring). PTP fixed it and as expected there was an update pending. Probably tried updating during the night and failed.

A manual trigger to update to xx.118 after successfully worked.

I just unplugged it and replugged it (5 secs) and it booted up, luckily not needed a PTP
But i cannot see any indication that there is a update or it failed updating.

That is a 5sec PtP

I experienced exactly the same. I had auto update turned on and 10.0.0-rc.118 was available but apparently it did not install properly. I was still on 10.0.0-rc.110

I made a diagnostic report after the ptp and made a support ticket for Athom to investigate :grin:

I had the same problem at release of 10.0.0-rc.118. I unplugged power for about 10 sec, plugged in again and it boot up with still existing 10.0.0-rc.110 without issues.

After that I could download and install 10.0.0-rc.118 manually with the app as it should be.

Do you guys recommend to disable automatic updates (I also had a red ring which was solved by quick ptp)

No, newest auto update to 10.0.0-rc.122 worked successfully.

Apparently i still need to receive the update to rc.122
However, i do not know what is happening but i am struggling with Zwave network and I am loosing connectivity to some devices.
In the night of yesterday i lost two fibaro walli roller shutters that were working no problem and then this morning are suddenly unreachable.
This is very annoying because in the last week or so i had at least 3 or 4 devices loosing connectivity.
I opened a ticket with Athom but…anyone experiencing the same?

@Peter_Kawa what do you suggest in terms of turning automatic updates off? Does this help with system stability? Thanks

At least you don’t get ‘surprises’ when you install updates yourself, and when you have time to solve any issues that might come up after updating. I prefer to use auto-updates as little as possible.

I’ve experienced issues with updating my old Homey Pro’s as well. One update to 8.1.5 failed and killed my Homey. I had to reboot into recovery mode and install a backup. Then it worked again.

On the other side, HP23 updates works completely different way… so it shouldn’t happen.

So far no Homey Pro update has really killed my Homey entirely.

However, majority of updates have somewhat negatively impacted my Zwave network with multiple devices being disconnected or unreachable as a result. Among other things I noticed that also the android location services dropped and working inconsistently.

Net I have now disabled the automated update because if an update eventually happens when I am on holidays and i still need/want to control my home remotely i do not want to have issues.

At the same time, the question for you and @Peter_Kawa is more around: once you disable the automatic updates - when do you actually do the updates? Do you wait a period of time to ensure that all the bugs of a certain update have been fixed? If the updates have a negative effect on the zwave network i think that disabling automating updates will never eliminate the negative impact it will just make it happen when we decide to have it rather than when pusehd by Athom…

Any view?

Most probably the option “Full software download” works as well. Saves you the backup install hassle.

Often when it’s a buggy update (or a certain app or protocol is affected) there will be messages of users on the forum and Homey channels pretty quickly. In other words, I let others do the tests :blush: :blush:
When I think it’s ok, I install the update.
Quite often I install the RC updates as well, or when there’s a fix or feature I like/need, I just install anyways and take the gamble. With RC updates you can revert to stable.

When you see posts about f.i. zwave is going down after an update, you can just skip the update and wait for a fw update which should have a fix for it.
There are users who never update, but at some point in time you’ll have update, to keep everything up and running (like EOL SDK1 → SDK2 upgrade)

Other advantage when you install updates yourself, you can (try to) fix any issue on the spot, instead of waking up / coming home (from a vacation) and discover nothing works.

To me it is still a mystery why auto updates are (still) not downloaded and announced up front, including a day/time picker, so we can pick a convenient time for it to install.
It’s pretty common in other environments / OS’s