Homey losing internet

Homey is disconnecting and is unreachable from internet every few days , i have Lan cable connected.
after power off and on its back, but i do not want this issue how to avoid ?

this is very anoying and i cant have such unstabillity its no good

Like having uptime >>xx hours ? How many hours ?

Does the LED have any color prior to PTP ?

It’s not, indeed - have you contacted support, providing system diag. rights after restart ?

You may want to consider installing sysinternals tool and add then two devices - Homey 2023 and Alerts.

Then, when the issue happen again, you can check some insights from sysinternals, like temperature, free mem, undervoltage etc - it might provide you some additional insights.

Also if you see that Homey is still controlling your smart home just not being reachable on the internet (eg. you don’t see for example RED ring LED), you may consider to implement some flows based on eg Net Scan App for Homey | Homey or Network Check App for Homey | Homey

1 Like

Led lights look normal the same as when it is operational and nothing wrong Colorfull

I`ve come to the solution that is you have a mesh system, disconect WIFI and only use esthernet cable since mesh can cause the disconect issue. Worked for me :slight_smile:

Its on LAN cable … not wifi

And any comments on the previous suggestions, have you implemented anything from it ?

1 Like

Just stumbled at this workaround, with a Homeyscript, below.

Somehow keeping the connection active might minimize the ‘offline’ crap.

Which is in theory the same as: regularly checking an internet site by means of one of these apps
As proposed alr. by mister @Sharkys :facepunch:

1 Like

Actually… Script enabled = no cloud connection outages, script disabled = at latest over night it’s offline.
Let’s see when Athom responds to my support request as I’d point them to those findings. But 2-3weeks response time… means to wait… Hopefully it helps to pinpoint the issue then. At least implementing such a “connection keep alive” probing in their software as workaround should be easy enough to fix it for most of us without those flows and scanning this forum.
In the end it means that there’s some keep-alive issue, tcp timeout, DNS caching, sporadic network stack outages or whatsoever that one can prevent by regularily emiting calls to the internet that hopefully can be found with more data. In a way I suspect DNS caching or related, because I can prove that it’s not the network connection that get’s lost given that local mobile app can access and Homey can still access local devices, it just cannot connect with the internet. So the network stack itself must be up and running , TCP connections even outgoing do work so as long I do have internal IP-based request, but something that’s required for internet connections fails and DNS resolution could be the culprit… I’ve also seen DNS rebind protection of routers as part of other posts… I might also try to actively exclude homey’s IP from that, but that’ll mean that some cloud connection concepts are severely messed up, if one would have to tweak such router settings meant to secure things.
Currently the script executes every 10min. Probably i’ll also adjust that to have it less frequent and continue testing to see where I hit caching or timeout limits. Would be much easier if one could see Homey’s internal logs…
Actually thinking about returning my Homey puck as having to diagnose this and find workarounds myself is not what I bought a Homey in contrast to setting up a Raspi and stuff myself in first place…

1 Like

Well, OK, that is obvious.
It’s odd though, while my Pro 2019 only throws the offline message when it’s really busy (i.e. a misbehaving app or too many Homeyscripts triggers), it’s pretty rare.
No clue why it’s successor has these silly issues.

My concern is, Athom definitely doesn’t get the real issue, looking at this FW update below;
Because the actual local (wifi) connection is almost never the issue, it’s the cloud connection.

They came up with this update because of the “Homey is offline” bug


Yeah it’s one of the annoying cons of Homey, we aren’t allowed to view the logs of our own Homey


Well, it’s how one’s looking at the product. It’s so many devices into one package, and not a one trick pony.
The way I look at Homey, it is a home computer, with hard- & software flaws… an ongoing process of bug-fixes, improvements and new features. And, besides the purchase, with no additional costs.
Nothing new compared to the Pro 201x series.

You can see the charm of it, or you hate it.

Not necessarily, there are also actual issues with the WiFi driver :man_shrugging:t3:

2 Likes

I have a Homey Pro 2019 sitting in the same local network. Never had any issues with offline cloud connectivity and no workaround probing on it. The only issue I had/have with 2019 is that it’s running low on memory and it needs to be restarted nightly since a few month. Guess if getting close to minimum free heap it’s no good and it drained more and more and AC adapter rumors are also obscure at best. No clue if this ever was linked to number of devices or flows I had.
So even if it had any connection issue with the older Pro 2019 I’d probably not notice it. Wanted to have more RAM for all the apps I have and so I upgraded. Now hesitate to migrate everything suffering a different issue. Didn’t give up yet and hoping for remedy, but poking around in the fog to figure out what could be done consumes time. Pretty sure you’d see something in a log. The charm however is definitely the number of apps, the flows and the broad support of devices that makes up for much.
Meanwhile I raised the probing frequency from 10min to 30min. Let’s see how far I can push it. Not that Chuck Norris quotes sent to a syslog server serve a higher purpose :wink:

Unfortunately RPi is not cooperating :frowning:

1 Like

Yesterday I changed me Internet probing from 10 to 30mins frequency. At 21:00 last probe according to syslog event, I have another flow that emits syslogs every 15secs to my NAS and that stopped at 21:17. My Fritzbox also says Homey’s network connection was last active at 21:17. So it just dropped out of the network at that time, completely local & cloud. That’s new… :frowning:

Great… Tried to restart/unplug/nothing. 21:17 must be the time the approx. 1month old Homey Pro 2023 original AC adapter died. Had to use another adapter to boot. Next support ticket to come… :frowning:

Reply was swift within minutes. New adapter is on its way from NL to DE.

Can you elaborate on “original AC adapter died” ? Like there was no voltage on the USB at all ?

As far as I can tell: No voltage at all. No homey ring light, no reset pin reaction, nothing. At least it didn’t charge another mobile and tablet, no matter what cable. Didn’t use a voltage meter though fiddling with the pins and my USB VA stick is USB A only and I didn’t have USB C-A adapters at hand to fit for the Homey AC adapter which is USB-C female. As I had a USB-A-to-C adapter I could use another AC adapter with 2,0A max (used one of a UE Boom) and the USB meter says it’s idle at 0,69-0,7A at 5V with the Homey ethernet adapter in between.

1 Like

However unfortunately setting the probe frequency from 10min to 30min caused Homey to loose internet connectivity again over night while local connection was still up and even my NAS was still receiving all internet probe syslogs every 30mins, with other syslogs every 15 secs. So restarted using the mobile app (which is usable thanks to local connectivity at least instead of unplugging…) and will change the probe back to probably 15mins to check further.
I’d somehow need to script access to the web app from another system, like my NAS, as I’d be interested to “see” it go offline from the other side and when. If related to Fritzbox Internet DSL nightly reconnect the providers enforce or something…

Do you know if your internet provider uses CGNAT? In other words, when you visit a website like https://whatismyipaddress.com/, does your IP address(es) change over time?

CGNAT. Not sure. It’s 1&1 in DE with DTAG for the last mile. Afaik they always had enough IPv4 in their address space to avoid quirks when other providers had DSLite/Dualstack stuff that made it difficult for home server users. My Fritzbox is connected with IPv4 and IPv6. I’m using dyndns for years without issues and the Fritzbox takes care of the updates. Basically the IPv4 address can and does change, but only during the nightly DSL reconnects that afaik all providers here use and hence the routers automatically do that around 3-4 o’clock so one’s offline for approx. 10secs.
However as far as I recall I experienced Internet connection outages of my Homey even during the day as well before running my script, so I doubt that it’s the DSL reconnect.

1 Like