Homey Pro 2023 - Regularly red light and unavailable

Hey all,

I’ve received my Homey a few weeks ago and am a first time user. I notice my homey system is unresponsive for a LOT of times. Up to the point I’m starting to doubt my purchage. Is it normal homey keeps crashing or disconnecting? I run a unifi network, so in the dream machine I can see it losses connection a lot of times. (yes the signal is good, it’s the only device that’s not stable in the network) When I pull the plug to restart I, nearly always, get a red ring. Sometimes I restart it 3 times to see it come back online.

I’ve received a defective charger which is already replaced by athom (5.2v).

Is there anything I can do or check? Are there logs or steps I can or should take?

Is it not but believe me that Athom works hard on addressing all the issues.
I hope you have submitted diag. report to Athom, right ?

In any way, you can go trough similar topic and little bit longer explanation-insights-tricks I have provided.

Isn’t Homey hopping AP’s frequently?
Did you create separate SSID’s for 2.4 and 5GHz?
To force Homey to ONE AP, try band steering, MAC filtering or transmit power settings

:slight_smile: Now yet, but I will, I should.

Thanks, No, I’ve locked the AP. Yes, I’ve got separated SSID’s for both frequencies. And I think bandsteering is set automatically with Unifi, but since I’ve locked it to one AP it would not matter, right?

Hmm this is annoying. I’ve tried to stealthy introduce my SO to a smart home. But she is the one constantly discovering the crashes. “why is this not working, why is that not working”. She became my crash watch deamon…

I feel like I should try to buy the POE adapter to create a wired Homey. But that adds to the costs and I feel kind of forced to buy it and add shipping costs. But on the other hand I’m curious the Homey will be stable with wifi disabled.

Ah I see you run the test lab live at home :stuck_out_tongue_winking_eye: :stuck_out_tongue_winking_eye:
To me it is a mystery how a brand new Homey just won’t work well with Wifi. I’m sure it still is a matter of tuning.
But, on the other hand, how many wifi problems (including the classic Pro) I’ve seen here, I would’ve included an ethernet adapter with the order without blinking.

Funny fact, I have a classic Pro, with no wifi issues whatsoever since day 1.
It only ‘chokes’ when (a) app(s) start to use over 60MB’s, somehow it affects Homey’s wifi.
I may hope this problem is not “migrated” to the Pro 2023…

Right, I no way near being an expert, but it feels like the Pro23 might have wifi (antanna placement) issues. I’ve got 20 devices on my wifi. Only the homey has hiccups. Plus, it’s right under the AP, within 1m.

Having that said, come to think about it. It might not be the wifi at all. Right? IF the wifi has bad reception. z-wave would still respond, right? Switches and stuff should still work without the wifi. The thing is, nothing works. But wifi is the only symptom we users see, since the app won’t connect. And yes I see downtime in wifi in unifi, but it’s also down when it’s off. Sooooo.

I know the power is also an issue. Hence the 5.2V apter replacements. But what if it’s still not stable? I’ve got the same results with a default Samsung adapter as the original 5.2V Athom adapter. Which gives me the idea that A, the problem is/was not the adapter. Or B, the adapter is still bot stable enough.

Am I correct I’ve seen the Homey runs RPI? I’ve got several RPI’s that crash on groundloops. Say, when a drill starts of a large amount of fluorescent lamps.

It’s too bad I can not replicate a crash. With my RPI’s I’ve added an UPS. This solved the groundloops and power dips. If you can replicate a crash you can test with and without UPS. If it’s a power dip you can add an USB with a capacitor? Going way outside my field here :slight_smile: Just spitballing


RED LIGHT means that the Homey Pro container crashed, it shall self-reboot within a minute or so. Is this the case ?

Also have you installed already Sysinternals app and added two related devices ? Have you enabled Power user in Experiments, so you can check more diagnostic data in the insights ?

Hmm nope, your message made me checkup on my device. had been offline for over 24hours now. So, no, it does not reboot. No red light either. I notice the red light is not always on when it’s unresponsive. I’ll turn on the ring screensaver again. Thought it was annoying. But maybe it will give me some feedback when it turns unresponsive. (read: I don’t know if the screensaver stays active when unresponsive, now it’s just off)

  • Sysinternals app installed, yes.
  • I don’t know what you mean by that. I don’t know what related devices are
  • Power user is enabled
  • Diagnostic data in the insights, what can I expect from this? I see no logs or other insights here

Not needed - the RED light shall come up even without enabled screensaver

Add new device after installing Sysinternals and choose Sysinternals - you will then understand.

App/CPU utilisation, you will see there also sysinternals insights from the device you will add etc.

Right, turns out I had this all already in place. But the utilisations are not very insightfull, euh right? I mean the CPU, RAM and Temp are never maxed in last 8 days. I have no flows for the alarms, but no internal alarms where raised in the last 8 days.

You can share then insights of uptime, free RAM, loadavg 1min, temperature and CPU frequency ?
Ideally with required resolution, eg. not for past 2 weeks but select some shorter period.

Like this (maybe we will spot something)

(please note this is example only, don’t look on my values :wink: )

Whelp, first I had a bug to report :slight_smile: Insight crashes on field input.

Sure --Edit 2: replaced screenshot–

---- Edit ----
Oh, I just now see it only renders two days even though it’s set to a week. Or does it render a week starting from monday?
I wanted to make a render for a longer period but:

Would there be any usefull logs when connecting to Homey via SSH?

Nope, it’s isolated container unfortunately

Looking on the Insights, it would be more useful to have higher resolution, like last 24 hours during which Homey crashed. Unfortunately your last Insights for last 24 hours ate useless as Sysinternals got stuck / not updating data after restart. I have workaround for it, when Homey starts, restart Sysinternals… now you can restart it manually and wait for Homey when it will become unavailable.

btw, you have new power adapter?

As you can see the Homey was offline for about 28 hours. This is also to be seen on the unif (network) log when it checked out of the network.

Yes, I’ve got the new 5.2V adapter. It was even already been replaced by Athom, so second 5.2V adapter

Btw, newest experimental fw released… Homey Pro (Early 2023) Changelog | Homey …so you may want to try.

Similar problems here.
Homey Pro is offline many times a day.
Some minutes later it is working fine.
Connected on WiFi. Delivered one week ago.

It might be similar yet without all the relevant details, it could be caused by something completely else.