Help with 2019 to 2023 migration - ZigBee

Hi, please maybe I missed something because my English isn’t so good, but I tried to migrate from 2019 to 2023.
I turned off the 2019 and turned on the 2023, selected the backup from last night and than has everything installed and so on.
After that I found that I need to reinstall many apps because devices hasn’t work like some Zwave devices. But the mainly problem is with the ZigBee devices. They couldn’t they repair. It only works if I delete it from Homey and add as new devices but the try to repair function doesn’t work for me it shows that he is recognize the device but after that show a message that at takes to long and stop adding. If I remove the device and add it as new it works, but if I do that it would lost the devices from flows and I can’t imagine reconfigure all flows…now I have connected back the old 2019…is there something that I have made wrong?

Thank you

Zigbee devices not responding after restoring a backup

Each and every Zigbee device needs to be send a repair command to start working on your new Homey Pro. To do so you can go to the device settings on the Homey Mobile App and click “Try to repair” under Maintenance. In the Homey Web App you can right-click the device tile and click repair.

And with Google translate.

Zařízení Zigbee po obnovení zálohy nereagují
Každé zařízení Zigbee musí odeslat příkaz k opravě, aby mohlo začít pracovat na vašem novém Homey Pro. Chcete-li to provést, přejděte do nastavení zařízení v aplikaci Homey Mobile a klikněte na „Zkusit opravit“ v části Údržba. V Homey Web App můžete kliknout pravým tlačítkem na dlaždici zařízení a kliknout na opravit.

This means that after the migration you go to, for example. to the web app,, click with the right button on a non connected tile en click repair.
Then do what is shown on the computer.

I clicked the try to repair button in the app in my phone it tells I should bring the device to pairing mode, I made it and it shows that the device was found but on the end shows that something went wrong…
So it seems homey recognized that there is a device in pairing mode but can’t repair it

Is it a 230V powerd device or a end-device?
Start with the powerd devices.
If it is a end-device keep it awake by pressing the pair button every 3 seconds or so.

I tried the battery devices. I tried 3 pieces.
Because it hasn’t work I disconnected the 2023 and connected back the 2019. So I will earn more information and try to do it again on Sunday

No problem.
Good luck.

This might be an already known problem:

I’m already in contact with Athom support and they said, that they will fix it in the next firmware update:

If you don’t want to wait, you can delete the Zigbee devices and add them new. But all flows will be broken.
With this script it seems to be possible to repair all flows after re-adding the devices, but I didn’t tried it myself;

1 Like

…ok but also with the script it takes many time to readd the devices I have 90 ZigBee devices running on 2019 :thinking:

That’s not something you can work around, HP2023 has different Zigbee hardware than HP2019 which means repairing each device is required.

I know that about the hardware, but when I do the migration the list of ZigBee devices is empty. Zwave devices are there but no ZigBee devices. So therefore I think the repair function doesn’t work. I am satisfied with the repairing each device no problem but it doesn’t working for me.

Read @DirkG’s post, they link to a script that may fix your flows after removing all your Zigbee devices and starting new.

For some people, resetting the HP2023 (back to factory settings) and restoring a backup again also worked.

This is the same error as mentioned in the linked threads. So actually there is nothing more to do than:

  1. to wait for a fix from Athom
  2. delete all Zigbee devices and reset the Zigbee network on the HP23 and
  3. use the script to repair the flows

I did it also several times and it worked not for me, also via USB-Tool under guidance of Athom.

Same here, the devices are there (in device and flow tab) but not on de zigbee developer page. You sure repairing them won’t re-add them in the network? (still have to try myself :sweat_smile: - mostly temperature sensors, not really missing them)

I’m sure, yes. Tried several times. Did also several times a factory reset with the pin like it’s explained here, and also with the USB-Tool like it’s explained here.
It’s no problem to add a new Zigbee device, but it’s not possible to repair them. But try it out yourself, there is nothing what can go wrong. And you can go back to HP19 (or earlier).

Fantross has right. Same by me.
I am today on it and will do some research, but i am sceptic…i thing i would not go over the delete all and pair them as new :frowning:

After many resets, backup restore and so on I finally went to the version to delete the devices and start add the ZigBee devices one by one as new including repairing flows…it taken the whole Sunday and I have about 75% done…I have the PRI since April at home I thought now will be the migration easier as in April but wasn’t …so I will bring the last 25% to the end and hope it will all run better as on 2019…

(I have over 90 ZigBee devices :thinking:)

Yes. I ran into the same problems too. Left my new Homey in the box for some months. Todat was the day. But without succes. Now trying to get my old Homey up again. Hope nothing is ruined. And than wait for the Zigbee fix.

So the next version they refer to is not the current stable 10.0.3, I guess? The changelog does not show the date of release, but there’s no mention of this specific issue, so I guess that means they refer to some future version.

I’ve been holding off on migrating to the new Pro for months now, but I guess I’ll have to wait a bit longer. The chore of updating ZigBee devices is bad enough (physically accessing them to press the button), so at least this bug needs fixing before it is worth even trying…

1 Like

Seems like the fix is not there yet. I have same issue and definitely do not want to spend time adding all devices as new ones.

This should really have priority, as migration is very important to many people. I guess this was working in some older version, as many have reported successful migration in the past.