Google Nest SDM

Hi Martin, I probably misinterpreted the wording in the initial message on this topic; apologies! Happy to hear, I’ll set it up this weekend :muscle:

They became available a while after the initial app was released, almost all of the things are supported. :grin: Have fun!

Martin Verbeek

Hi, is it possible to change in an update to make nanoleaf react faster than 30-35 seconds?
maybe 5-10 seconds after protect detects smoke?
I make a video

Hi Martin, small question… first Nest protect works like a charm. now I added two more Nest protect to the house. but I can´t add them. to the rooms. First idea as they are connected only one can/must be added. Second idea I must bring them “alive” so that they will work. Third idea I must update the legacy?
Fourth idea I don´t understand how google works, In the Nest app they all show up in the correct rooms.

Thanks for help


Hello Till, should be able to just add these devices to Homey. I guess you already tried add nest protect within the homey app, could you do that again and see if any messages appear in the log of the app?

You could try and get a new legacy code, but that should not be needed.

What do you mean with bringing them ‘alive’, they are already installed for NEST i assume?

Hello Martin,

here comes the screen shot:

what version of the app are you using?

Version 6.3.0 guess that is the problem… :-)… must I delete app and than download again from HCS??

If you only run nest protects it is easier to delete the app and install latest version.

Be aware that the procedure for getting authorised is completely different, but many have already done it. Just follow the guide precisely.

Martin Verbeek

Thanks …tried… but no chance for me…I skip Google protect… :slight_smile: …for a person not working in the field really not easy understandable… get to point six and than nothing happens… not your fault…will try out HA :slight_smile:

HA has almost the same procedure.

Martin Verbeek

True… seem easier but last step at HA…don´t know what happened :-)… I skip Protect than…

Hi @Martin_Verbeek , may I ask you, does the Nest Protect trigger in Homey Smoke alarm even for “warning” level (amber light) ? It just happened today 4AM (yep…) but Homey didn’t recognize anything - maybe 4min were not enough as I immediately silenced it via official app , I just wonder.

And Happy Christmas !


Need to check but I do not remember having code in place for that…

Martin Verbeek

1 Like

I previously had this app working.

however now then i try to configure i get the following message upon login:

{“success”:false,“message”:“OAuth2 Session Already Used”}

Ive tried to make a new api / 0auth as wel, but same problem unfortunatly

What version are you running, i am having an issue in the move from 6.x to 7.x which probably is causing your issue. Quick fix is to go back to 6.x and logout and login again.

Thank you for your quick reply!

Ive installed 6.4.x but unfortunatly i get the same callback when pressin “log in” a browser window opens saying {“success”:false,“message”:“OAuth2 Session Already Used”}

Made everything brand new, but no luck

Can you pm me a piece off your log around that error?

Martin Verbeek

even better. i will post the sollution.

I had the homey app on my chromebook. i found that i couldt select the log. so i pulled out my phone. i cleared the log and tried to log in, so the log would only contain the fault. as the screen with the above message popped up, the same screen opened on my chromebook…

I closed the homey app on the chromebook, logged in via the mobile app and voila. been 3 days of trying :sweat_smile:

Again thanks for your fast reply! keep up the good work!