Google lntegration lost and can not be repaired (other then reboot modem / router / Homey): Athom is aware

Since yesterday, maybe the day before, I am not able to integrate Homey with Google. When I set the integration on, I get a message that there appears an “Internal error”.

Restarting Homey does not work.

For the context: this integration is working for years now, so it’s not a ‘new’ integration. Nothing changed in my Google Home environment either. All settings and needed connections are (still) defined there.

By the way: what is it that after updates on Homey the connection with Google is lost (in most cases). Is there a solution to fix this with a flow?

Hi there,

I have a clue what is triggering this error situation. I think it is caused by Rithum. Issue with refreshing Rithum descriptions (regarding updates on Var tags)

See topic about the refresh rate of Rithum, latest version (3.2) where you can use variables in the descriptions. Cool if it works, but it doesn’t quite yet).

Rebooting my router solves the problem with Google, which eliminates the ‘internal error’ situation. However, 1 or 2 days later, it is back.

I have reported this also at Rithum support, so if you experience the situation above mentioned, AND you use Rithum, let’s follow the progress on that (Rithum) end.

To be continued.


UPDATE 24-12-23: I have deactivated the functionalitry in Rithim and the Homey-Google connection still is lost after some hours after rebooting the Modem/Router. So it seems there is no direct connection between the Google issiuee and Rithum 3.2.

Q: Am I the only one experiencing this problem? Does enyone know what causes an “Internal error” in Homey?

I already tried to escalate the issue within Arthom, but if this is seen as such is still not certain to me.

What is, is that I have to reboot modem or router every few hours.

Please respond if you have any clue how I can see what causes this, or share your irritation or solutions if you experience(d) the same.

Thanks, Michel

Same issue here.
“Internal error encountered” when trying to resync my Homey with Google.
Rebooting Homey solves the problem temporary. After a few hours the error comes back again and I cannot use Google anymore for giving voice commands to Homey.

Have you all contacted Athom support? Obviously it’s nothing community can help with…

Hi @Sharkys yes I have. They come up with the usual answers about basic settings. I have already told them that they need to escalate to senior developers within Athom. The ones that now what triggers this ‘Internal error’.

The community can respond by sharing when they encounter the same problem, or have a solution, or a hint. That’s what a community is for, isn’t it?

@Roel_van_de_Kerkhof You make my day!! Thanks for sharing, and welcome to the Homey Community! I was really beginning to doubt whether I was the only one and that it was somewhere a problem in my configuration.

It sucks by the way that this is happening. My wife isn’t into automating our home and therefor relies on being able to speak to Google. Now this is unreliable at the moment.

I hope more will share that they experience this problem. This will raise the escalation possibilities within Athom. Reporting it yourself at Athom is helping the best off course :wink:

Enjoy this Christmas day!

1 Like

Hi, I have the same problem. Think it started happening 1 or 2 weeks ago. Every day connection between homey and google home is lost. Restarting Homey solves it but next day it lost again. It’s prettty annoying because wife and kids rely on google to operate the home automation. For know I am going to see if I can make a flow that restarts the Homey.

Hi @Prom welcome to this community and thanks a lot that you havce shared that you experience the same ennoying issue. Restarting Homey, in my case will mostly also loose the connection with Google Home, but at least it’s a working solution for few hours to a day, once the connection is restablished.

I had the same idea, so why not.

Let’s all also report it @ Athom! The more issues reported, the higher the chance of a succesfull escalation within Athom for a solution.

Thanks upfront and we’ll keep each other posted!

I will let Athom know via my support ticket, that more experience this problem and will sent them a link to this page.

@Doekse any thoughts please ?

I just had a look at my settings and I was getting the same error. After reconnecting Homey to the Google Home app (under the Works with Google tab) and then completely closing the Homey app I could re-enable synchronisation within the setting in the Homey app.

My devices kept syncing whilst it was apparently “turned off” within the Homey app. I do switch between stable and beta builds of the app a lot so I don’t know if my scenario is anything to draw conclusions from :thinking:

Anyways! I’ve flagged it to our support team as well.

1 Like

Hi @Michel_Bos. I had the same issue. My connection with homey was lost within Google Home. My solution was to remove Homey from Google Home and reinstall the app. After this i was able to synchronize with google within Homey. Hope this helps.

Thank you @Doekse …btw, I have slightly different problem. Favorite flows do not work - it says that Homey is unavailable when I try "Active flow … " , while however I see and can control ALL Homey devices within Google Home and “Sync my devices” have no positive impact. I observe this issue for like 3 weeks or so. Just in case it would be related, that time as workaround I was also disconnecting fully my Homey and reconnecting it back - again without positive impact on favorite flows. It’s kind of strange.

Now I found out that Sync my devices has lower success rate for flows - see example - there two got failed and two seems to be right… ?

For @Doekse, same error here. Unable to sync with Google home.

Ps. After trying to reconnect in Google home I get the message: “Could not reach Homey. Please try again”

Did some more testing. I’ve found that the Homey app was unable to communicate via mobile data. That could explain Google home is unable to connect.
Reboot of Homey fixed the problem, but for how long…

@All thanks for responding. It sucks that we have to find workarounds in stead of Athom presenting them to us.

Disconnecting Homey from Google Home also means that devices will be lost in Google Home, aren’t they? I still would like to know:

  • Is this a permanent solution
  • What caused this situation and
  • Who can tell that the trigger for it is gone once you disconnect/reconnect Homey to Google Home.

Response from Athom btw: My ticket is closed, for the support desk can’t do anything more. Issue is addressed to the developpers, but since it is Christmas time, it might take a while. The will re-open the ticket when there is any news.

Update 28-12 9:44 from Athom: “Het is ons inderdaad bekend dat meer mensen dit probleem hebben.” (We indeed are aware that more users experience this problem.)

Does anyone know/have experience with escalating within Athom? For this is not satisfying at all. Thx upfront.


There is no escalation option, but since they are aware, I would suggest to be more patient - if they are aware, thry will be looking on it for sure.

Hi all,

I notice, getting sick from restarting Homey again and again, that if I don;'t restart Homey, the connection with Google seems to reconnect by itself… Does anyone experience the same?

I did not have any problems after auto reboot my Homey at 4am. But this morning I got an email message from google that noticed me that my account was used to connect to Homey. This got me thinking the connection is working (maybe) again. So I will disable my auto-reboot and see if the problem is solved. I’ll keep you posted.

Pffff, I think it was a lucky one. Maybe I thought I didn’t reboot it, but did anyway…

What I’m saying is: still not working.

@Prom Did you had any luck? Is it still working or did you already re-activate your auto-reboot…

I’ve turned the auto reboot off. For now it’s going ok. But let’s wait another 24 hrs. Hope it’s ok now. I’ll keep you posted.