Issue with refreshing Rithum descriptions (regarding updates on Var tags)

Hi there,

since last month, version 3.2 of Rithum has been released, making it possible to use tags (variables/text) in the descriptions of the screen options. Great feature!! Long be awaited!

However… the variables, although set right in Homey, are not always updated in Rithum.

Does anyone know if there is a kind of refresh rate? Or sequence? Update rules, or whatever…Or can I do something within a flow to push the right value to Rithum?

Hope someone knows or has it figured out :slight_smile:

Thanks upfront!

Hi all,

I have also reported the question Rithum Support Tghis is their answer:

Grant Sloman (Rithum)

11 Dec 2023, 11:36 GMT

"Rithum polls Homey for changes every 10 seconds whilst the screen is not in standby, once a minute whilst in standby. Therefore any change made to a variable on the Homey side should be reflected within 10 seconds.

We’re not aware of any issues with that, but if they’re not updating then please do the following for us:

  • Enable System > Network capture
  • Change the Homey variable
  • After about 20 seconds of the label on Rithum not being updated, do System > Send Report
  • Let us know when sent, along with your serial number shown in System > About"

Update 15-12-23: Since itt didn’t work I have sent them a report and a part of my advanced flow. They have analyzed my input and concluded:

“We have made a fix to the Homey plugin for the problem of the labels not updating and also implemented a fix for the Sonos issue in main switch firmware. Your switch has been updated with these patches.”

The patch for the Sonos problem (not mentioned here) did work, but the other didn’t. To be continued.

Hi there,

update: the fix still isn’t working. I encountered some collateral damage in the connection between Homey and Google. At least, I think both are related.

The problem with Google is that it can’t connect anymore with Homey. So “OK Google, turn on TV”, thus addressing a Homey flow via a virtual device present in Google Home, get’s no response. “It seems that devices are not available”. Furthermore, de integration option in Homey gives an internal error (See topic elsewhere Google lntegration lost and can not be repaired (other then reboot modem): possible cause Rithum) which is solved by rebooting the router.

So I think these two are connected…
UPDATE 24-12-23: : They seem not to be connected. See reply post.

To be continued.

I have deactivated the Rithum functionality and still my Google - Homey connections brakes in hours :frowning: It seems not to be caused by Rithum.

This means the basic problem is no solved.

Hi all, solution (uopdate by Rithum) is working for a few days now! I’m satisfied and for me, this case is now closed.

No connection with the Google issue after all. That is an Athom issue.