All Homey devices in Google Home (GH) are offline after linking

This is a new thread that continues for cases that were not solved with the server-side fix Athom brought out last week (for cases where the connection with GH broke after GH had been working).

After linking to Google Home using Works with Google:

  1. All Homey devices in Google Home are shown as Offline with an exclamation mark. Each time the Google Home app is started the devices show: Loading… and after a while: Offline with an exclamation mark
  2. When you manually press the device in GH, the device comes online and can be used to switch a light for example. But after re-opening the GH app the device is offline again. The device is not available for use by Google voice.
  3. The devices are not per room/zone but all together (which Athom confirmed was caused by a change in the Google API).

Additional information:

  • It may have to do with a first time linking / a new home in Google Home.
  • Selecting Synchronize to Google in Homey under Settings/Google Assistant does not help.
  • Homey is reachable from remote (tested by using the Homey mobile app on a phone using mobile data).
  • The router was power cycled (Homey received a new LAN IP address or the router received a new WAN address). This was the fix for the issue described in the other thread mentioned above.

My set-up in case it matters:
1… HP2023 10.3.0-rc.7
2. Google ethernet adapter. Both Wifi and LAN are enabled and each has an LAN IP address reserved for it
3. The devices are varied: Hue (Matter), z-wave, groups, and many more

Update: I suspect my (unifi USG) network settings because with my old HP2016 and only one virtual button I have the same issue:

  • Linking Homey to Google Home succeeds 1 of 5 times. Sometimes devices are linked, but offline
  • Unlinking Home from Google Home succeeds 1 of 5 times

Upon linking

  1. Google home says: “Homey is linked” followed by
  • When I use an iPhone: “Something Went Wrong”
  • WHen use an Android phone: “Could not reach Homey. Please try again.”

I would be grateful if anyone with a Unifi USG router could post his settings below.

Here three screenshots of my current settings:

  1. Settings/Network overview
  2. Settings/Network, network selected
  3. Settings/Firewall overview (my port forwarding is disabled)

All my suspicions were wrong. It turned out to be one Fibaro double switch 2 that was somehow preventing syncing to complete.

Here’s what I did:

  1. Backup Homey
  2. Remove apps one by one and try to link Homey to GH.
  3. I discovered that when I removed the Fibaro app, all remaining devices synced.
  4. Restore backup
  5. I designed a schedule to remove sets of Fibaro devices in groups (I have 50+). After verifying with Athom support I knew that when I remove a zwave device, the devices considers itself unregistered. So a restore would mean I would have to re-register each removed device again!

This can be avoided. Thanks to the tip by Homey support, I noted for each device the circuit breaker that feeds it. When a device is not powered you can remove it from Homey (with a 30s wait), but the device, when powered up, still considers itself registered to Homey. So restoring a backup is then straightforward.

  1. I switched off the first circuit breaker and selected one of the oldest devices…and tried to link Homey with GH … I was lucky! All 159 devices synced right away and none stayed offline.

A big thank you to Homey support who did more than could be expected of them in checking my set up and guiding me through this process.