Flows are not starting other flows since update 8.0.4

Good day lads,

I’m having issues with my Homey. I’m using structured flows to seperate ligths and switches so I can create multiple scenes and change a light now and then without going through all the flows to change the lights.
The thing is, when a flow is triggered that has to trigger another flow. The other flow won’t get triggered. When I run the flow by hand (that won’t get triggered by the flow above) it works flawless.

As a matter of fact, everything worked yesterday. And this morning (4-5 am) the Homey updated itself and now the flows in other flows won’t get triggered.

Does anybody also have this problem? Or maybe a solution?

I already rebooted the Homey, but with no avail. I also tried to re-add the flow, to the flow, but this also did nothing.

I’m not using advanced flow btw.

Thanks in advance!

1 Like

that’s clear enough :slight_smile: will do as soon as I get home!

I have exactly the same problem here as Roy. I noticed this as well this morning, when leaving for work. I used the google assistant to call a flow for leaving, this flow triggers a flow for turning off the lights, which as you can guess did not work anymore.

Just now, after comming home i checked why this was the case and noticed the same issue as Roy. I created a new flow that triggers an other flow, with the same result. It is not possible anymore to trigger a flow with another flow.

Overhere the update was running at 4.50 am, before that time my morning routine flow started just fine.

Hope it gets solved real quick.

I have the same issue.
Starting a flow to inquire my wall switch to switch on the lights; all related flows started from this flow are not executed. :frowning_face: I have to start all flows from within the app otherwise it will stay dark. I can start these flows from within the app, but my partner doesn’t know what to do. Yesterday evening when I came home she was reading a book with the assistance of here phones flashlight. :smile:

1 create a virtual device (button not on/off)
2 replace the “start flow” with push the butoon
3 “replace the when this flow” is started by the button

An advantage is that you can now also trace back how flows are started (virtual devices have a flow button that shows in which flows they are used.)
(Main reason why I started using the virual devices iso flow triggers)

Disadvantage is ofcourse that you have to create virual devices…

1 Like

Thanks for the tip.
But I have a load of flows I need te re-design.
I want this to work ascespected.

Unplug and reconnect doesn’t solve the issue.

What happens if you hit test in the Flow editor on the Flow that starts another Flow? Does the ‘Start a Flow’ card error?

PTP didn’t solved it.
The flow that contains cards with other flows does run without errors when I press the Test button. But the flow card that gets called in the flow that I tested doesn’t run.

Does it show an error?

Same problem here sonce this morning.

Icasa switch triggers a flow nothing happens.

Icasa triggers only one light= light goes on

Test button in flow also does not switch the lights but the green ok sign shows

Exactly, main flow runs while testing. Leaves al cards checked with a green mark, even the cards that should trigger/start a flow. But the triggered flows don’t get executed.

Do the When cards in the started Flow have tags?

Yes, i use a dummy var that never gets changed in the “when” slot of flows that are used as a function or execution of actions that are very common in a lot of other scenes. So i don’t have to add all these cards to other flows which makes errors easier to trace. And of course easier to change a light bulb without changing lots of flows.

Edit: sorry, no tags, only a var, “if changed”

I’ve identified the issue I will look into a fix asap.

Meanwhile if you want your Flow fixed right now you can use the ‘When this Flow is started’ card.

1 Like

That’s good to hear! :slight_smile:
I will wait for the fix, otherwise I have to change to much flows. And my structure is designed in a way that ‘When this Flow is started’ wouldn’t properly work for 80% of the flows.

The fix is available in the Experimental release channel, version 8.0.5-rc.1. Please let us know if this has resolved the issue for you!

1 Like

I also replied to Dennis via mail. But I will also write it here.

The 8.0.5-rc.1 experimantal release fixed the issue for me!

Issue seems to be solved in the experimental release.
Thanks a lot.