Experimental Virtual IP Camera and Hikvision

I’ve been trying to setup Virtual IP Camera devices in the new experimental release 2.2.0-rc.7 and my Hikvision cameras without success. Access to the cameras is working just fine, also trying the URL in curl or browser gets a still image but when I try to add my cameras as Virtual IP Cameras i get the error “Content-Type “image/jpeg;charset=UTF-8” not allowed.”

I’m using the url below and have been trying with both stream 1 and 2

Have anyone successfully added hikvision cameras as virtual ip cameras?
These are the models that I have tried, both with same result.


Click add device, then select Homey.

Virtual Devices will show there along with Generic devices and IP cameras.

Hi! Thats how I do it but i get the error message as described

There is a setting “System -> Authentification”
It’s default digest only but I guess Homey does only support basic authentification. You have to switch it to basic to work with Homey. Also had that same issue with showing the cams on my Fritz Phone. So it’s not only Homey which doesn’t support digest.

Sorry @JimmyElfving, I was replying to @Canedje, which he has since ‘edited’

Yes. Sorry about that. immidiate after placing i did find the answer

do not support : .mjpeg , now.jpg?snap=spush

Same issue, same error, other camera Hik DS-2CD2142.

@BaoTran I do not get what you ment with your post, please can you explain further?

@JimmyElfving Any progress on this matter?

No progress but I heard in another forum that homey require a pure jpg file and do not support the script page that hikvision cameras provide. Workaround could probably be to get the jpg file from an NVR.

1 Like

Okay with the NVR it works fine and direct with the camera not.
I see the differences. The NVR sends Content-Type: “image/jpeg” and the cameras Content-Type: “image/jpeg;charset=UTF-8” - but Homey ony allows Content-Type: “image/jpeg”

1 Like

This is, in my opinion, a Homey bug. It should not care if any parameters are added to the header, as long as it is declared to contain image/jpeg data. A charset parameter doesn’t make much sense for binary data, but OTOH, RFC2046 states that “MIME implementations must also ignore any parameters whose names they do not recognize”.


Off course this should be fixed if it’s a bug, but is Imagegrabber an option till then?

Any update on this topic? It indeed still throws this error.

Generate http-URL for various cameras, follow link:


Same problem here with a DS-2CD2342WD-I.

Someone filed a bugreport yet?

(i just did)

I have the Hikvision DS-2CD3145F-I. When i generate the Url i got rtsp://user:password@145.129.???.242//Streaming/Channels/101 and i fill this in Homey virtual ip camera i got the message URL malformed. What i am doing wrong?

Nothing done wrong, Homey protocol to use camera’s like Hikvision have to be updated.
That’s all, therefor, be patience! Dozens of Hikvision users are in the same :motor_boat:

Thanks for your answer

I dont think homey will ever support RTSP, since that is for streaming and very resource intensive.

I think it will only support capturing still images via http. This makes more sense, since you can send those over telegram for example.

I cant think of anything usefull you can do with an rtsp stream in homey?