Experimental Virtual IP Camera and Hikvision

Me neither.
Capturing an image from an D-Link camera works like a charm.
However your camera should support it.

does not support rtsp


I completely agree! That’s why this is fixed in Homey 2.3.0. Although i’m really curious what a jpeg in utf-8 charset looks like :see_no_evil: :joy:

Isn’t fixed in 2.3.0 for me

Excuse me, apparently the pairing wizard of the virtual IP cam itself performs another check which will be fixed in Homey 2.3.1. It should be possible (using Homey 2.3.0) to create an IP cam for another URL to a valid image, such as “http://thecatapi.com/api/images/get?format=src&type=png”, then going to the device settings, and changing the URL into the actual hikvision url.


Great to hear that there is a fix coming for this. I tried to add a new working ip camera and then change url to my hikvision but I stil get the same error. I have latest experiemental on both homey and iphone app.

Same problem in my case. Looking forward to see the fix soon :slight_smile:

I also have the same issue with hikvision camera’s. Lookingforward for the update!

Hi! It’s working now with latest release 2.4.0-rc1 and ios app 2.6.0 with all my hikvision cameras. Thanks for fixing this :grinning:

1 Like

That’s great. Can you tell me how you fixet this or can you show me this in an example or flow.

1 Like

Edit: it’s now suddenly working on 1 IP cam with URL below. But the other (but same type) UP cam is not working. I get HTTP error 401 unauthorized. Again, the URL is working in my browser.

*Which URL did you use? I tried http://[user]:[password]@[IP]/ISAPI/Streaming/channels/101/picture *
This URL is working in my browser but in Homey i get the notification could not find that Pairsession.

Also i tryed everything. Even i got the message “Could not find that PairSession”
I tried http and rtsp

1 Like

It’s working for me. The http unautohorized message was caused by a setting in the hikvision camera. Now Both are avaiable in homey

What setting did you changed, and I’m curious how does the url looks like now?


The URL in Homey i use is: http://[user]:[password]@[INTERNAL IP]/ISAPI/Streaming/channels/101/picture (you can test this URL in your browser first)

In the Hikvision config i changed the security setting for RTSP authencity and webverification to digest/basic. You get there by loggin in to your hikvision cam, go to configuration, system, security and then verification.


Thank you, my mistake was NOT adding ISAPI and the 1 instead 101.

It works with Telegram and with Push.
My cameras; Hikvision 2CD2142FWD-i

Thanks, this works for me with my Hikvision NVR.

I’ve just summarized what I did to get it working, could be useful to others with similar setups.
I’m using a NVR to which the Cameras are directly connected via POE (creates it own network, normally only accessible if you connect your laptop to one of the POE ports).
Still can’t get it to work to get snapshots directly form the nvr (channel 0 stream for example), but it works when getting snapshots from the cameras itself. (Big advantage: I can now use “platform access” aka “Hik-Connect” to the NVR and get decrypted snapshots in homey)

Just to be clear: the in the URL’s have to be removed.

My cameras:
DS-2DE2A404IW-DE3 (PTZ-camera)
3x DS-2CD2185FWD-IS
DS-7608NI-K2 / 8P

Steps to take:

  • enable virtual host on NVR (it creates a port on the NVR that lets you connect to the http port of camera, in my case 65001 to 65008) This solves the problem not being alble to connect to the cameras outside of the POE network. NVR menu: Configuration - Network - Advanced settings - other

On cameras:

  • Enable digest/basic in WEB authentication, ipcam menu: configuration - system - security - authentication
  • Disable platform access
  • URL: [user]:[password]@[ipNVR]:[virtual server port]/ISAPI/Streaming/channels/101/picture

Other cool stuff:
Use “logic” to move your PTZ hikvision camera to different presets.
Create webrequest via logic and put in the following information:

  • Methode: PUT
  • URL: http://[user]:[pass]@[IPaddres]:[port]/ISAPI/PTZCtrl/channels/1/presets/[preset number]/goto
  • Headers:[leave empty]
  • Body: {}

Did someone manage to link the alarm output of a hikvision camera or NVR to homey? To for example trigger a flow on a event of the camera (linecross-motion-intrusion-etc)

I have been in contact with athom and they told me that rtsp is still not supported. only snapshots ending with jps or png other types are not yet supported perhaps in the future.