[APP] Qubino - Turn any home into a smart home with Qubino

Central Topic for the Qubino App:

Since you probably know the Qubino App recently pass to the Qubino developers. We did the first release 4.1.1. of the app where we did add the 3 Phase Smart Meter (highly and long waited integration) we did set also the On Off Thermostat 2 min and max set-point temperature.
Since we want to make the app in the best possible way we decided to open this topic, where we will post all the adding, fixes, changes, flows and the rest that we’re planning to implement in the Qubino app. To make the most of the app we’re asking you the users to add in the replies what you want to see in the app, what you found wrong etc,…

Here’s our list up until now:

To add:

  • (ZMNHJD) Flush Pilot Wire and Din Pilot Wire - full integration
  • (ZMNHMD) Smart Leak protector - full integration
  • (ZMNHND) Flush 1D Relay - widget I2 for
  • (ZMNHAD) Flush 1 Relay - widgets for I2 in I3
  • (ZMNHDD) Flush Dimmer - widgets for I2 in I3 on
  • (ZMNHTD) Smart Meter - widgets for the extra end points (Ika, Bicom)
  • (ZMNHXD) 3 Phase Smart Meter - widgets for the extra end points (Ika, Bicom)
  • (ZMNHWD) Flush RGBW Dimmer - 4 dimmer mode for the
  • (ZMNHHD) Mini Dimmer - parameter 71 - Force Calibration
  • (ZMNHBD) 2 Relays - main widget add cumulative values and states

Fix:

  • (ZMNHWD) Flush RGBW dimmer, (ZMNHQD) Luxy Light - the currently set colour is not reflected in the interface
  • (ZMNKAD) Luxy Switch - the currently set colour is not reflected in the interface
  • (ZMNKAD) Luxy Switch - there are two flow events “Alarm mode turned off”, test the flows, the flows was not triggered.
  • (ZMNHQD) Luxy Light - the currently set colour is not reflected in the interface
  • (ZMNHQD) Luxy Light - it is not possible to set the volume of the built-in buzzer volume
  • (ZMNHQD) Luxy Light - there are two flow events “Alarm mode turned off”, test the flows, the flows was not triggered.
  • (ZMNHTD) Smart Meter - MC encapsulated meter reports do not update the values in the interface

Flows:

  • (ZMNHCD) Flush Shutter - windowcoverings_tilt_set parameter
  • (ZMNHOD) Flush Shutter DC - windowcoverings_tilt_set parameter
  • (ZMNHHD) Mini Dimmer - check the dim flow card, the dimm is not fluid seems like steps (details post on 8.12. by matrover)

What is plugged In:

  • (ZMNHND) Flush 1D Relay - garage door

Proposals:

  • (ZMNKID) On/Off Thermostat 2 - main widget have no action, add action Heating - Off (Cooling - Off) ?
  • (ZMNHBD) 2 Relays - main widget have no action, add the all on all off command ?
  • Set the METER_GET command under the kWh value, so that it will refresh the state at the press ?
  • Set the SENSOR_MULTILEVEL_GET command under the temperature value, so that it will refresh the state at the press ? (request 25.11)
  • (ZMNHHD) Mini Dimmer - Use the SWITCH_MULTILEVEL_SET instead of the SWITCH_BINARY_SET - this will make possible to turn on the Mini Dimmer to the latest dim setting (request 25.11)
  • (ZMNHHD) Mini Dimmer - add Start/Stop Level Change Command ? (request 7.12)
  • (ZMNHCD) Flush Shutter To have also tilt % and position % as a status indicator (in Homey tile) (request 24.12)
  • (ZMNHSD) Din Dimmer - add a flow for when to detect a double click (proposed by nicophili 11.2.22)
  • (ZMNHXD) 3 Phase Smart Meter & (ZMNHTD) Smart Meter an automated Flow to export the total kWh usage every month by e-mail

Check - bugs:

  • (ZMNHBD) Flush 2 Relay problems with reporting values - checked the kWh are reported automatically in the version 5.4
  • (ZMNHTD) Smart Meter the widget do not update the values, the Smart Meter sends the values properly and the gateway get them.

Kind Regards from the Qubino team :slight_smile:

6 Likes

Thanks for keeping us up to date with the changes.

Smartplug 16 A does not update Total Energy consumption correctly. While current and power are update regularly when the value changes, Total Energy consumption updates only when I restart the Qubino app.
Regards,
Paul

hi
I’ve a Qubino Flush 1 Relay with temp sensor
and the value of the temp sensor are not updated regular
eg: temp update 3 hrs ago


what can I do?

Check the Settings / Group 1, there should be set 1.1
image

was set by default,
btw, got one temp update 8 min ago :slight_smile:
so update come infrequently

The unsolicited temperature reports are sent every 0,1 °C in case that the temperature raises few degrees in very short time a report is send every sec (more or less) this have to be set like this, to don’t have a device spam the z-wave network.

Other reasons that the temperature is not reported frequently can be the distance from the gateway.
To test the response of the temperature sensor, what we usually do is to touch the sensor tip with the hands for few seconds, this raise the temperature and provoke the device to send the reports. Like this we’re sure that the reports are sent :wink:

I know I don’t have a “perfect” deployment


but switching works
does this mean sending from homey → Qubino is different from sending Qubino → homey ?

Testing the Smart plug right now, the latest version works and send the kWh as you may see from the print-screen below.


Open a ticket on the Qubino support page. We will send you the OTA of the mentioned firmware :slight_smile:

@QubinoHelp this is a great effort, thanks!

The (ZMNHHD) Mini Dimmer doesnt remember the last dim setting when using the on/off button, is that something that can be fixed?

How the commands are sent when you have routing is up to the gateway and depends from the strength of the signal of the devices that are in the routing. Unfortunately on that there’s no much that can be done as it is done automatically.

If you’re getting the updates than the settings are ok. What I will ask the developers is to add the GET command also for the temperature. If it will be possible it will be great as like this the user will have the chance to test the device.

Similar thing that is proposed for the kWh.

That is because the all of the On Off buttons in the app associated with the command SWITCH_BINARY_SET which have only two states off or full. The command to be used instead of this should be the SWITCH_MULTILEVEL_SET FF which is the command to send the last non 0 value in other words to the latest value before the device was set to off (0).

I have add this to the proposals.

Great! thanks

Hi,
I have a request, would it be possible to add a parameter (to set manually only) in a Flush PWM thermostat that can override the measured energy consumption parameter from the module? Something like module off = 0kWh, module on = xxxkWh set by parameter y reporting to Homey.
Let me explain myself:
My house is heated by electric convectors/radiators and I adapted them and installed a Qubino Flush PWM Thermostat (ZMNHLD) into the convectors together with a SSR relay so that I can control them via Homey. The SSR’s (solid state relays) make that the thermostat is able to switch loads easily up to 3000W and this without any noise or switching contacts because the SSR’s are 100% electronic devices. Also the switching frequency is no longer a problem when turning the device on or off like when my solar panels are producing energy or not, no clicking sounds from relay contacts and temperature control is almost perfect because of the PID controller in the PWM Flush module.
Only issues is that the energy returned by PWM module reports the power going into the SSR, this is reported as 0.1kWh when on, and does not represent the actual consumed energy of the controlled device.
Therefore if I had a parameter that would be something like = 0 report internally measured energy and if <> 0 use the parameter value as consumed energy, it would make my life a lot easier :wink:
Of course I can add a flow that checks when the heater is on and that returns a value in a variable but I don’t know if I can add these values into Homey’s energy overview screen?

That is a nice option not only for the PWM but also for the 1D Relay since it can’t measure the W - kWh. I will propose this to be applied in the future version of the PWM. In case that the idea will be accepted and there’s enough space on the chip the firmware can be changed (added the parameter).

Thank you for the input :slight_smile: :+1:

@QubinoHelp could you maybe also fix this, its a bit hard to explain.

with the Qubino mini dimmer when i trigger the flow card dim to x for 5sec (with the duration option on the flow card) the steps of the dimming are very visible. So it seems like if i dim from 100% to 5% whit a duration of 5seconds it doenst fade but just dims 19% every sec.

We will check if anything can be done to make the dimming more fluid.

Apologies for the long wait busy times :wink:

2 Likes

Looks like zmnhxd (3 phase) does add into homey, but doesn’t have the ability to turn off the relay, as well as it doesn’t report any watt usage after it’s added first time.
Anyone else that has this problem?

I have Issue with adding the single phase smart meter to homey. any suggestion @QubinoHelp ?

I have one 3 phase (zmnhxd) that I was able to add. But this is generating 5 different items in Homey. What is the reason for this. Would be great if it was represented equally as my car charger with all info in one item in Homey. if I will add many units like this it will easily be many units/items keep track on.

I have also the 3 phase smart meter. I have also added the Bicom432 which is needed to be able to turn relays on/off, it is not possible directly on the smart meter.
I was hoping that Qubino would add support for the Bicom432 which will let me turn my heat pump on/off.
I cant seem to find a way to do that, and I cant find an option in the Homey app to add the Bicom432.