Homey Community Forum

Qubino ZMNHXD1 3-phase smart meter

I have bought Qubino ZMNHXD1 3-phase smart meter, but as the driver is not yet included among the apps in Homey, i downloaded them fro. https://github.com/athombv/com.qubino/tree/feature/ZMNHXD
and installed it onto homey, that part worked after a few attempts, and qubino flush thermostat works, which where in the same package i downloaded into homey. Pairing also worked fine when i had the smart meter close to homey, but o do not get any information from the smart meter, and i cannot change the settings.
I would appreciate some hints how to get it to work.


I’m also interested in getting the Qubino ZMNHXD1 to work with Homey. I recently bought one and I’m getting it installed soon.

1 Like

Also interested. Will gladly donate.

Really interested in the support for the ZMNHXD1 too.

My supplyer m.nu has now declared on their web site that this energy meeter does not work with any standard router, so i returned mine and boutgh 3 pcs of ZMNHTD1 single phase energy meeter instead.
they do work as energy meters, but not the built-in relay with homey.


Also very interested in to have the ZMNHXD1 working. Happy to donate to have it working

1 Like

Any status update? Athom itself isn’t going to add support for this device. I really would like to have it talking with Homey, since it’s installed for months now…

It is Qubino who needs to update the firmvare in the ZMNHXD1energy meeter to make it work, not Athom Homey

I bought 3 phs of ZMNHTD1 single phase energy meeter instead, one for each phase, and they work fine for about an hour, with the beta version of the Homey qubino device driver, but then they stop reporting values, until power is cut and restored, then the start sending data again.
I still hope that Athom Homey will find a fix for that.

Hello all,

I’ve got a single phase smart meter from Qubino ((ZMNHTD1) paired with my Homey which runs the Beta version of the Qubino app (2.0.10) & unfortunately my experience has not been great.

I’m using the meter to monitor energy usage (I’ve got PV panels at home) & haven’t tried the relay/ switch functionality. Ater pairing data is refreshed on the Homey app as expected but after a short period (minutes) this updating ceases (see pic below of data) & the only way to fix the problem is removing & repairing the device.

The smart meter is within 2 metres of my homey
I’ve tried a factory reset of the monitor - no change
I’ve tried changing most of the advanced settings - no change
I’ve tried temporarily disabling/ depowering all other Z wave devices to see if that was the issue - no change

Perhaps it’s an app issue? I can’t tell at this stage & difficult to troubleshoot shoot further unless someone can suggest something?


please report the problem to athom homey support, i have, got the reply yesterday that they are not able to reproduce the problem, it would help them to have more data on different kinds of installations to find the problem.
i have seen on other forums that they have got this energy meter working with other routers by modifying the app, so i hope it can be fixed with changes in the app, even if the root cause to the problem is in the energy meeter firmware.

I reported this issue th Athom some time ago. Likewise they say that they can’t reproduce the problem.

Me too!

Same here! :slight_smile:

Any news on this? I contacted both Athom & Qubino but so far no solution/ fix.

Software versonions 3 is the one Athom Homey have successfully tested witn, but the software version 7 i have does not.
Reply from Atom Homey service:
The development team states that it also seems like there is a “bug” in the Qubino firmware itself because the device stops reporting overal

you find the software version on the label on the side of the meeter it is part of this code:
H1S7P1, the number after the S s the software version

I’ve also got firmware version 7 (i.e. H1S7P1) on my meter.

I’ve been in contact with both Athom & Qubino directly. Qubino say they’ve been unable to replicate the problem but they say Athom have. From searches online it seems similar issues have been reported on other home automation platforms:

I wonder is it possible to get a workaround for the issue?

Hi All,

I have tow ZMNHXD1 meters, the standard Qubino app does not support these. There is an older version on Github with “support” adding them is not working with Homey very close to meter.

I think with all the solar coming in to hour world the usage of these serious 3 phase meters with homey is not something to leave out in the official Qubino app.

Any help or tips?

It is very important to report all issues you find here: https://support.athom.com/hc/requests/new

again and again and again so they know it is urgent.

Is there any update on the support for the 3 phase smart meter?