[App][Pro] Tuya Cloud

renew your developer subscription. See earlier in the various posts. Ask for 6 month extension. Will be granted within 24 hrs (at least it worked for me 2 days ago)

Click on “IoT Core” and renew you subscription. Mine worked just fine (see below)

Thanks. My trial expired exactly on the moment my devices stopped responding. Hope it works and then re-extend after 6 months or try a new account.

Edit 20-01: I was waiting in vain for some days for my radiator valves being able to be reinstalled or an email from tuya but found out my subscrition was succesfully renewed quite quickly already but i also needed to opt for the “Use official only” in the configure app screen. So many things you can do wrong. Now all set again.

You’re welcome! @Jan_Peeters

I thought it might come in handy for other users as well :hugs:

There are 2 ways to import a flow. This way, you’ll get the advanced virtual device as well. When not needed, just delete the AVD afterwards.

It is quite simple, only you’ll have to start by first adding an AVD with the web app.
You’ll see the textfield where you can paste the copied TEF code.
Hit ‘Read Device’ and the AVD gets created
Screenshot from 2023-01-15 23-27-54

Then, the flow gets prepared to be imported, and you can make your adustments, and press “Update Text”. It’s the same screen as the flow importer

1 Like

Have some troubles with the Tuya Cloud. Wasn’t working properly anymore and now I got this: Error: Error: Code: 1106; msg: permission deny

Has been working like a charm, but can’t reproduce why it isn’t working anymore. The authentication worked beforehand…

Any clues?

Did you read the first post of the thread?

1 Like

And read a few posts above yours? When it suddenly stops working, ‘Expired iot Core trial period’ is (most) probably the issue.

Hi,
I have bought, received and integrated the Tuya mmWave presence detector.
As far as the presence detection function is concerned, it is fully functional in the app.
Altough it is recognized as another type of sensor, it is working just fine. And, at that, even better than the Aqara body sensor.

However, the sensor has multiple settings that are available in the Tuya app but not in Homey.
Nor is the LUX value available in Homey. The LUX value is much more reliable than the LUX value as measured by the Aqara Body Sensor.
A ‘nice to have’ would be to have them available in Homey as well.
…just saying :wink:

Hi thanks for this plugin (took a while to setup but I got it), however the Duux Beam is added in the Tuya app but i cannot add it through this plugin as the category humidifier is missing, can this pls be added? :grinning: Thank you.

good morning,
since this morning I am no longer able to control the devices connected to homey through the tuya cloud. From the Smart view app, all devices are connected and respond correctly.
going to the tuya iot page and starting the project I see all the devices, their status and capabilities. If I go into debug from the tuya iot page and try to control some device, I get the message: not allowed, your plan has expired. it happened to someone else
thank you

Edit:i had read the first post, but i couldn’t find where to ask for the six month extension. I did some google searches and found it. I would like to know: how long did you wait for the approval of the request? thank you

Please read the first post of this thread carefully. Your problem is explained and a solution is provided.

Hi All
suddently my Tuya WIFI is not working in Homey anymore
It works fin from the Tuya app.

I have checked all API configurations also that it is linked to my tuya app.
In homey when I try to turn it on or off it writes “Missing Capability listner: ON/OFF”

Have any of you had this problem?

Update
Tried to make a complete new project, unlink and link everything
on webpage it finds my device, but when I try to find devices in homey, I get no no new items, and it writes please configure the app first…

I have added account email and pass + Access ID/Client ID and Access Secret/Client Secret

It if work before and not anymore I think your license is finished. You must go on tuya iot and ask for 6 months renovation. You find some answers on first post and find exactly how to do on Google ( There are also image) you must ask for renovations and wait to approval

All, I will stop actively development of this app, thank you for using the app.

The reason I stop is that I moved to Home Assistant. I had Zigbee problems, so I needed extra hub, not all 433 devices I had did work with Homey and I saw that sometimes events get lost( papertrails did give insights in this). Besides the problems I am not completely agree to force SDK 3 without updating all of their own apps( or make available so a community dev could take over) and the decision not supporting Matter on current Homey pro( even not as extra add-on, just like advanced flows).

My problems and disagree with some decisions doesn’t mean that Homey is a bad product, it has absolutely strengths( and better looks) and still best choice for beginners( I think), but it doesn’t suit my needs anymore. Also HA has his own problems and quirks. I had to made the choice to invest in new Homey, with uncertainties, or continue with HA and add some extra USB controllers for ZWave and 433. I already had HA running aside to Homey last half year with Zigbee. And last 2 months I run without Homey and the new USB modules without problems.

because I think it’s important that devices stay supported, and if an other developer wants to take over the app, this can be arranged.

3 Likes

:sob: