[APP][PRO] Smart Presence

Edit your wifi connections and go to advanced settings.
Then you can choose ‘random MAC’ or ‘phone MAC’

Oh wow, thanks :slight_smile:

I’ll let you know!

Peter, thanks! It’s works perfectly!

1 Like

V. 0.8.0 available as a test-version:

  • Added presence to the Timeline
  • Fixed rename bug
  • Migrated to SDK3

Thanks for the update Bjørnar!

Question. How to use this new feature:

The presence state is visible in the Timeline, like this:

Skjermbilde 2021-11-08 kl. 07.34.12

1 Like

Found it!

Yesterday, all of a sudden all my flows which depend on SP got ‘broken’, and SP was in ‘pause’-state. After restarting the app everything worked fine again. Haven’t seen this with the stable version. Will keep track of this and report back in when it continues to happen.

Hi, I got the same effect. SP stops working after a few days. Sometimes after a day after I restarted the app. I made a diagnostic report maybe that could help: 2cc6bc9e-9922-49b1-89f1-a6f0a64c3f61

I’m looking at the problem.

What firmware do you have? 7.1.6 ?
How many SmartPresence - devices have you added ?

Firmware 7.1.5
I use 5 devices

It seems to be a memory problem. I will try to have a fix ready later today.


same issue here, the app is paused, needs a restart. i’m on Homey 7.1.6 and v0.8 of SP

Same issue here. Homey v7.1.6 and v0.8.0

Same experience.

Yes. It’s the same for all users. The app uses too much memory on SDK 3.

You can choose to disable the app, or restart, until the fix is ready later today.

I’m running a flow to restart a few apps regularly anyway, added SP till it’s fixed. Thanks for the great app @balmli

v. 0.8.1, with a fix for the memory issue.

Not tested for a long time, but please test it. :slight_smile:

@Martijn_Hoogenbosch , @MarcoG , @thobu, @MadMax , @Morgan


You can see the memory consumption for the app from Insights.

So far, so good.