Zigbee stopped working/broken

Helpdesk had a look at diagnostics, probably a problem with the Zigbee chip. Homey has to return to Houston (or whatever place of birth) to have a proper examination.

Thanks for your reply … but what does it mean? :thinking:

Broken Zibee chip? Homey will be sent in for repair.

Did you send it in? And get it back with Zigbee working?

Helpdesk is extremely busy, not yet sent in.

I have the same problem here. Started after a reboot I had to do every week. As Kaku devices stop working now ant then. Now a lot stopped working… Wife not happy

After problems with zigbee lamp (despite booster right next to it) my whole Zigbee functionality went down.

Numerous PTP and reboot attempts. Resetting the Zigbee network does not work (error code EBADF).

After consultations with Athom support (speedy and pleasant) the advice is that the Zigbee chip has failed. Just 6 months out of warranty :unamused:

And apparently a repair would be uneconomic so I am advised to buy a replacement Homey.

I would rather not do this if there are alternatives. These seem to be

a) a do-it-yourself replacement of the Zigbee chip - but I can see no evidence of this being done
b) marrying the Homey with a Zigbee hub (Hue/Tradfri etc) - but this will complicate flows. What is the experience of others?
c) replacing all the zigbee devices with WiFi or Z-wave versions - nearly as expensive as a new entry level Homey.

Any advice welcome.

Because of the poor Zigbee implementation of Homey, some users are moving to a third-party solution like deCONZ to handle all Zigbee-related tasks. It supports more types of devices, has a good range and its relatively cheap (a deCONZ Conbee II with a Raspberry Pi 3 will set you back around €80).

I’m not sure how well it integrates with Homey at the moment, as it’s a rather new project (but also actively being developed). You’d still need to re-pair all your Zigbee devices and fix your flows, but that would be a one-time affair.

having some issues here with Zigbee as well. Having a Homey Pro for not even 4 months. Issues started with one Hue bulb and then a day later also with an IKEA bulb.

did a restart of Homey and the apps concerning but that made it worse because i didn’t see the zigbee nodes anymore.

Did a PTP for 10 minutes and now the Zigbee devices are back but still not working except for one zigbee Aqara device. Very strange issue since three devices are not working anymore and only one is.

I will remove one and pair it again and if that fails get some support from Athome.

Are you sure the devices aren’t out of range? After a reboot it may take some time for devices to show up on the Zigbee page of the developer website.

re-adding a motion sensor is working after a few tries so i’m starting to think about wifi channel usage.

Too bad that channel 11 cannot be altered because i have a neighbor who also has a Homey. What if every neighbor would have a Homey ?

I am going to ask this question to Athome but maybe somebody else has more information about this ?

well, i only have 4 of them and the one that was still working was two floors up so it cannot be something like that.

I did a PTP for 10 minutes and then waited also at least 20 minutes. wondering if the wifi channel seems to be the issue here. The bulbs are 4 meters from the homey with a thin wall in between so that is not it. It worked for 3 months and suddenly now issues happened.
I see a new wifi network on Channel 11 so that is what i am looking at.

Maybe i can test something more or see what Athome will say about wifi channel.

Have you tried replacing Homey’s power supply? When you’re using the original power supply, and Homey suddenly starts acting up, it may be a sign that the power supply is failing (for which it is very well known). A USB charger that can provide at least 2A and preferably from a reputable brand should work.

It can always be something like that because different devices have different transmit/reception power or have some electrical, metal or other signal blocking elements in between etcetera.
My newer Aqara senors have way better reception and can overcome more distance without a repeater then the older Xiaomi ones.

Given that your bulbs act as a repeater and are not working, it is inevitable that other devices that use them as a path to connect will also start to give problems.

ok, no not yet. thanks for the tip. i had a week ago that Homey was present on the network but was not accessible to the app or web interfaces so will use another power adapter if i face issues again.

The ikea bulb is no working again without re adding, only the Hue bulb is still not working and with that bulb the issues began. i will otherwise see if the hue bulb will stay offline to see if that might cause issues.

at least my Zigbee controller is not broken :blush:

yes i know but the bulbs and a motion sensor were very near the Homey. also keeping the sensor next to the Homey did not work so i guess i can rule out it was something about the range.

the bulbs have not been on every time since other people in the house use the switch but since this is happening for several months now i still am thinking about new wifi devices in the area from my neighbors or a defective Hue lamp perhaps.

i will see if it keeps working and report back here if i know more. Thanks for supporting!

That is also asking for problems because they act and will be used as routers while switched on and other devices loose their route the moment they are switched off (or even when switched on because the mesh is changing and may cause delays).

yes i know but only the bulbs had issues first. everything that is powered is a router, i know.

that is not whats happening here. i will investigate more. I have also added the Philips Hue now again (could reset it wit only a dimmer switch) so have to see how it goes from now.

i also changed my wifi channels to the same channel (have 2 accespoints) but unfortunately there are a lot of wifi in the neighbourhood and one of the accesspoints i cannot change to channel 11. But my nextdoor neighbor also has Homey and even more wifi SSID’s are on channel 11. the setup has worked for almost 3 months and the only thing that has changed are a few flows and new wifi networks were added by neighbors it seems.

i already know to have a bit of patience here so i will wait to see what happens, or the wifi or the power adapter seem to me to be investigated more

thanks again for supporting

1 Like

ok, every zigbee works except again for the Philips Hue which started first with issues. So maybe that one was acting as router for the other ones who are closest to it.

Not sure but i will replace that Hue bulb with another i just got, this one is also a newer BT version. At this moment the bulb that is not working also has another ProfileID while everything else is on the same ProfileID.

looking again at this topic. Zigbee works fine but only sometimes the Philips Hue bulbs have issues and now lately only one of them.

Also wondering why none of the powered devices is acting as a router. If i see screenshots of other people they do have the numbers shown of some acting as a router.

Maybe someone can tell if they have Homey 4.2.0 firmware running and zigbee devices as routers as well ? In my case only the Philips BT bulb is giving issues from time to time (sometimes after weeks) and that one is the only one which has another profile ID.

starting to think it is almost time to move to firmware version 5 which has improvements on Zigbee. Maybe someone also knows if there is an easy way to check if all devices/apps are supported ?