Zigbee light devices problem

A few days ago, some of my devices stopped working correctly. Specifically, it’s Zigbee devices, such as lights. When I try to turn them on/off using the app, nothing happens; it just shows an error message. The devices include zbmini, zbminil2, Philips lights, or Gledopto LED – all Zigbee. When testing Wi-Fi devices, they work fine. Restarting didn’t help. When I switch lights on/off physically, I can see changes in the app. What is weird, zigbee devices from Aqara are working correctly (at least most of them). I’ve already contacted support but wanted to check here for any tips or tricks. Thank you.

Hello Thomas,

  1. Which Homey model?
  2. Are the wifi and zigbee channels tuned? https://support.metageek.com/hc/en-us/articles/203845040-ZigBee-and-WiFi-Coexistence
  3. Pls show a screenshot of your zigbee mesh https://tools.developer.homey.app/tools/zigbee
  4. Can you recall what changed since the issue? Firmware or app updates f.i., neighbors have new wifi system, power cut, …

How to ask a question the best way:


sorry to jump on the back of this but I’m having the exact same problem. You’ll have to forgive my ignorance, I am very new to this. I went the Homey route because I have no programming knowledge so it seemed easier than Home Assistant.

Ive clicked on the link you provided and the only Zigbee devices showing are the Sonoff ZBMINIZL2 which Im having issues with, and my Homey.

I actually have a lot of Philips Hue bulbs and their hub which i naively thought would all be part of my Zigbee mesh network, but im guessing i was wrong and they will only communicate amongst themselves?

The thing i cant understand though is that seemingly nothing has changed. There have been no firmware updates, and i havent tampered the device physically before it stopped working.

After it began to not work, I have disconnected it and reconnected (from the homey) it whilst it was still in the wall and that didnt work. It would reconnect to the homey but the command to turn the lights off and on again failed (the physical switch at the wall still worked) and i would get a timeout after 300000ms or 500000ms error message.

i have tried disconnecting the wires and reconnecting them in case of a faulty install (though i dont see how that would explain why it suddenly stopped working, or why it still works with the physical switch) and it briefly reconnected to the Homey and behaved as it should. but then within 5 minutes reverted to no longer working.

Any and all advice is welcome :slight_smile:

Correct, Hue hub = zigbee controller with it’s own zigbee mesh network.
And zigbee devices can be paired with one controller only.

So, Homey has one zigbee device, the Sonoff switch? What is the distance between them?

For how long did it work?

What do you mean,

  1. are you cutting the main power from the Sonoff with a dumb switch?
  2. or are you cutting the power to the connected light?
    If it’s 2.) , the Sonoff is cut from power also, because it uses the light to work without a neutral wire.
  3. or did you wire it like it should:
    Screenshot from 2024-02-16 03-31-22
    Then the issue must be something with the zigbee signal.

Are you shure nothing’s changed with your 2.4GHz wifi channel? Any nearby neighbors wifi channel could have changed as well and could interfere with zigbee signals.

Ah, well that’s foolish of me re zigbee hub :frowning:

It’s a reasonably new device, I’ve had it for about 4 nights but it has worked perfectly until last night. It is only about 6m from the Homey Pro if you take it as a direct line straight to the Sonoff relay, but there are a couple of walls between the Homey Pro and the Sonoff.

Yes it’s wired in as they suggest, so the permanent live feed that used to go to the switch, now is wired into the ‘s1’ terminal of the Sonoff, and the wire that used to go from the other side of the switch to the bulbs is wired into the ‘S2’ terminal’s now, and the the ‘dumb’ light switch on the wall is now wired into the ‘L out’ and ‘L in’ terminals on the Sonoff.

To the best of my knowledge I don’t think my neighbours will have altered their WiFi. It’s a detached house, and so the only neighbour close enough for any interference hasn’t altered his WiFi or ISP that I’m aware of.

I think you’re right though and it seems to be a zigbee network issue, I have also received a ‘network error’ error message a couple of times now. The command from the Homey Pro to turn the light on and off has begun working intermittently since my last post, and I will find that sometimes if send a command from the Homey to turn the light on, nothing happens, so I will hit the button to turn it off, still nothing, then if I hit on again it will turn on, off, on. So it seems like the Homey is struggling to get the signal through perhaps?

Forgive my very basic question, but am I right in understanding that if I add another Sonoff ZB mini, to a switch closer to the Homey Pro, then it can act as a relay to bounce the request to turn the light on/off to the switch I’m having the issue with?

Edit: thank you for your help btw :slight_smile:

The ZBMINIL2 devices act as Zigbee end devices, not Zigbee routers, so they won’t relay messages from other Zigbee devices in the network.

Thanks Robert, forgive the follow up basic question, but do you know any way to get my Philips Hue hub to pick up the Sonoff so that it can be part of that network?

I assume you tried pairing it with the hub? If that didn’t work, I don’t think it’s possible (also, even if it were possible, the Hue app for Homey may not support it, although if you enable Matter support on the Hue hub it might).

Thanks Robert, yeah I tried that and it didn’t recognise it which was why I paired it directly with the hub.
I may try another route such as adding an Amazon echo to the room and then pairing it to that.

I don’t suppose you know of any other very small no-neutral relays that can be added behind sockets that are compatible with Philips Hue do you?

Their own offering requires me to connect the lights directly to the permanent live feed, but this is a ‘dumb’ lighting circuit and some of the bulbs are G9 so can’t be replaced with smart bulbs, which would mean the lights would be on permanently.

I don’t have any experience with Hue, so no idea. The Sonoff devices are indeed very small (I have two myself, albeit not connected to Homey but to zigbee2mqtt).

Shelly also have some small devices (although I don’t know how they compare in size with the Sonoff), but those are WiFi, not Zigbee.

I have a lot of other Shelly devices and they’re great, I can’t use them on this particular circuit though as I don’t have a neural wire, and they no longer seem to sell their 1L.

Normally in the UK you can still access the neutral and the permanent live cables in the ceiling rose of a light, and so I have been able to install a Shelly there. But this is just the circuit for some under cabinet and plinth lights in my kitchen, and whoever installed it must have concealed the circuit in a junction box in the ceiling, and so I only have access to the switched live feed coming out of the wall. So for this one circuit I need a no neutral device. The frustrations of living in the UK I guess :man_shrugging:

Thanks again for your help

Hmm that’s too bad :frowning:

Another thing you could try is to move some of your Hue devices from the Hue hub to Homey directly, together with the Sonoff. Perhaps it just needs a larger network to work better.

I think Hue block more than 4 devices that aren’t paired to their hub.

To be honest I’ve just had a poke around in the ceiling removing some of the spot lights to see where the junction is and I’ve found some very alarming wiring. So I think I’m actually going to fix that and then I’ll add a Shelly 1PM when I do. In the meantime I’ll try connecting it to the Amazon echos to see if they can reach it more successfully

Do you know if I’m likely to encounter the same issues with zwave? My plan is to install some iblinds motors on a few blinds but they will be the only zwave products I own and I’m concerned now that the homey hub won’t be able to reach them as they’re further away than this switch is.

Hue has nothing to say about it when those devices are paired with another controller (i.e. Homey).

“Perhaps”. In theory, Zigbee on Homey should just work too.

You can solve it by adding one (or more) router device(s) in between, to have the signal hop from Homey to a router to the device you want to control.
Almost any Zwave/Zigbee non-battery powered devices act as a router/hop.

Zwave kb articles:

Zigbee kb article:

Ace, thanks for this Peter, I shall have a read :slight_smile:

1 Like

Okay, so following on from this in case anybody else experiences the same issue in the future and is looking for a resolution, I’ve managed to get mine working again.

I still don’t fully understand how this works, but I took a bit of a Hail Mary at it before messing about pairing the Sonoff switch to Alexa.

Peter provided a link to the developer tools above (Homey Developer Tools) when you open this link then click zigbee, in that section there is a link to ‘reset network’. In clicking this it removed the only device I had paired to the Homey Pro, so be warned this may cause you a lot of work if your network is large. But since re-adding the Sonoff relay to the network it has worked fine (I had previously tried deleting the device from my Homey Pro and then re-adding it but that didn’t work).

My guess would be that either a) Placebo. This is all a big coincidence and actually I haven’t done anything to fix the problem, but the fact it fixed its self at the same time I did that, means that I’ve drawn a false conclusion. Or, B) something in my vicinity was interfering with the network, and so in clicking that link, the Homey Pro has searched for a new frequency to host its network on that has less interference, and so now it works again?

I’m sure one of the more knowledgeable folk can confirm whether or not B is plausible or not, but hopefully this helps someone else in the future.

As it is, I’m glad I’ve had this issue as it’s lead me to find a pretty bad fire risk in my house installed by the previous owners so I guess every cloud… :upside_down_face:

When you reset your zigbee, it searches for a quiet channel. So it’s possible you have less interference now.
You can see if the zigbee channel has changed at the developer page.

On the other hand, the actual reset could’ve just set internal ‘wobbly’ things straight.


FWIN you first get a warning which you have to aknowledge?
Or did it immediately start the reset procedure?

Thanks for clarifying Peter, I guessed that would be the case but I didn’t want to espouse it as fact when I don’t actually know what I’m talking about. :joy:

IIRC it asked to verify “are you sure you want to reset the network”, it doesn’t though specify that this means it will unpair all devices. Not an issue for me, I only had one, but people stumbling on this thread in the future may be more heavily invested in theirs. Hopefully this will help them to diagnose their issue more quickly though :blush:

1 Like