Zigbee issues with pairing several sensors

Here’s a very strange situation that I am experiencing with my Homey 2019 and I hope someone can provide me with some advice.

A couple of months ago I bought a Moes Zigbee LCD Temperature and Humidity sensor with the idea of testing a potential replacement to my Aqara sensors (I wanted something more “visual”). After several unsuccessful attempts of pairing it to Homey, first with the Tuya App and then as a generic Zigbee device, I blamed the Tuya sensor and gave up.

Recently I decided to give it another try this time with two Sonoff SNZB-02D Temperature and Humidity sensors which I received today and should be supported by the Sonoff Zigbee App. But once more I wasn’t able to pair them to my Homey.

That is not entirely true, and here comes the mystery part, is because out of frustration I started trying everything including using the iPad instead of the iPhone to add the device and getting close to a Ikea Tradfri Zigbee repeater instead of Homey and with this combination, in a few occasions, I went past the initial screen but still I wasn’t able to finalise the pairing.

Since the Zigbee network is up and running (the activity alarms go off if I open a window and the Aqara sensors report the temperature) I decided to unpair one of those and try to pair it again, and now I am not not even able to pair the previously working Aqara.

As I am typing I am trying a PTP as a last attempt of what I could possibly try, which included:

  • Trying different devices to pair the sensors (iPhone, iPad, web interface)
  • Trying to pair the device to the repeater instead of Homey (I’ve read somewhere that there’s a limit of the number of device a router could handle)
  • Pairing with the Sonoff Zigbee App and as a Generic zigbee device
  • Restarting the apps
  • Re-installing the apps (not Aqara),
  • Restarting Homey… now PTP

Any suggestion will be appreciate before I start looking for an alternative Zigbee hub.

Hello Dandooze,

If you didn’t already, replace the power supply and cable with a 5V, 2A or up model from a wellknown brand.

Next, start Homey in recovery mode, and perform a “full software download”.
It sort of installs the firmware from scratch, without touching your data.
It solved several other odd zigbee issues!

As always, make sure you have a recent backup available.

1 Like

Hey @Peter_Kawa I will give it a try.

p.s. by well know brand, you mean the “bitten fruit” specifically, or anything reliable?

YW! Yea, apple, samsung and such.

1 Like

Have you followed the instructions on this page?

How many end devices and router devices do you have?

I tried both things that you suggested with initially not apparent results

  • I have replaced the power supply with an Apple iPad charger (5V2.1A)
  • Recovered homey, even though it seem that with the current procedure there is no way to select “full software update” as described here

Eventually and very late, I was able to add one of the Sonoff sensors as generic Zigbee device via one of the extender. One more curious thing is that despite that, it is seen by the system as connected via the Sonoff App

I will do more tests today.

Hi @robertklep, and thanks for always jumping in!
Yes, I did from the very beginning of my Homey journey. My house has two floors and a loft, Homey is on the “middle floor” and I have two Ikea Tradfri Extender on the ground floor and in the loft.

The number of devices used to be around 25, but with all the recent tests it went down to 19. Moreover, as you can see from the attached image, it seems to me that the load is pretty balanced between the router (0) and extenders (3 and 5)

Two routers on 20-25 devices is not enough, routers have a limited number of slots for children. I would suggest adding at least 3 more routers.

See also the aforementioned document: “That is why we recommend placing at least one router for every five end devices in your Zigbee network.”

That’s how Homey works: if there’s an app installed that can support a particular device, the app will be used, even if you added the device as a generic Zigbee device.

1 Like

Two routers on 20-25 devices is not enough, routers have a limited number of slots for children. I would suggest adding at least 3 more routers.

Oh, I definitely didn’t read that last bit carefully! Anyway in my current situation, with one coordinator and two routers on a total of 19 devices, it makes roughly 5 passive device for each spot… (and it was working with 24 before my LCD Temperature adventure)

That raises more questions in my head in order to find a stable solution:

  • Is this limit a Homey thing or I would have the same problem if I would decide to use an external Zigbee hub?
  • Could resetting the Zigbee network and choosing a different channel potentially help? I upgraded my wifi set-up in the meantime and I read that also 2.4Ghz channels can disrupt the Zigbee mesh (of course popping some other router here in there).

Thanks in advance

Zigbee networking isn’t an exact science, sometimes a particular setup works while another one doesn’t. Same as how Zigbee routing works: people tend to think that because they have a router device close to an end device, that end device surely will be using that particular router, but that’s not always the case either.

If you want to solve your problems, you at least need to make sure that you have a healthy Zigbee network, which IMO you don’t due to the lack of routers.

It’s the actual router devices that have a limited number of slots (usually because of memory constraints) and that will not change if you use a different Zigbee controller. However, HP2019 itself also has a limited number of slots (although more than a typical router), which is why it’s advised to always add router devices first and end devices later, when the routers have established a mesh amongst themselves.

Potentially, yes.

1 Like

Thanks for all the tips
I will try a reset first, while on my way to get more Tradfri :smiley:

That’s odd…
So I just tested, it’s still there when Homey runs v8.1.6
Your Homey presumably runs v10.x ?

→ download full software update
→ Reset to factory settings
→ skip
→ back

Your Homey presumably runs v10.x ?

Correct, my homey runs 10.0.2, the only option that I was given was to restore from a backup or not.

Hmmmm, when I chose “NO” at the backup question, I got the next question: Do you want to install a software update (or something like that). It didn’t end the recovery session.

Oh, I chose to recover from the backup because I was afraid to lose everything. Now reading carefully your first message I see that that procedure doesn’t touch your data.

In the meantime I went for resetting the Zigbee network and adding more routers.

Recover from backup before performing a full software download makes no sense…
And when things might have broken, you can always recover from backup again.

Make sure to fix the 2.4GHz wifi channel before resetting zigbee. Homey looks for a quiet channel for zigbee during the reset procedure.
Of course you can change the zigbee channel yourself, but not all devices ‘get the message’ and have to be re-paired afterwards.

1 Like

Seems like I have exactly the same issue (Zigbee not pairing, athom not responding ), have you been able to resolve this?

Isn’t this sounding like something what worked for Dandooze?

Seems like I have exactly the same issue (Zigbee not pairing, athom not responding ), have you been able to resolve this?

Somewhat I did resolve it. And I would say that my solution is a combination of everything that has been suggested by @Peter_Kawa and @robertklep so I cannot really pinpoint one single factor.

In summary I have:

  • reinstalled the Homey with “full software download”
  • changed the original power supply with an iPad charger
  • Added more repeater (a few Ikea Tradfri and a couple of Aqara plugs)
  • reset and rebuilt the Zigbee from scratch

I am still in the process of reconnecting all the zigbee devices (the infamous Temperature Sensors are now connected) but overall the network seems more stable and reliable so far.

The only thing that I was not always able to do as suggested, is to pair every device to its nearest repeater. With some devices, no matter how many times I tried, it simply doesn’t work. In those cases, I paired them with homey directly and then placed them in their final location. It seems that the network adjust itself after a bit anyway.

Hope this helps.
And thanks again to @Peter_Kawa and @robertklep

1 Like