Problems connecting Aqara

I have trouble with connecting a Aqara temperature and humidity sensor to my Homey Pro 19. I have severals of them in my system already but my new ones don’t want to connect. I have tried to reinstall the app, rebooted Homey several times, but it doesn’t help. I tried to find contact info to the developer of the app, but couldn’t find any. So now I’ve contacted you to see if you can help me. Have I beaten all odds and purchased 2 broken units or what can the problem be?

Search for the app in the App Store and scroll down to the bottom:

Have you built your Zigbee network according to the specification in the Homey Support section?

Have you read this document?

Yes I have used that link, but on that page there’s another link to where you report a problem, and that link goes to a 404 page.

I have read that document before but misread or forgot parts of it. Now I see that I had maxed out the capacity of my Homey. I installed a couple of extra zigbee wall plugs and now it works like a charm.

Tanks a lot for the help! :slight_smile: