Slow Flow

I am experiencing my flow are slow it actually takes several seconds for the light to come on.
Anybody else having same issue, my new model Homey is wired and it happens with all lights and configurations, so it seems to be a homey problem, i have ikea , and hue , and several other products aswell all the same when homey is conrolling through motion sensors. it the same when one test the flow
it takes 5-10 seconds to go through the flow, but that might be because it is a test.

so my problem is the light first comes on when i am out of the room , when we are walking through a room.


Test flow’s (advanced) are always slow. (To show you what it is doing).

In my situation, my lights are on within a second. Can you give more info about the sensors you are using and how they are connected to homey? For example, if you are using the hue motion sensor connected to the hue bridge, they are slow because of the polling times.

1 Like

With a log app like SimpleLog, I add cards to trigger-, condition- and action cards.
That way you can see what is slow or, “taking its time”, and, from my experience, it can’t be the flow itself, unless Homey is way overloaded

  • What is your systemload? —>
  • Issues I’ve read about:
    • Did you replace the power unit with the new recommended ones? The original power unit slows Homey 2023 CPU down (much), because it’s output voltage is just a bit too low.
    • Did you replace the USB-C cable with a shorter one? The longer cable seem to lower the voltage a bit to much

A flow with log cards everywhere:

No panic, adding the cards can be done whit a script , for a flow or a selection of flows. The script is work in progress, but here it worked fine:

Other slow stuff:
  • Sensors: wifi sensors (on battery) can take up to 8 seconds to send an update, so not very suitable for instant detection
1 Like

Hi @Peter_Kawa I am not experiencing slow flows but rather the fact that some of the devices in my flow do not get activated when I run the flow.

As an example I have the following flow which is meant to close all the blinds of my ground floor:

I created the flow and saved it as favorite so in the evening i just run it before going to bed.
The flow has worked seamlessly for two or three days but recently some of the devices do not react to this. When I run the flow maybe only 3 or 4 of the 7 blinds are activated. Please also note that all the blinds are responsive via Homey, i.e. if i try to close one single blind by commanding it via homey it responds within milliseconds. However, when i try to move them all with this flow some of them do not move.

I am on Homey pro and noticed this started after the recent Homey update…i do not know if this is a coincidence.

Any clue on what that can be? Should I kill the flow and make a new one again? I also thought that maybe homey might have challenges in running flows with so many devices on…


Maybe, you shouldn’t trigger all the blinds at once, so signals are not received correctly.
Try a ‘wait’ card in your flow !

True, Homey Pro 2019 is bad with sending more than a few commands at once.
No clue how Pro 2023 handles that

Another way besides adding delays is, in Advanced flow, you can daisy-chain your action cards (connect the input for the 2nd card to the output of the 1st card and so on) so they won’t get fired at once, but one after the other.

Other option: create a group device with all your devices you want to control with this flow. The group members are not fired at once, but in sequence so to speak


Dear all, I just got a message also from Homey team. They confirmed that it is not advisable to have all devices being fired up at the same time so the solutions suggested by @Peter_Kawa are indeed all recommended by Athom.

In parallel, they are working to developments and upgrades to eliminate the issue.

Overall I also must say that this issue did not happen all the time but just every now and then…so maybe Homey Pro 2023 is a bit better at managing simultaneous inputs. Nonetheless applying some delay cards will make the issue go away completely.



I’m having some similar issues, but only in flows. I have one where a Z-wave switch activates a flow that controls a roller blind.

If I use the test buttons in the flow, it is almost instantly closes the roller blind, but if I use the device control it takes 3-5 seconds.
If I use the switch, it can take up to 10 seconds before anything happens. Very strange.

1 Like

Using the test button is triggering the flow directly → you bypass the original trigger, the z-wave switch, that way;
So you should try to discover the delay somewhere in your z-wave switch, or zwave mesh I think.

Is there any way to test button latency?
It triggers a lamp after less than a second, but that’s through z-wave associations.

Could it be that the new Homey really is that slow? 5+ seconds to activate a flow externally?

I tested by adding just a push notification to button 3.
It takes 10 seconds from pushing the button until receiving the push message.

Is there a problem with z-wave? I have used insecure mode to try to have it as uncluttered as possible. And I don’t have a lot of devices, and most are 230V devices, just a handful of battery devices.

A probable error in my case was actually one of the buttons on a device. For some reason only that single button made it slower. Still a bit lag on the z-wave network, especially with “All lights off”, that can take anything from 5-30 seconds before all lights are off.

I received some tips from Athom yesterday on how flows work. Maybe it will help you. Since you are using advanced flows, bear this in mind.

  • In normal flows the entire “Then” block of flow cards is fired as fast as possible. So if you need to have a certain order to your commands you have to use delay blocks in normal flows to guarantee the right order.

  • In advanced flows flow cards are always fired sequentially if the flow is constructed that way (which is different from normal flows). The flow will only go to the next flow card if the current flow card has finished executing.
    When sending a command to multiple devices it is recommended to add delay blocks. The delay card is not necessary between system cards (since there is no command sent to a device).
    Even in the case of sending a command to multiple devices, you could probably group them together with 10 calls at the same time then 1 second delay. then another group of 10 etc.

Following this advice, I imagine you have more success with the following examples, assuming you do not really care if all happen exactly at once.
Note I have added error connectors, just in case one fails, it will move to the next.