OOMI Mote switch cannot be added

Hi, I’m new to Homey Pro. Wanted to migrate from my existing z-wave network, but I met a problem at the beginning: I have several OOMI Mote switches:

They are probably just rebranded Aeotec ones:

They cannot be added to Homey Pro. Even as a generic z-wave device.

I get an error: "Something went wrong while adding the device: unknown command class ‘254’ "
This happens when I try to add it using Homey or Aeotec apps. OOMI app does not support (and probably never will) Homey Pro.

So what can I do now. Is it a bug in Homey? Can I code some app myself? (Do not know how yet). Any other possibility?



You can ask in this thread, if someone is willing to write a new OOMI app.

Also read this thread. Maybe the user can help you out.

Thanks. Probably I’ll try to create an app. But I am soooo frustrated. I waited half year to get something that is not able to do even the basic things. I have Fibaro HC2 and it works for years without problems. It just became a bit obsolete. And now a new shiny Homey Pro is not even able to work with basic z-wave devices … and I read the posts that z-wave network is just unreliable with Homey. Is there anyone who has a lot of devices and everything works fine?

So you joined a week ago, and you already know it’s a piece of junk (I don’t say it’s perfect).
Yes, some users have issues with it.
And in some cases the problem is not the mesh, but the user('s ignorance).

The users who don’t have issues, don’t post a message about it here.
Did you ever read a post like;
Hey, I’m very happy, that’s because of the reliable zwave network. Even my wife came back home.
Anyone with similar issues?

Never heard or read about OOMI by the way. Why do you buy that in the 1st place.

Do you really ask such inteligent question? Congratulations. But I will answer: I tried different switches, this is by far the best and most elegant. And it works with pieces of non-junk.

Jarda had these OOMI Z-Wave switches used with his old system and then he switched over to Homey.

And because there is a OOMI App already available I can understand his frustration. The problem with this app is, that it’s not supported by the HP23.

Thank you, fantross :slight_smile: Looks like this OOMI app is dead (not supported anymore). Does anyone know … is it possible to “hack” it somehow and update it for HP23? Or use it as an inspiration and be able to easily create a new one?

As I wrote already in post #2.
“Hacking” the app or the code is not allowed. You can program a new app (based on the existing app) and make it available in the App Store (over Athom). You can also use the code privately, reprogram it for your needs and install it via CLI on your homey.

This is the code from the OOMI app:

Thanks for the link! So probably I’ll try to modify this app so that it works with HP23

So I played with it. And my result is: Homey Pro is a buggy thing. The documentation says: " All Z-Wave devices are paired using the built-in Z-Wave pair wizard. Upon pairing a Z-Wave device, an App will be selected if all three IDs match."
So first the internal pair wizard tries to pair the device and then your driver / app would be called. But the wizard itself crashes with the stupid error “unknown command class 254”. The command class 254 is a normal thing, it’s a vendor specific command class … and the built-in basic pair wizard should just ignore it. Instead, it crashes and the driver is never called :frowning: :frowning: :frowning: So you cannot do anything.

I have no problems with that at all, never. It works flawlessly. On my HP19 and HP23.
Have you restarted the homey and tried again?
Can you please share more information?

Hi, you have the same switches? I have four of them … and they simply cannot be added to Homey Pro 2023. And because of the described behaviour, I cannot write a driver.

Of course I tried to restart Homey. I also reset it to factory settings. Still the same problem.

I guess there is a misunderstanding. I have never had such problems with the pairing Wizard, but I only use devices that are compatible with Homey and the corresponding apps. So no, I don’t have these OOMI switches.

I spoke with an employee of Aeotec. He said that it should theoretically be possible to install the firmware from the Aeotec WallMote Quad on the OOMI devices. Then the OOMI devices would work with the Homey Aeotec App. However, for this you need a Z-Wave controller that can be used to perform firmware updates, e.g. an Aeotec Z-Stick. This is not possible directly with Homey.

Another option would be, you tell me the device IDs of the OOMI devices, I give them to the Aeotec employee and he updates the Homey Aeotec App so that the OOMI devices are recognized by the App.
To find out which device ID these devices use, you have to include the devices (or only one device) as a generic Z-Wave device.
Add new device → Homey → Z-Wave
If that was successful, you can find the device ID in the devices section of Developer Tools.
Search for this device and note the device ID (zw_product_id):

Your choice.

Thank you. But the problem is that Homey Pro wizzard is not able to add this device. Even as a generic one. And no one can write a driver. Because the driver is called AFTER the wizzard … which crashes.

So there are two possibilities: Either Athom fixes this bug … or … .I try to update the firmware of the switch. I have Fibaro 2 and the switches work with it without any problem. So maybe I could use the Fibaro to update the firmware? Not sure how to do it … because it looks automatically for the correct firmware updates for the devices … not some firmware from other brands.

Using the info from the old driver, the ids of the switch should be as follows:

"zwave": {
    "manufacturerId": 362,
    "productTypeId": [
    "productId": [
    "zwaveAllianceProductId": 2153,

How do you try to add devices? With the Homey smartphone app, or with the WebApp?
If you use the smartphone app, did you checked already if there is a new app version available? Other suggestion is to delete the smartphone app and install it again.
As I wrote before, I had never such problems with the pairing wizard and it’s also the first time to hear this. And I’m active in this forum since 2019.
But of course, if it’s a bug please report it Athom via support ticket.

I own a HC2 myself, but I don’t think you can update non-Fibaro devices with it.

The Aeotec employee has published a test version of the Aeotec app where he added the IDs of the OOMI switches. So please install this app version via web browser and try to include the OOMI switches.

If there’s something that doesn’t work as it should, please inform the Aeotec support.

Of course, if the pairing wizard still crashes via smartphone app and WebApp, you have to wait for an answer of the Athom support.

Thanks. I tried this app, but it is the same. As I said, the wizzard throws the error before the driver is called. The behaviour is the same when I use the mobile app or the web app. I’m pretty sure it is a bug in Homey Pro. I wrote to Athom support some time ago, no answer yet. I’ll let you know if / when they answer or a solution is found … So far, I stick with Fibaro 2 and Homey Pro is just sleeping on the shelf :frowning:

Which Homey firmware is installed?

The last one 10.0.0-rc.122 … the behaviour is the same between updates. I hope they can fix it :frowning:

Any news? Because Aeotec has integrated the OOMI switches especially for you.

This is nice from them. However, I still think this is bug in Homey and no one can fix it on driver level. It crashes before the driver is called. Athom promised they would fix it … about 1 and half months ago … but they didn’t ( yet).