Homey Pro Device Addition Issues

I recently received my Homey Pro and have been working on migrating my z-wave devices to the Homey app. I’ve been excluding them one by one from my prior hub and then adding them through the mobile interface. Initially, I was able to add both Leviton z-wave devices (primarily dimmers) and Aeotec devices (recessed door sensors) without issue. I have a handful added. But now every device addition fails - either with an error message saying that the device wasn’t communicating any longer, or that there was some kind of z-wave error. But most often the app just hangs on the “please wait while your device is being added” screen and never resolves. I’m on release 10.0.0-rc.118 and have tried restarting the hub. Curious if anyone has seen this issue and whether there is a known solution for it?

Hub or Homey?
Take a look on developer interface, what it shows?


Hi, I had the same problem with Zwave, after the first few it was nearly impossible to add devices. My solution: hold the bottomside of the Homey on maximum of 10cm from the device.

Weird, if I would have to do that with my 20 ZWave wall installed Fibaro devices, I would be really unhappy

Within the Node library I see a bunch of unknown nodes entries piling up, and little else. I’ve seen some timeout message flash during the add process, but not every time. Mostly I see the please wait message that never clears, or sometimes a z-wave error like transmit_fail. I just got a Homey message the just said Could not reach the device anymore - please retry adding the device by holding it closer to Homey. But this is happening with a Aeotec door sensor that I’ve pulled and placed next to the hub, and it doesn’t seem to help.

While I would also be unhappy toting my hub around the house to associate all of my z-wave devices, I would do it if it worked. Unfortunately that doesn’t seem to help in my case. I can hold it right next to the device and I still cannot add a z-wave device to the network.

Maybe share screenshot … but doesn’t sound good.

Based on insufficient details, I would assume that your ZWave mesh got corrupted - maybe because in paralel you still had enabled former hub, not an expert here.
Last think I would probably suggest - was it working for you at least for a day? Do you have already flows in place or you just added devices? In first case, you can still try to restore backup (if you pay cloud backup option). In second case I would suggest to start from scratch while performing ZWave reset (on the dev. page) and when adding them, turn of the parallel hub (just for sure)

Thanks for the insight. I’ve dropped in a screenshot of current state, but not sure it tells us much. Have to say, I’ve delivered a lot of tech in my career and the Homey experience doesn’t measure up - even for a beta. Thank goodness for the community. I’m at a point where starting from scratch is likely the right option.

OK, that’s a “nightmare” view.

Please first of all, submit bug report to Athom via form, something like that can’t happen again.
They will not reply to you but they will take a look and eventually fix the code/issue itself and prevent from reoccurring.

Then :

  • try to physically identify those Unknown nodes devices → are you able to repair them using maintenance option in the app ? If so, try to repair and then check the view
    As some point of time the situation might get stabilized, keep refreshing the view. If not, proceed next.
  • if you are not able to repair them, remove all Unknown nodes via Homey Developer Tools via button REMOVE UNKNOWN NODES
    As some point of time the situation might get stabilized, keep refreshing the view. If not, proceed next.
  • if needed, press it repeatedly until all UNKNOWN nodes disappear
  • restart your Homey (might be not required but I would do it)
  • re-add missing devices and fix your flows ;-(

Also please note of new firmware just released - Homey Pro (Early 2023) Changelog | Homey

Several Z-Wave related changes… (not sure it help but probably nothing to loose).

You must have experimental updates allowed - https://tools.developer.homey.app/tools/settings


    Fixes an issue where multiple Z-Wave backups were made.
    Update firmware of Z-Wave to the latest version.
    Clarified Z-Wave error messages to explain the actual problem to the user.
    Notify user if a device is very "chatty" on the Z-Wave network.

Wow - thanks for the insight. nightmare is how it feels. :-). I was unable to repair the unknown nodes and the tools you pictured didn’t seem to do anything for me. So I reset the z-wave network - I hadn’t added any flows as of yet so really just re-adding the devices. I also updated to the latest firmware - thanks for the heads up on that. Started re-adding my Leviton z-wave dimmers and switches and for the first few devices they have been quickly recognized and associated. So far so good but will update if things go south again as I add more.

could you elaborate on what you mean here? The unknown nodes don’t appear in the app as a device, and I haven’t been able to find a maintenance option. I have validated that the ‘heal’ option in the z-wave developer tools console will highlight the route, but doesn’t provide any other benefit.

But if you started from scratch, it’s irrelevant, or ?
I keep fingers crossed that such disaster will not happen with your Z-Wave anymore…

Thanks. I’m trying to avoid future disasters. Received feedback from support that I should remove unknown nodes before attempting another pair. So basically doing one at a time, and when I get a failure I stop and wait to see if it shows up as an unknown node (seems to take a few min), then work on removing it. Because it is reachable, it you can’t simply remove it by testing it first and then removing it. I’m forced to remove power from the device to make it unreachable, test it, and then remove it. Kind of a pain.

Were you able to solve this? I’m experiencing similar issues; I was able to easily add Leviton devices but as my device list grows it’s becoming more and more difficult to get inclusion to work.

In my mesh I see that every Leviton device shows a lot of Rx’s. Too many IMO for a simple ON-OFF switch. I suspect that is blocking the network and making inclusions timeout. I may exclude and include as generic zwave devices instead and see what happens then. But first I wanted to check if you ever solved your issue?

For those in similar situation, I solved my issue by changing all of my Leviton wall switches from the Leviton App to the Generic Zwave App. When they were included with the Leviton app they were flooding my network with traffic, making it very unstable. As soon as I removed them and reincluded them as a generic zwave device all was fine.

Adding on more finding of the similar topic.
Changing all my devices from Homey 2019 to 2023. After approx. 100 devices I had it several times that Unknown Nodes occurred. Was able to delete them with „the three dots“ => test => remove sequence. Still for three it did not work out.

Now it‘s gone mad. Was trying to add two Eurotronic Spirits and both totally refuse to pair with. After several tries I found 9 Unknown Nodes in the Dev-Tools. Procedures as above did not work, as Homey shows them as „reachable“ when I use Test. Fun Fact: the Spirits are lying beside my desk without batteries. For sure they are not reachable.

Also using the function „remove unknown nodes“ does not work, as well as restarting Homey.

Any suggestions? Especially that Homey shows devices without battery as „reachable“ sound interesting to me.

Update: after countless attempts of removing the unknown nodes, I disconnected Homey and rebooted after 10min. Same status. But after some more attempts I was able to connect the two Spirits. Still the unknown nodes are there, still they are „reachable“ even though the IDs are for sure not used, as the two Spirits have 116 and 119.

…contact Athom support, generate several System diags and attach it to tickets. This is definitively not normal.
Just to be sure, on latest firmware, correct ?

Thanks @Sharkys
Yes - Homey 2013 is running on latest firmware 10.2.1
After one day I tried again - still same behaviour.

I still have Homey 2019 running, which is now stripped of almost all devices. I tried to regular unpair all of them, still I have 23 unknown nodes also there. And - fun fact - the 2019 has the same behaviour as my 2023. Those devices are definitely not paired anymore to Homey 2019. I did a reset on all of them and paired them to the new Homey 2023. Still Homey 2019 claims to reach them => I cannot remove the unknown nodes.

Maybe bad vibes in my house :smiley:

Will open a ticket at Athom as you suggested.