Extremely difficult to add Z-Wave devices

I’ve brought my Homey Pro online this weekend and when trying to add my final Z-Wave devices, it became nearly impossible to add them.

For each device I tried to add, several attempts failed with device not found, device not in range (even when placed directly next to my Homey Pro), or similar failures. I’m currently wondering if the amount of Z-wave Devices has any impact on adding new Z-wave devices. I currently have 35 devices added to my network. I still need to add 4 more to it (waiting for some new CR2 batteries to arrive before I can add them). Furthermore for several devices, not everything worked right away, so I was forced to reinclude them into the network.

Adding the devices was quite frustrating, since it takes several tries of adding, removing (due to Homey not being able to add the device) and occasionally resetting the device (to see if that fixes things), before the device has been added to my Homey

I have no idea what the issue is, if this is an indication of a problem which will get worse in time, or something else. Fortunately everything works right now (more or less), but still I’m quite concerned.

The amount shouldn’t be a problem:

Perhaps someone with a lot of Z-Wave devices can get you on track.

I have in excess of 70 z-wave devices with a “normal” Homey and not the Pro version.
There are people with much more than 100 z-wave devices around here.

It could be that your Homey is busy trying to creates routes, perhaps let it breath for a while.
You can also try cycle the power. A joke around here says unplug it for something like 11.2 minutes. I would have it off for at least 10 minutes then after power on wait at least 10 minutes, too.
Let us know how you go.

Try this.

  1. reset the device.
  2. exclude the devices. (even if the device has not yet been included in the Homey)
  3. include the device near the Homey.

I think I’ll do that once I get home. Any idea how long Homey needs to create routes? I did add a lot of devices all at once, so that might be it. Once I tried to include my device, Homey started the inclusion process inmediately (same went for excluding, devices were found nearly instantly), but trying to configure it took a while. Might be because Homey is busy with the network and/or dealing with all the other devices.

I did all the above (even including a devices right on top of my Homey), the inclusion process starts right away once I’ve put my device into inclusion mode. However finishing the inclusion process takes very long and is prone to the failures described in my fist post.

I would leave it for a while, maybe few hours. Once the routes are created they will pretty much stay like that unless you move your devices a lot.
You can also go to the dev tools here: https://developer.athom.com/tools/zwave
and once all your devices are added, start one by one (with great patient) to perform Heal. Note: battery devices can heal only if you wake them up just before you hit heal. All devices should be in their final location when performing Heal.

The key ingredient for a nice and stable mesh is to have as many as possible of mains powered z-wave devices. Those will create the routes.

Edit: also in my case and few other people case, the key ingredient for a solid z-wave network was to add an external antenna.

@danone, How do you add external antenna to Homey?



As per above reply.
Just keep in mind that your Homey warranty will be void 100%.

Yes, I’m aware of it. But it seems that results are worth it :grinning:. So far I have no issues with zwave signal, but I would like to place Homey to a cabinet and that may require this fine-tuning.

Left it for a day, then powered down my Homey for about 15 minutes and brought it back online. So far things are looking good, but I haven’t tried to add any new devices to my network.

Looking at the dev tools, I see a lot of Unknown node’s in my Z-wave list of devices. Should I be worried about that? I think it is all those devices that failed to be included and required multiple attempts.

Concerning the mesh, that should be good. My Homy is in a central location in my appartment, and it is surrounded by powered Z-wave switches (I also use a few extra switches for routing). As for adding an external antenna, I’d rather not void the warranty and I haven’t had any issues concerning range so far.

Mostly because of that indeed. You should be able to remove them by clicking on the 3 dots on the end of the line and select “remove”.

Therefore always use “Remove Z-Wave Device” in the Settings / Z-Wave section if an incusion process was unsuccessful.
Start the Exclusion process (remove Z-Wave device) and then start the inclusion / exclusion process on the device. This deletes the “unknown devices” and also resets the device. Thus, you can start another inclusion attempt because the device in the device list of homey deleted and the device is also reset.

Plz be aware that this only works when removed with another controller. When the device is added to Homey 1 and u remove it with Homey 2 then the device is resettled. When added to Homey 1 and removed with Homey 1 the device will not reset!

I can not confirm!
In my case the devices are resetet no matter if the are included in the same homey or comes from an other Gataway.
By the way, I delete in this way all Z-Wave devices from homey. And then they can all be included in the homey or other gataway again.

I’m unable to select the remove option, it is greyed out and I cannot select it… Do I have to wait a while for Homey to recognize the devices are indeed not there or is there anything else I need to do first? (like test, or send test frame) Also, is it a bad thing if those devices say within Homey (for either Homey, the Z-wave network, etc)?

If available, first use the “test” function. If i remember well it will say that it is unrechable and after that remove should be available.

1 Like

Weird, some nodes are still reachable according to my Homey. Considering I’m done adding Z-wave devices to the network, are there any disadvantages for leaving things just the way they are?

Then it looks like some of them are ghost connections to now successful added devices. Don’t know is that is possible, most of the time re-adding gives an error if the device is already known but pairing was unsuccessful.
The only times i experienced this was

  1. when i had reset a sensor without disconnecting it from my homey and it was still on
  2. I added a sensor to my test homey without proper disconnecting from my other Homey.