Exreme difficulties re-adding z-wave devices from fibaro

Hello.
The story. I was stupid enough to reset my whole z-wave network becasue i wanted to add the fibaro devices as unsecure to speed up the response. Therefor all devices has been successfully added before.

So after i did that i tried adding them again to Homey. Impossible…

Tried a lot of things…

Even tried to swap the homey for a brand new homey device.

Also when trying to re-add them to Homey i tried the following.

Reset the device to fabric settings > Exclude them from the z-wave network through settings > Including the device so that i get the first green check mark. Waiting 20-25 seconds before i use the include again to get the second check mark. After some time > Can’t add device, please try again later!!!

I have also tried to add it again as normal secure, but same message!

Tried on several fibaro devices. I only have fibaro z-wave devices. What the hell am i doing wrong?
Please someone call me stupid, because i feel like i have tried everything…

Vegard

Did you have your Homey close to the devices when adding?

Yes. 1 cm

Some days ago an other user had the same problem with an Aeotec door sensor.
The solution for him was, to lay the smartphone at a distance of about 2 meters far from Homey away while including the device.

Sorry. Tried now 3 meters away. Same results. Something wrong happened when adding the device. Please try again.

Tried a PTP alr?
And plz tell us what devices u have (just Fibaro is not enough) and what Homey version u are running (also here “latest version” is not enough)
.

Yes. I have tried to pull the plug on Homey and waited for 10 minutes. This is tried several times. I have also tried fabric reset of homey several times. Though the same result. Furtheremore i have also tried to PTP on the z-wave devices. I use Homey stable version 4.2.0. App version 6.1.0.633 if that helps?
It is fibaro dimmer 2 and fibaro motion sensor.

Did you try this on the Fibaro modules:

Reset

  1. Disconnect the power supply.
  2. Remove the device from the wall switch box.
  3. Connect the power supply.
  4. Locate the B-button on the housing.
  5. Press and hold the B-button for 3 seconds.
  6. After few seconds the device will be reset .

Hello. I don’t know this kind of reset. I have reset the device with holding the b button until the yellow light and then it turn red to confirm the reset. When powering on the z-wave device again. Should someone immidiatly press the b button (meaning you need to people). Or can i do this after i have turned on the power?

Also another theory. I don’t know z-wave network that well. Can it be that the other z-wave devices is constantly trying to reach the old homey and therefore interfare with the signal when adding?

I guess no, but I’m not sure.

Have you checked in Developer (https://developer.athom.com/tools/zwave) if all devices are really deleted?

When you do a fabric reset, there are no devices here :slight_smile:

Here is the z-wave log if that tells you anything?

2020-09-27T12:32:51.862Z Command[136] start: removeNode
2020-09-27T12:32:51.875Z Command[136] status: removeNode, status: REMOVE_NODE_STATUS_LEARN_READY
2020-09-27T12:33:03.606Z Command[136] status: removeNode, status: REMOVE_NODE_STATUS_NODE_FOUND
2020-09-27T12:33:05.637Z Command[136] status: removeNode, status: REMOVE_NODE_STATUS_REMOVING_SLAVE
2020-09-27T12:33:05.643Z Command[136] status: removeNode, status: REMOVE_NODE_STATUS_DONE
2020-09-27T12:33:05.646Z Command[136] end: removeNode
2020-09-27T12:33:05.653Z Command[137] start: addNode
2020-09-27T12:33:05.663Z Command[137] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
2020-09-27T12:33:45.081Z Command[137] status: addNode, status: ADD_NODE_STATUS_NODE_FOUND
2020-09-27T12:33:52.234Z Command[137] status: addNode, status: ADD_NODE_STATUS_FAILED
2020-09-27T12:33:52.234Z ProcessAddNode[115]: Error: ADD_NODE_STATUS_FAILED
2020-09-27T12:33:52.237Z Command[137] end: addNode

@Caseda, maybe you can help?

Yes please @Caseda

I had serious problem re-adding my FGS-222 relay switches. The reset mentioned above by @Jo_San helped, and I did the inclusion procedure multiple times till it succeeded.

the dimmer 2 needs several seconds between step 1 (device reset) and step 2 (device inclusion) of the inclusion steps as it needs to finish an calibration run after a reset (it does the same after inclusion).
So wait at least 10 seconds between step 1 and step 2, might need even more time, but I think 10 is enough.

As for the motion sensor, that should just work if you do step 2 shortly/directly after step 1, but might be needed to also wait so it is asleep again after its reset.

1 Like

Thanks for your help!

Hello @Caseda
A little update. I was able to add several z-wave units following your method. Though i still get that message on some dimmer 2 and switch 2. With error message: Something went wrong, please try again. It seems to work fine. After the 1 exclusion it calibrates as you mention. It takes about 15 seconds to complete. After the second green check mark, everything seems to be fine for a few seconds. Then the error message appears. I have only tried the hold in until yellow light and then click B button once to reset the dimmer 2. Should i then try (turn of the fuse) and then hold the b button for 3 seconds reset? Are there any difference on these two types of reset?

if you don’t mind the dimmer being included unsecure, then try that by choosing one of the Walli devices for pairing (doesn’t matter which one), don’t worry it will still be included as a dimmer 2, but it just takes over the forced unsecure inclusion. (the same goes for the motion sensor(s) btw).
Including it unsecure makes the amount of data being send back and forth a lot less, making it less prone to fail.

as for the reset, the dimmer 2 only has 1 hardware wise reset (holding the b-button until the yellow LED), the “power off” procedure is the same procedure, but just with a power cycle before hand.