Fibaro devices not pairing with Homey

I"m facing a problem with pairing these FIBARO devices with Homey:

  • Flood sensor FGFS-101
    I’ve tried everything (reboot, fibaro app updates and restart, removing devices and reinstalling them, short distance btw. device and Homey)
    I’m still waiting for a solution and every check after Homey-Update costs a lot of time and I’m frustrated with this homey patchy product. Such kind of basics must work without questions!!! :rage:

Homey Firmware Version: 1.5.12
Fibaro v1.5.18


Sorry to hear you’re having issues with pairing these devices…

Can you indicate a bit more based what error message / observation you see when pairing fails?

Some suggestions:

Did you already try to remove the device first (through settings > Z-wave > remove device > triple press the B-button on the device / S1 button connected to it)? It might be that the inclusion was aborted while the device thinks it is included.

Did you try to include these devices at short distance of Homey; moving Homey to the intended usage area of the devices?
Homey does not support inclusion / pairing over the network.

Hi TedTolboom,
yes, all what you mentioned in your questions was done and close to homey.

I got these errors:

  • something went wrong
  • device not found
  • device.drivers.zwavebasic.pair.request_timeout
  • etc…


Ive got same problems. Trying to pair a FGS-212 relay switch and a FGMS-001 motion detector. Both are Fibaro. Doesnt get any error messages. It just doesnt find them. Restarted the app and the Homey, but no go? Ive got a mesh network in my house with good coverage.
Any good idea`s??
Can mention that my Nexa switches has paired ok.

@Jossi1973 I can share my experience with both units.

As Tedtolboom wrote above, you must first exclude those units before an attempt to include them. If for any reason during the inclusion process things get stuck, then go again through the exclusion process before attempting another inclusion of that particular unit.

FGS-212, for some reason I had to factory reset this one as it did never manage to exclude using the triple click of the B button. The manual has a very ambiguous translation (at least the English part) when explains how to factory reset. In essence you must hold down the B button and then apply power. Keep holding the button for like 4-5 seconds after power applied. Then disconnect the power. Put Homey into inclusion (add new device etc…) then apply power to the FGS-212. No need to triple click the B button, soon as after you apply power Homey will find the FGS-212. Basically this guy if factory reset and power on, it goes straight on into autoinclusion process. From the moment you apply power to it you have 30 seconds to get Homey into inclusion so that’s why I said first get Homey to look for the device then apply power to FGS-212.
As per @TedTolboom , post Homey does not support network wide inclusion so it is a must that you either bring the z-wave device close to Homey or viceversa.

FGMS-001 exclude first. It is only done when you get the message that it has been excluded. Bring this one close to Homey and triple click fast the B button when prompted.
Then include the unit and my suggestion is to select Z-Wave and not actually the Fibaro app and the device itself. In this way you are sure that Homey will find the right unit as FGMS-001 has a couple of options.

Initially I had similar issues like yourself but the above worked well for me, hope this helps you. :slightly_smiling_face:

1 Like

Thank’s for good tip. I will try the things you say. Can I exclude devices when they are not found in homey app on computer? I have tilted the homy upside down once, to reset it, but still not able to pair the fibaro devices.

Resetting Homey is one thing and excluding devices another.
No matter that Homey is reset. If a device has been included in any controller like Homey, Vera etc, it needs to be excluded first. The exclusion does not has to be done with the same controller that was used for inclusion.
Even brand new z-wave devices I found that sometimes were included in the factory perhaps because some random batch testing and they would not include in my controller before excluded first.

So rule of thumb, always perform exclusion before attempting any inclusion of a z-wave :grinning:


Ok. Thank’s again. I will try your advice👍

thx danone for your advice but still not working.
I sent the sensors back to the dealer and i bought 2 new ones FGFS_101_v2_1 and I"m still having the same problem.
I opened an Issue in the Fibaro forum:

I hope somebody can help…