Homey Community Forum

Can't add Fibaro Relay Switch FGS-212 to the Homey 2.0

Hi everybody,

I’m trying to add Fibaro Relay Switch FGS-212 to my Homey 2.0 but it tell me that it’s unknown device and add it as Basic Z-Wave device. Is it known problem, does anybody have the same?


Remove it first with
in https://developer.athom.com/tools/zwave

even when it has never been included!

It works here fine with the latest Fibaro beta 2.1.11 and Homey v2 rc11. I have a whole bunch of them.
If you have managed to include it (even as a basic z-wave device) means that it was excluded before, which is good.

Have you got this working before with Homey 1.5.13? Or is this the very first time you try including a FGS-212?

This is the first time I’m trying 212. I have the same latest versions of software as you. All previously (1.5.13) installed Fibaro devices is also working well, the problem is to add new.

I’ve tried to remove it and to add it several times. It removes successfully. When I’m removing it the Homey showing me the exact Fibaro picture of device, but it can’t add it as Fibaro device.

Did you try resetting the device as well (though in this case I doubt it would matter). Could you post a screenshot of the device-info (hardware-id, software-id, manufacturer-id etc) after it was included as a basic device?

Yes, I’ve tried factory reset too.

That is not clear which option is to use in fibaro but looks like it sould be Relay Switch 2 and it also doesn’t work.

Can you try one more thing? When add device and asks you to “Pick a brand”, don’t select Fibaro, just select Homey and then z-wave. Click Install and put your device to inclusion mode.
Let us know the result…

But first delete the device from Homey and reset the device…

Sure, forgotten that, thanks @bvdbos

Also @Alik_Tabunov after inclusion as z-wave basic, please post a screenshot from your smartphone Advanced Settings of that device.

Added as a basic device

Ah, now it starts to make sense. The Product-ID 16386 is not in the list:

Could you file a request at https://github.com/athombv/com.fibaro/issues including the last picture?

1 Like

Looks like I can’t:

This repo “https://github.com/athombv/homey/issues” is readonly so I also can’t add something.

Perhaps same problems I had few years back with my Australian frequency z-wave products…
Missing Product ID’s.

Since the new firmware, I think you file the issue here: https://support.athom.com/hc/en-us/requests/new
Haven’t use this, thought…

Thanks a lot for assistance, I’ve dropped message to Athom support.

If you know how to install an app through the CLI, you could also alter the app yourself and add the correct product-Id for your device…


I have the same issues trying to install Fibaros Smoke and Flood detectors. I get the same “unknown device” message followed by a basic zwave installment which does not work.

Can it be the same issue?

I have other Fibaro items and they work fine.

Probably yes so if you add additional sets of data it will be easy for Athom to add those to the app. Instead of creating issues at the repository, if you know how to work with Git, you could also create PR’s for Athom…