Beginner with first app

Hi, I have a Minimote fob controller (z-wave) which I’m trying to get working via my first ever app.

I’ve managed to get the app running and have paired the Minimote via the app. I have set up a flow which currently just has homey talk if a button is pressed.

I can see button presses in the log file from the divice as COMMAND_CLASS_SCENE_ACTIVATION logs.

However the device is showing up as offline and the app is not responding to the button presses.

Any tips on how to debug this?

Ok, I got passed the offline issue (turn it off and on again).

Now to debug why the app does not do the flow.

All working once I had registerReportListener listening to the right stuff :slight_smile:


Well done!

If you are running into issues with developing an app; you’re able to get almost instant support at Slack in the #developers channel

1 Like

Hi @Tiggerito, I am a new user to homey and I also got the minimote.
I was surprised it is not supported in the aeotec app yet…
Is your app ready and can I use it as well?

I’ve just made my Homey apps public. Hopefully the aeotec one will work for you.

It works great!
Thank you very much!

1 Like

I got the message: Could not find a valid Homey App at …

This are the files:
8 -rwxr-xr-x@ 1 ivo staff 4 8 jun 23:59 .gitignore
8 -rwxr-xr-x@ 1 ivo staff 481 8 jun 23:59
0 drwxr-xr-x@ 12 ivo staff 384 8 jun 23:59
0 drwxr-xr-x@ 12 ivo staff 384 8 jun 23:59
0 drwxr-xr-x@ 10 ivo staff 320 8 jun 23:59
0 drwxr-xr-x@ 13 ivo staff 416 8 jun 23:59

Is this compatible for the latest firmware? I’m using a Mac to install.

I bought an Athom Homey to replace the Domoticz on Raspberry so no more linux and installs more in the backend. Is there an other way to get the Minimote remote control to work?

There are four app directories there. If you want to install a specific app, cd into the correct directory first.

For instance:

athom app run
1 Like

just wanted to delete my reply by browsing the directory’s. ;-).
Installation succesful. Thanks

1 Like

Thanks @robertklep.

Glad it worked.

If i connect the minimote I got a message: already…added
What’s wrong? Minimote type:DSA03202w-ZWEU

I don’t see the device. Ofcourse i unpaired it first from the old device. I even tryed a hard reset.
Pairing again with the old Zwave stick is no problem.

I hope someone can help to connect this device?

FIRST unpair on Homey, yes, even when it has never been paired with Homey! And always pair and unpair close to Homey.

1 Like

thanks that did the trick. Minimote working 100%.

1 Like

The minimote button 1 long and short press works fine. The other buttons only works the long press.
What’s wrong?
Is there something I can check?

Unpairing and removing by the zwave device did not help.

I just tested mine and two short press buttons I’d set up were fine.

You could try the scene activated trigger. I just set it up for Homey to say the scene and all buttons worked fine.

After that, it may need debugging the driver code.

I tested it and I got response on every 4 buttons n short and long press.
Can I help and give you information about what codes are sent?

I’m busy for the weekend so probably won’t get a chance to look at it.

From a quick look at the driver its listening for a SCENE_ACTIVATION, SCENE_ACTIVATION_SET then checking “Scene ID” which is a number from 1 to 8.

oke, let me know I can test something. Greetings