Trouble pairing the Aeotec Smart Switches in Australia

Hi Tony,

I wonder if you can help - my new Homey arrived this week and I am having trouble pairing the Aeotec Smart Switches with it (I have about 6 of them).

I have downloaded the Aeotec App, and it shows the switch there as a device - I select the Smart Switch, and it then says to put the switch in to learning mode. I then press the action button once and it starts flashing green - however the Homey doesn’t seem to be picking it up.

What am I doing wrong? Any help is appreciated.

I am in Australia if that makes any difference.


How close is the switch to Homey, I found they had to be within 10cm of the homey unit to be found and included

Also, if you havent already, switch to the beta Aeotec app in the app store, it has better support for AU/NZ device types.

Also check if your homey has the correct zwave chip (region) inside, you can see this on the developer pages under hardware region.
If not, you should take contact with

1 Like

@DanR I Split your post as it doesn’t have anything to do with @Tony_Burn 's Initial Question.
Please keep topic’s on topic :wink:

And Now I see you already created a post with the same question, Please don’t double-post!
Before posting, please check the forum rules/guidelines
Your other Post is deleted!

Thanks Tony - that worked perfectly. I put the switch next to the Homey and it paired first time.

The trouble I have now is that I can’t get Homey to control the switch when I put it back in the socket which is only 5m away in the same room… it can control it when I have the switch right next to the Homey, but not once I move it.

Hi @DanR is the switch the first device you have added?

If so I suggest that you leave it close to the homey, say 1-2 meters. Then add in the other switches. You will find that the switch that is closest to Homey will function as a repeater and give out a stronger signal to all other devices, or so I have found.

Thanks Tony, but I haven’t had any luck trying that approach. I have tried connecting a few switches and a range extender - the range limit seems to be less than a meter from the Homey.

I am starting to wonder if my Homey is a dud and needs sending back.

All the other devices have connected perfectly and smoothly - but none of the Z Wave devices have any range more than a meter.

Hi Caseda,

I checked it out and the Hardware region is “AH” and the software region is “ANZ”.

Not sure where AH is, and if that is potentially the issue?


You’ve got the right z-wave frequency AUS/NZ else, you would not have been able to include the devices.
1m range only on a mains powered device? Strange, unless something is really jamming the z-wave frequency, your Homey is having indeed a problem.

Cheers Danone

I am starting to think the Homey has an issue - having no range doesn’t make sense. There are no other Z Wave devices or controllers running in the house, so the frequency shouldn’t be jammed.

I have logged a support call with Athom and will post their response once I get it.


1 Like

I am in Australia as well, lucky us :slight_smile: Changing to the BETA Aeotec app solved my pairing problems for the Wallmate Quad Switch and some Smart Switches.

As ALWAYS with Aeotec products I find you need to factory default them after every failed pairing attempt, dont just keep trying to pair failure after failure.

Working on the Smart Sensor 6 this weekend, fingers crossed.